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AVANQUEST END USER’S LICENSE AGREEMENT

The software that is subject to this End User’s License Agreement (EULA) is licensed, not sold, to the Licensee by 
Avanquest USA.

IF LICENSEE DOES NOT AGREE TO ALL OF THE TERMS AND CONDITIONS OF THIS EULA, THEN 
WITHIN 30 CALENDAR DAYS AFTER ACQUIRING THE LICENSED SOFTWARE, LICENSEE MAY 
RETURN IT TO THE PLACE WHERE LICENSEE OBTAINED IT FOR A FULL REFUND (LESS, IF 
APPLICABLE, SHIPPING, HANDLING, AND ANY TAXES), BUT ONLY IF LICENSEE HAS NOT 
INSTALLED, ACCESSED, OR USED THE LICENSED SOFTWARE.

Installing, copying, accessing, or using the Licensed Software constitutes Licensee's acceptance of, and promise to 
comply with, all of the terms and conditions of this EULA.

LICENSE TERMS

CONTENTS.
The “Licensed Software” includes all of the contents of the files, disk(s), CD-ROM(s), DVDs, or other media for 
which this EULA is provided, including:

(1) third-party computer information or software that Avanquest USA has licensed for inclusion in the Licensed 
Software;

(2) written materials or files relating to the Licensed Software (“Documentation”);

(3) fonts; and

(4) upgrades, modified versions, updates, additions, and copies of the Licensed Software, if any (collectively, 
“Updates”).

INSTALLATION.
Licensee may install one copy of the Licensed Software on a single computer. If Licensed Software includes 
multiple licenses, Licensee may install the number of copies licensed to Licensee by Avanquest. Licensee shall be 
solely responsible for all expenses incurred in Licensee’s installation of the Licensed Software.

ACTIVATION.
The Licensed Software contains technological measures that are designed to prevent its unlicensed or illegal use. 
The Licensed Software may contain enforcement technology that limits Licensee’s ability to install and uninstall 
the Licensed Software on a machine to no more than a finite number of times, and for a finite number of machines. 

The Licensed Software may require activation as explained during installation and in the Documentation. If any 
such applicable activation procedure(s) is not followed, then the Licensed Software may only operate for a finite 
period of time. If activation is required, and not completed within the finite period of time set forth in the 
Documentation and explained during installation, then the Licensed Software will cease to function until activation 
has been completed, at which time functionality will be restored. If Licensee has any problem with the activation 
process, Licensee should contact Avanquest USA customer support.

COPIES.
Licensee may make one copy of the Licensed Software for backup or archival purposes only, except that the 
Documentation may not be duplicated.

TRANSFER.
Licensee may not sell, assign, or transfer the Licensed Software or the License granted by this EULA without prior 
written consent of Avanquest USA.
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USE.
The License granted by this EULA is non-exclusive.

PROHIBITED USES.
(1) Licensee may not modify, adapt, translate, sublicense, rent, lease, or loan all or any portion of the Licensed 

Software or Documentation;

(2) Licensee may not create any derivative works from all or any portion of the Licensed Software or 
Documentation;

(3) Licensee may not reverse-engineer, decompile, disassemble, or otherwise attempt to discover the source code 
of the Licensed Software except, and then: only to the extent expressly permitted by applicable law; after 
notification to Avanquest USA; upon payment of a reasonable fee; and execution of a confidentiality 
agreement to protect the code from disclosure to any third parties;

(4) Licensee may not use a previous version of the Licensed Software after receiving a media replacement or 
upgraded version as a replacement to a prior version (in such case you must destroy the prior version);

(5) Licensee may not use the Licensed Software in the operation of aircraft, ship, nuclear facilities, life-support 
machines, communication systems, or any other equipment in which the failure of the software could lead to 
personal injury, death, or environmental damage;

(6) Licensee may not remove or obscure Avanquest USA’s copyright or trademark notices, or the copyright and 
trademark notices of third parties that Avanquest USA has included in the Licensed Software or 
Documentation; and

(7) Licensee may not use the Licensed Software to host applications for third parties, as part of a facility 
management, timesharing, service provider, or service bureau arrangement; and

(8) Licensee may not use the Licensed Software in any manner not authorized by this EULA.

CONTENT.
Licensee may use any clipart, photographs, icons, fonts, shapes, animations, sounds, music, video clips, and all 
other graphic content (collectively, “Content”) included with the Licensed Software, if any, only as stated in the 
Documentation. If the Documentation does not permit Licensee to use the Content, then Licensee may not display, 
modify, reproduce, or distribute any of the Content; and even if the Documentation permits Licensee to use the 
Content, Licensee may not distribute the Content on a stand-alone basis such as where the Content constitutes the 
primary value of whatever Licensee is distributing.

Certain portions of the Content may consist of the copyrights, trademarks, service marks, trade names, or other 
intellectual property of third parties. Avanquest USA has provided these portions of the Content for Licensees’ 
convenience in using the Licensed Software, pursuant to authorization of their owners. Except for this limited use, 
Licensee may not use any third-party intellectual property identified as belonging to others without the owners’ 
express authorization. Furthermore:

(1) Licensee may not sell, license, distribute (commercially or otherwise), or make available the Content as stand-
alone images or sounds, or in catalogs, design books, compilations, collections, templates, designs, stock 
engravings, products, services, or the like;

(2) Licensee may not sell, license, distribute (commercially or otherwise), or make available electronic copies of 
the Content to third parties in any manner, including without limitation, via the Internet, on any tangible media 
or by broadcast, that is intended or designed to enable a third party to copy the Content for its own use;
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(3) Licensee may not sell, license, distribute (commercially or otherwise), or make available electronic copies of 
the Content that includes representations of identifiable individuals, governments, logos, initials, emblems, 
trademarks, or entities that expresses or implies any endorsement or association with any product, service, 
entity, or activity; and

(4) Under no circumstances may the Content be used in the production of defamatory, fraudulent, infringing, 
lewd, obscene, or pornographic material, or in any otherwise illegal manner.

Licensee is solely responsible for Licensee’s use of the Content. Licensee may only use the Content responsibly, in 
a manner consistent with the exercise of good judgment. If Licensee is having difficulty deciding whether 
Licensee’s intended use is appropriate, or whether Licensee needs written permission, or whether other legal issues 
should be considered, Avanquest USA strongly encourages Licensee to seek competent legal counsel. Avanquest 
USA will not assist Licensee in making this determination, nor can Avanquest USA provide Licensee with legal 
advice as to intellectual property rights.

If Licensee or Licensee's attorney determines that Licensee is required by law to obtain written permission to use 
portions of the Content, Licensee must request permission for reproduction, redistribution, or modification of the 
Content from the appropriate owner of the subject materials (as may be cited in the Licensed Software). If, on the 
other hand, Licensee or Licensee's attorney determines it is permissible to proceed and include Content from the 
Licensed Software, Avanquest USA asks Licensee to correctly designate Avanquest USA’s trademark(s) when 
referring to the Licensed software in the notice or copyright portion of Licensee’s paper, project, or product.

Licensee shall indemnify, hold harmless, and defend Avanquest USA and Avanquest USA’s suppliers from all 
claims, damages, attorneys’ fees, costs, and lawsuits that arise from, or result from, Licensee’s use or distribution of 
Content.

SOFTWARE UPDATES.
If the Licensed Software is an Update to a previous version, Licensee must possess a valid License to the previous 
version. Any Update provided to Licensee is made on a License-exchange basis such that Licensee agrees, as a 
condition for receiving an Update, that Licensee will terminate all of Licensee’s rights to use any previous version 
of the Licensed Software. However, Licensee may continue to use the previous version only to assist in 
transitioning to the Updated version. Once an Update has been released, Avanquest USA may cease support for 
prior versions, without any notice to Licensee.

CONTENT UPDATES.
Avanquest USA provides updates to the content of some of its software from time to time, including but not limited 
to, virus definitions, URL lists, rules, and updated vulnerability data. These types of updates are collectively 
referred to as “Content Updates.” Licensee may obtain any such Content Updates during the initial period provided 
for by the applicable software without additional charge. Licensee may purchase a separate subscription for a 
specified period of time to continue to receive Content Updates after the initial period expires. Avanquest USA 
reserves the right to designate specified Content Updates as requiring purchase of a separate subscription at any 
time, and without prior notice to Licensee, except that any such change will only become effective at the earlier of 
the expiration of the initial period provided for by the applicable software, or the expiration of the term of a 
separately paid for subscription.

SUPPORT.
Avanquest USA is not obligated by this EULA to provide Licensee with any technical support services relating to 
the Licensed Software; however, Licensee may order additional support services for an additional charge as 
Avanquest USA may offer from time to time during the term of this EULA.
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LIMITED WARRANTY ON MEDIA.
Avanquest USA warrants that the media on which the Licensed Software is distributed will be free from defects for 
a period of 30 days from the date the Licensed Software is delivered to Licensee. If Licensee discovers a defect in 
the media during this 30-day period, Licensee must then return the defective media to Avanquest USA within 10 
calendar days of discovering the defect, and Licensee’s sole remedy is to have either the defective media replaced, 
or at Avanquest USA’s sole option, a refund of the money that Licensee paid for the Licensed Software.

NO WARRANTY ON LICENSED SOFTWARE.
The Licensed Software is provided to Licensee “AS IS.” Avanquest USA, and Avanquest USA’s suppliers, make no 
warranty as to its use or performance. AVANQUEST USA, AND AVANQUEST USA’S SUPPLIERS, MAKE NO 
WARRANTIES, CONDITIONS, REPRESENTATIONS, OR TERMS (EXPRESS OR IMPLIED WHETHER BY 
STATUTE, COMMON LAW, CUSTOM, USAGE, OR OTHERWISE) AS TO ANY MATTER INCLUDING 
WITHOUT LIMITATION NON-INFRINGEMENT OF THIRD-PARTY RIGHTS, MERCHANTABILITY, 
INTEGRATION, SATISFACTORY QUALITY, OR FITNESS FOR ANY PARTICULAR PURPOSE, EXCEPT 
FOR, AND TO THE EXTENT, THAT A WARRANTY MAY NOT BE EXCLUDED OR LIMITED BY 
APPLICABLE LAW IN LICENSEE’S JURISDICTION.

LIMITATION OF LIABILITY.
IN NO EVENT WILL AVANQUEST USA, OR AVANQUEST USA’S SUPPLIERS, BE LIABLE TO LICENSEE 
FOR ANY DAMAGES, CLAIMS, OR COSTS WHATSOEVER, OR FOR ANY CONSEQUENTIAL, 
INDIRECT, INCIDENTAL DAMAGES, OR ANY LOST PROFITS OR LOST SAVINGS, EVEN IF A 
REPRESENTATIVE OF AVANQUEST USA OR ONE OF AVANQUEST USA’S SUPPLIERS HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS, OR COSTS, OR FOR ANY 
CLAIM BY ANY THIRD PARTY. THESE LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT 
PERMITTED BY APPLICABLE LAW IN LICENSEE’S JURISDICTION. THE AGGREGATE LIABILITY OF 
AVANQUEST USA, AND AVANQUEST USA’S SUPPLIERS, UNDER OR IN CONNECTION WITH THIS 
EULA, SHALL BE LIMITED TO THE AMOUNT PAID FOR THE LICENSED SOFTWARE, IF ANY.

ADDITIONAL TERMS FOR BETA SOFTWARE.
If the Licensed Software that Licensee receives with this EULA is pre-commercial release or “BETA” software 
(“Pre-release Software”), then, to the extent that any provision in this section is in conflict with any other term or 
condition in this EULA, this section supersedes such conflicting term(s) and condition(s) as to the Pre-release 
Software, but only to the extent necessary to resolve the conflict.

Licensee acknowledges that the Pre-release Software does not represent the final product from Avanquest USA, 
and may contain bugs, errors, and other problems that could cause system or other failures and data loss. 
Consequently, Avanquest USA disclaims any warranty or liability obligations to Licensee of any kind whatsoever. 

IN APPLICABLE JURISDICTIONS WHERE LIABILITY CANNOT BE SO EXCLUDED FOR PRE-RELEASE 
SOFTWARE, BUT MAY BE LIMITED, AVANQUEST USA'S LIABILITY, AND THAT OF ITS SUPPLIERS, 
SHALL BE LIMITED TO THE TOTAL OF FIFTY DOLLARS (U.S. $50.00).

Licensee acknowledges that Avanquest USA has not promised or guaranteed to Licensee that the Pre-release 
Software will be announced or made available to anyone in the future, and that Avanquest USA has no express or 
implied obligation to Licensee to announce or introduce the Pre-release Software. Avanquest USA may decide not 
to introduce a product similar to, or compatible with, the Pre-release Software. Accordingly, Licensee 
acknowledges that any research or development that Licensee performs regarding the Pre-release Software, or any 
product associated with the Pre-release Software, is done entirely at Licensee’s own risk.

During the term of this EULA, if requested by Avanquest USA, Licensee will provide feedback to Avanquest USA 
regarding testing and use of the Pre-release Software, including error or bug reports.



DataBase Professional End User’s License Agreement   •   7

If Licensee has been provided the Pre-release Software pursuant to a separate written agreement, then Licensee’s 
use of the Pre-release Software is also governed by that agreement. Notwithstanding anything in this EULA to the 
contrary, if Licensee is located outside the United States, Licensee will return or destroy all unreleased versions of 
the Pre-release Software within 30 days of the completion of Licensee’s testing of the Pre-release Software if that 
date is earlier than the date scheduled for Avanquest USA’s first commercial shipment of the publicly released 
(commercial) Software.

SURVIVAL OF DISCLAIMERS.
The exclusions of warranties and liability limitations shall survive the termination of this EULA, howsoever 
caused; but this survival shall not imply or create any continued right to use the Licensed Software after termination 
of this EULA.

EXPORT RULES.
Licensee shall not ship, transfer, or export Licensed Software into any country or use Licensed Software in any 
manner prohibited by the United States Export Administration Act or any other export laws, restrictions, or 
regulations (collectively the “Export Laws.”) If the Licensed Software is identified as export controlled items under 
the Export Laws, Licensee represents and warrants that Licensee, and Licensee's employees who will use the 
Licensed Software are not a citizen, or otherwise located within, an nation embargoed by the United States 
(including without limitation: Iran, Syria, Sudan, Cuba, and North Korea), and that Licensee, and Licensee's 
employees who will use the Licensed Software, are not otherwise prohibited under the Export Laws from receiving 
the Software. All rights to use the Licensed Software are granted on condition that Licensee complies with the 
Export Laws, and all such rights are forfeited if Licensee fails to comply with the Export Laws.

GOVERNING LAW.
This EULA is subject to, and will be governed by and construed in accordance with the substantive laws in force of: 

(1) the State of California, if the Licensed Software is obtained when the Licensee is in the United States, Canada, 
Mexico, or Chile; or

(2) the applicable law of any other jurisdiction if the Licensed Software is obtained in any location not described 
in (1), but only to the extent the law of the other jurisdiction conflicts with California Law. 

Unless prohibited by law of an applicable jurisdiction, the courts of the State of California shall have exclusive 
jurisdiction over all disputes relating to this EULA. This EULA will not be governed by the conflict of law rules of 
any jurisdiction, or the United Nations Convention on Contracts for the International Sale of Goods, the application 
of which is expressly excluded.

INTELLECTUAL PROPERTY OWNERSHIP.
The Licensed Software and any authorized copies that Licensee makes are the intellectual property of, and are 
owned by, Avanquest USA, and by third parties whose intellectual property has been licensed by Avanquest USA. 
The structure, organization, and code of the Licensed Software are the valuable trade secrets and confidential 
information of Avanquest USA and such third parties. The Licensed Software is protected by law, including 
without limitation, the copyright laws of the United States and other countries, and by international treaty 
provisions. Except as expressly provided in this EULA, Licensee is not granted any intellectual property rights in 
the Licensed Software.

RESERVATION OF RIGHTS.
Avanquest USA reserves all rights not expressly granted to Licensee by this EULA. The rights granted to Licensee 
are limited to Avanquest USA’s intellectual property rights, and to the intellectual property rights of third parties 
licensed by Avanquest USA, and do not include any intellectual property rights.
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COMPLETE AGREEMENT.
This EULA constitutes the entire agreement between the Licensee and Avanquest USA relating to the Licensed 
Software, and it supersedes all prior or contemporaneous representations, discussions, undertakings, 
communications, agreements, arrangements, advertisements, and understandings regulating the Licensed Software.

MODIFICATION.
This EULA may only be modified or amended by a writing signed by an authorized officer of Avanquest USA.

SEVERABILITY.
If any provision of this EULA is determined by a court of competent jurisdiction to be contrary to law, that 
provision will be enforced to the maximum extent permissible, and the remaining provisions of this EULA will 
remain in full force and effect.

WAIVER.
No failure or delay by Avanquest USA in exercising its rights or remedies shall operate as a waiver unless made by 
specific written notice. No single or partial exercise of any right or remedy of Avanquest USA shall operate as a 
waiver or preclude any other, or further, exercise of that, or any other right, or remedy.

U.S. GOVERNMENT USERS.
The Licensed Software and Documentation are “Commercial Items,” as that term is defined at 48 CFR §2.101, 
consisting of “Commercial Computer Software” and “Commercial Computer Software Documentation,” as such 
terms are used in 48 CFR §12.212 or 48 CFR §227.7202, as applicable. Consistent with 48 CFR §12.212 or 48 CFR 
§§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer 
Software Documentation are being licensed to U.S. Government end users:

(1) only as Commercial Items; and

(2) with only those rights as are granted to all other end users pursuant to the terms and conditions herein.

Unpublished-rights reserved under the copyright laws of the United States. Avanquest Publishing USA, Inc.; 3132 
Dwight Road, Suite 500; Elk Grove, CA 95758-6469, USA.

For U.S. Government End Users, Avanquest USA agrees to comply with all applicable equal opportunity laws 
including, if appropriate, the provisions of Executive Order 11246, as amended, Section 402 of the Vietnam Era 
Veterans Readjustment Assistance Act of 1974 (38 USC 4212), and Section 503 of the Rehabilitation Act of 1973, 
as amended, and the regulations at 41 CFR Parts 60-1 through 60-60, 60-250, and 60-741. The affirmative action 
clause and regulations contained in the preceding sentence shall be incorporated by reference in this EULA.

PROOF OF COMPLIANCE.
Within 30 calendar days after request from Avanquest USA, or Avanquest USA’s authorized representative, 
Licensee will provide full documentation, and certify under penalty of perjury, that Licensee’s use of any and all 
Licensed Software is in conformity with this EULA.

TERMINATION.
If Licensee breaches this EULA, and fails to cure any breach within 30 calendar days after request from Avanquest 
USA, or Avanquest USA’s authorized representative, Avanquest USA may terminate this EULA, whereupon all 
rights granted to Licensee shall immediately cease. Furthermore, upon termination, Licensee shall return to 
Avanquest USA all copies of the Licensed Software, or verify in writing that all copies of the Licensed Software 
have been destroyed.
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Installing and Starting DataBase

Introduction
DataBase Professional™ (DataBase for short) is an easy-to-use database 
program for use with Windows®. DataBase allows you to organize your 
data using the DataBase templates or create your own custom database. 
The database is easily shared across your network, allowing multiple users 
simultaneous access to the data.
You can design and print labels and other forms for the records in your 
database. Print text and graphics directly on labels using a dot matrix, ink-
jet, or laser printer.
DataBase also allows you to calculate values within a data field and to 
create reports.
We suggest reading the “Getting Started” section of the user’s guide or 
online help to help you get an overview of the program. The extensive 
online help can be viewed any time in the program by choosing from the 
Help menu or clicking a Help button in a dialog. For more information 
about the available help options, see “Getting Help” on page 35.
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Installing the Program
Insert the DataBase CD into your CD-drive to open the setup program. 
Follow the on-screen instructions to finish installing DataBase.
If the setup program doesn’t open, follow the steps below:
1. Open the Windows Start menu and choose Run to open the Run 

dialog.
2. Enter the drive letter of your CD-drive followed by a colon (:) and 

the word setup.
For example, if you CD-drive is drive D, enter d:setup.

3. Click OK and follow the on-screen instructions to finish installing 
DataBase.

Identifying Your License
Whenever you install DataBase on a computer, you need to enter a unique 
user name and license. This helps the program keep track of who is 
working with a database at any given time.
For example, if two people have the same record open at the same time 
and both make changes, DataBase saves the information when the first 
person leaves the record. When the second person leaves the record, 
DataBase displays a message explaining that changes were made to the 
record by the first person, preventing overwriting of important data. 

To help prevent confusion 
between letters and 
numbers, the license key 
doesn’t contain the letter I 
nor the letter O. However, it 
can contain the number 1 or 
the number 0.

 

Your user name must be between one and twenty characters and can 
include only letters, hyphens, and underscores. You can optionally enter 
your company name.
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Starting the Program
To start DataBase, open the Start menu and choose  
Programs > MySoftware > DataBase Professional. 

You can also start the program by double-clicking the DataBase 
Professional icon on your desktop.

Upgrading From an Earlier Version
This version of DataBase Professional has several improvements from the 
previous version of the program:
• A new image field type allows you to store image files in separate 

records (see “Placing an Image in a Field” on page 74).
• More sorting and editing features are available in the Data Table (see 

“Entering Data in the Data Table” on page 77).
• Improved filtering allows saving and reusing filters (see “Filtering 

Records” on page 100).
• The new Form Wizard helps you create custom output forms for your 

data (see “Creating a New Form Design” on page 129).
• The fields in an alignment box can be locked and unlocked (see 

“Using an Alignment Box” on page 150).
• Enhanced email functionality includes HTML formatting (see 

“Sending Email Messages” on page 213).
• New custom report designer allows you to create full-page reports 

using the fields and layout that you want (see “Creating Custom 
Reports” on page 257).
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Updating a Previous Database
This version of DataBase is able to open all previous versions of 
DataBase. All of your data, designs, and reports will continue to be 
available with this version of the program. For more information about 
opening a DataBase file, see “Opening Existing Files” on page 32.
You can convert a file that was created by MyDataBase version 2.0 or 
later. Converting a file creates a new DataBase file containing the data and 
designs from your old MyDataBase file. Your old file remains unchanged. 
Since your email preferences aren’t saved with each MyDataBase file, 
you’ll need to enter your email preferences using DataBase. For more 
information about sending email, see “Sending Email Messages” on page 
213.
You can also import the data files from many software programs, 
including MyContactManager and MyDataBase. However, importing 
doesn’t include your old designs. Calculated fields are also not imported. 
You might want to keep your old files until you duplicate your designs and 
calculations in DataBase.
If you’re installing this version on a new computer and want to upgrade 
the database that is saved on another computer that isn’t connected to your 
network, you need to transfer the main file and all of the supporting files 
to the new computer before upgrading the database. For information about 
which files to move to your new computer, see “Transferring Files to 
Another Computer” in the online help or user’s guide that came with your 
previous version.

NOTE: If you’re having difficulty opening or importing 
data from your old file, try using the previous program to 
export the data into a *.csv file and then use this version to 
import the data from the *.csv file (see “Importing Data 
From Other Programs” on page 63).
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Converting a MyDataBase File
Converting a MyDataBase 2.0 or later file creates a new DataBase file 
containing the data and designs from your old file.If you want to convert a 

MyDataBase file without first 
creating a new DataBase file, 
click Open in the DataBase 
Professional Startup dialog 
and then click Cancel.

 
1. Open the File menu and choose Convert MyDataBase File to open 

the Convert File dialog. 

2. Click Browse to open the Open database file name dialog.
3. Locate and select the file you want to convert.

If you’re converting a MyDataBase 2.0, open the Files of type drop-
down list and choose MyDataBase File (*.mdb).

4. Click Open to return to the Convert File dialog.
5. Enter the same Administrator password in both Password boxes (see 

“Creating an Administrator Password” on page 43).
6. Click Convert to open the Save As dialog.
7. Enter a name for your new DataBase file (see “Naming Your 

Database” on page 42).
If you’re saving the new file in the same folder as the old file, you 
need to use a different name for the new file.

8. Click Save to convert the file to the new version.
During the conversion, DataBase creates a Backup folder in the same 
location as your original file and saves your original file in this folder. The 
new file is opened using the new name you entered.

NOTE: If you’re converting from a MyDataBase 2.0 file, 
custom reports might not be converted properly, some of the 
form designs might need to be adjusted, and calculated 
fields are converted to numeric fields in your new DataBase 
file.
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Importing From MyDataBase
MyDataBase was originally designed as a single-user database program. 
DataBase allows multiple users access to the data in the database. As a 
result, some compatibility issues prevent DataBase from efficiently using 
all of the data, designs, and reports from older MyDataBase files.
For example, calculated fields from your MyDataBase file are converted 
to numeric fields in your DataBase file. These fields can’t be converted 
back, so you’ll need to create new calculated fields to replace them. For 
more information, see “Working With Calculated Fields” on page 57.
Importing the data adds the data from your old file to a new file. None of 
your designs are imported. In the DataBase file, you’ll need to recreate 
any custom output designs or reports you had created using MyDataBase.
For more information, see “Importing Data From Other Programs” on 
page 63.

If you’re having difficulty 
importing data from your old 
file, try using the previous 
program to export the data 
into a *.csv file and then use 
this version to import the 
data from the *.csv file.

  

Importing From MyContactManager
DataBase isn’t a direct upgrade for MyContactManager, but it can import 
the data into similar templates. Be sure to map your Contact History field 
to the History field in DataBase.
If you created any custom designs, they aren’t imported. However several 
DataBase templates have similar fields and designs as the templates with 
the same names used in MyContactManager. For information about 
DataBase templates, see “Choosing a Template” on page 44.
When you import the data, you need to map the field names from the 
MyContactManager file to the field names in the DataBase template. In 
some cases the field names for the business addresses and home addresses 
might be assigned incorrectly when the Assign Import Fields dialog 
opens. To correct this, click the Reassign All button and map each field 
again.
For information about importing, see “Importing Data From Other 
Programs” on page 63. 
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Learning the Basics

Overview
There are four basic steps to creating a database and printing forms using 
DataBase:
• Step 1: Setting Up a Database (see page 26)
• Step 2: Entering the Data (see page 27)
• Step 3: Preparing the Data (see page 28)
• Step 4: Printing the Data (see page 29)
These steps are outlined in this chapter. For more complete information, 
see the following chapters or the online help.
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Step 1: Setting Up a Database
Each time you start DataBase, the DataBase Professional Startup dialog 
appears allowing you to choose what you want to work on. 

• New With Template allows you to create your database using a 
DataBase template.

• New Custom allows you to design your own custom database.
• Open Last allows you to open the database you were working on 

when you last used DataBase.
• Open allows you to choose a database you have previously saved 

using DataBase.

If you want to convert a 
MyDataBase file without first 
creating a new DataBase file, 
click Open in the DataBase 
Professional Startup dialog 
and then click Cancel (see 
“Converting a MyDataBase 
File” on page 23.

 
• Exit closes the program.
Whenever you setup a new database, you first must enter a name for the 
new file. If you’re creating a shared database, be sure to save the database 
in a shared folder where others on your network can access it. For 
information about naming and saving a new database, see “Naming Your 
Database” on page 42.
After naming your database, DataBase asks you to login as the 
administrator of the database. For information about your initial login, see 
“Creating an Administrator Password” on page 43.
You can either start with a template or create a custom database, 
depending on the choice you made in the DataBase Startup dialog. For 
information about setting up the initial fields for your database, see 
“Choosing a Template” on page 44 or “Creating a Custom Database” on 
page 45.
When you finish choosing your template or custom fields, DataBase opens 
to the Data Entry form, where you can edit your records. You can 
customize the Data Entry form to fit your needs. For information about 
making changes to the Data Entry form, see “Customizing the Data Entry 
Form” on page 47.
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Step 2: Entering the Data
After setting up your database you can begin entering data in the Data 
Entry form. 

Click the field where you want to enter or edit data. The name of the 
selected field appears above the record. If you’re using a form that 
displays field names inside of the edit boxes, the field name disappears 
when you click a field or after you enter data into it.
To change the order that you move through the fields when you press TAB 
or ENTER, see “Setting the Tab Order” on page 52.
You can also use the Data Table to enter data or to view your database in a 
table. In the Data Table window, you can select groups of records to print, 
or even print your data in a table.

To select a record in 
the Data Table, click 
the record number 
on the left.

  

For more information about entering data, see “Data Entry” on page 61.
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Step 3: Preparing the Data
DataBase allows you to sort your data, filter records, and delete records 
before you create reports or print forms.
Use the Sort dialog to change the order that your records display and print. 
For information about sorting your data, see “Sorting Your Data” on page 
98.
Filtering allows you to view and print only those records that meet the 
criteria you set. For information about filtering your data, see “Filtering 
Records” on page 100.
DataBase can search for and remove duplicate records from your file. This 
can be a useful feature if you have imported information from several 
different files. For more information about removing duplicate records, 
see “Removing Duplicate Records” on page 109.
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Step 4: Printing the Data
After adding data for the records, you’re ready to design and print your 
output forms.
You can print forms using the Data Entry design or you can create a design 
in the Output Forms window. 
For example, you might want to create a special design for a seasonal sale 
or event using the Output Forms window. The form in the Data Entry 
window is saved along with any forms you create in the Output Forms 
window.
Design your output form the way you want it to print using the Output 
Forms window (see “Output Forms” on page 113).
To preview your output forms before you print them, open the File menu 
and choose Print Preview > Active Output Form.
To print your data, either click the Print button in the Preview window or 
open the File menu and choose Print > Active Output Form. 

You can also print your data in the Data Table format and in reports.
For more information about printing, see “Print or Send Data” on page 
191.



30   •   Learning the Basics DataBase Professional



DataBase Professional Opening a Database   •   31

Opening a Database

Overview
Each DataBase file can be simultaneously opened by multiple Regular 
users. Every time a database file is opened, a login is required. If you’re 
the administrator of a database, you can switch between Regular user and 
Administrator logins while the database is open.
DataBase files are designed to be accessed across a network. Since the 
only password requirement is for Administrator access, the database can 
be opened and modified by any Regular user. If you want to restrict access 
to the database, you can restrict access to the folder where the database is 
saved using Windows network permissions (see your Windows 
documentation or contact your network administrator).
DataBase tracks the users of a database to help prevent accidental loss of 
data. When conflicts occur, users are notified of the conflict and given 
choices of how to proceed.
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Opening Existing Files
Although DataBase allows multiple users on different computers to open 
the same file, only one DataBase file at a time can be open on a computer. 
When you open another file, the current file is closed. DataBase 
automatically saves any changes you made to the current file before 
closing it.
1. Open the File menu and choose Open to display the Open dialog. 

2. Locate the drive and folder where you saved the file.
3. Click the file that you want to open to select it.
4. Click Open.

Choosing a Login
Each time you open a file, DataBase asks you to login. 

You can login as a Regular user or the Administrator. If you login as the 
Administrator, you need to enter the password.
Choose your login and click OK to open the database.
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Regular User Login
When you login as a Regular user, anyone else on the network can also 
login to the same database as a Regular user. If the Administrator has the 
database open, you won’t be able to open the database until the 
Administrator closes the database.
As a Regular user, you can view and edit all of the records in the database. 
However, you can’t import data from other programs, or backup and 
restore the database. 
You have the choice of using shared or personal forms, emails, and 
reports. You can’t edit the shared forms, emails, and reports. However, 
you can create and edit personal forms, emails, and reports using the data 
in the database. Personal forms, emails, and reports can’t be shared by 
other users.

Administrator Login
When you login as the Administrator, no other user on the network can 
open the same database while you have it open. If any Regular users have 
the database open before you login, you won’t be able to login as 
administrator until they close the database. The Administrator can login 
using any computer on the network that has DataBase installed on it.
As the administrator you can view and edit all of the records in the 
database just like a Regular user. Only the administrator can import data 
from another file, or backup and restore the database.
The administrator doesn’t have access to personal forms, emails, or 
reports. However, the administrator can create and edit the shared forms, 
emails, and reports. 

Switching to a Different Login
If you’re the database administrator, you can switch between Regular user 
and Administrator logins. For example, you might want to edit a shared 
email as the administrator and then switch to a Regular user login so you 
can send the email.
To switch your current login, open the User Management menu and 
choose Change User Mode to open the Select User Mode and Enter 
Password dialog (see “Choosing a Login” on page 32).
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Getting Help

Overview
DataBase includes a comprehensive user’s guide and complete online help 
that is available while using the program.

Viewing and Printing the User’s Guide
To view or print the online user’s guide, open the Help menu and choose 
DataBase Professional User’s Guide.
If there wasn’t enough room on your computer to install the user’s guide, 
you can open the DataBaseProfessional.pdf file in the User’s Guide folder 
on the program CD.
After the user’s guide opens in Acrobat Reader, you can view it on-screen, 
print the entire document, or print just the pages you need. 
For complete information about using Acrobat Reader, see the Acrobat 
Reader online help or contact Adobe technical support.

To Print the User’s Guide
1. Open the Acrobat Reader File menu and choose Print to open the 

Print dialog.
The name of the selected printer appears at the top of the Print dialog. 
If this isn’t the printer you want to use, click the Setup button in the 
dialog and then choose another printer.

2. Choose the pages you want to print from the Print Range area.
3. Click OK to begin printing the user’s guide.
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Using Online Help
The online help for DataBase offers many features to help you find the 
information you need.
To view the online help, open the Help menu and choose DataBase 
Professional Help or click a Help button in a dialog. 

To view a help topic, click a title in the Contents tab on the left side of the 
help window. To view an alphabetical index, click the Index tab. You can 
also click the Browse buttons to browse through the help topics. 

Browse
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Using ToolTips
DataBase also supports ToolTips. When the ToolTips feature is turned on, 
a brief explanation appears when you pause your cursor over a button.  

To switch the ToolTips on or off, open the View menu and choose 
Toolbars, and then mark or clear the Show ToolTips check box in the 
Toolbars dialog.

Using the Status Bar
The status bar across the bottom of the DataBase window displays 
extended tips for menu items and buttons. It also displays information 
about the current file.
To view a tip in the status bar, point the cursor at a button or highlight a 
menu item. For example, point at the Print Preview button in the Data 
Entry window to display this information at the bottom of the window:  

To the right of the tip, the status bar tells you other useful information, 
such as the number of records in your database, the number of records that 
are currently displayed, how the file is sorted, and the name of the 
currently selected form.
To switch the status bar on or off, open the View menu and choose Status 
Bar.
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Setting Up a Database

Overview
You can set up a new database when you first start the program or after the 
program is already open.
• To set up a new database when the program starts, click either the 

New With Template or New Custom button in the DataBase 
Professional Startup dialog.

• To set up a new database after the program is already open, open the 
File menu and choose either New With Template, New Custom File, 
or New With Current Design.

Whenever you set up a new database, you must first enter a name for the 
new file. After naming the file, DataBase asks you to login as the 
administrator of the database. Then, you can choose a template or create a 
custom database.
When you finish choosing your template or custom fields, DataBase opens 
to the Data Entry form. As the database administrator, you can customize 
the Data Entry form to fit your needs by creating or deleting fields and 
placing them on the form in a way that makes it easy for you to enter the 
data for your records.
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Naming Your Database
The first step for creating a new database is entering a name for the file. 

Open the Look in drop-down list in the Input New Database File Name 
dialog to locate the folder where you want to save the database. If you plan 
to share the database, be sure to choose a folder that is shared on your 
network, so that other computers can access it.
You can enter any name you want for the database. When DataBase saves 
the file, it creates a folder with the same name as the file to hold the 
supporting files for the database. So, make sure that the file’s name 
doesn’t match the name of a folder already in the folder where you want to 
save the database.
When you’re ready to open the database, click Open.
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Creating an Administrator Password
When you create a new database, you’re the administrator. The password 
you enter in the Select User Mode and Enter Password dialog will be 
required each time you open the database as the administrator. 

Enter a password between zero and thirty characters long. 
Each database that you administer can have a different password. The 
Administrator password isn’t needed when the database is opened by a 
Regular user.
For more information, see “Choosing a Login” on page 32.

NOTE: You can’t use the DataBase program to recover the 
password for a database file. Be sure to keep the password 
in a safe place, so you’ll be able to open the database if you 
forget the password.
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Choosing a Template
DataBase allows you to choose from several database templates with 
predefined fields. To open the Select Template dialog, click New With 
Template in the DataBase Professional Startup dialog or open the File 
menu and choose New With Template. After you give the new database a 
name and enter an Adminstrator password, the Select Template dialog 
opens. 

1. Click the Template Categories drop-down arrow and choose a 
category.

2. Choose a template listed in the Templates in Selected Category box.
3. View the available fields for the template in the Fields in Selected 

Template box.
If you can’t find the exact template you want, choose one that closely 
matches your needs and then customize the Data Entry form.

4. After you finish choosing a template, click OK to close the Select 
Template dialog.
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Creating a Custom Database
DataBase allows you to design a custom database with the fields you need 
for your data. Create and define text, numeric, and currency fields for your 
data using the Create Custom Database dialog.
To open the Create Custom Database dialog, choose New Custom in the 
DataBase Professional Startup dialog or open the File menu and choose 
New Custom File. After you give the new database a name and enter an 
Adminstrator password, the Create Custom Database dialog opens. 

For each new field you create, give the field a name and then choose the 
field type and the output format. When you finish defining each field, 
click the Create Field button near the top of the dialog to add the field 
name to the Defined Fields list near the bottom of the dialog (see “To 
Create a Field for Your Database” on page 46).
If you want to remove a field from the Defined Field list, choose the field 
in the list and then click the Delete Field button (see “To Delete a Field in 
Your Custom Database” on page 46). 
You can’t change the settings of the fields in the Create Custom Database 
dialog after you create them. However, you can continue to add, remove, 
and customize fields in the Edit Data Entry Form window after you close 
this dialog.
After defining your initial fields, click OK to open the Data Entry window.
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To Create a Field for Your Database
1. Enter a field name in the Field Name box.
2. Choose a Field Type option.

• To add items to a Listbox field, click Listbox Entries (see 
“Editing List Box Fields” on page 50.)

• To create a formula for a Calculated field, click the Formula 
button (see “Adding a Calculated Field” on page 57).

3. For Text and Listbox fields, you can set the character length of the 
field in the Field Length box.

CAUTION: After you have created a new field, the 
Field Length is fixed and can’t be modified.

4. Choose an Output Format from the list displayed in the Output 
Formats box.
The available Output Formats are specific to the Field Type (see 
“Choosing the Output Format” on page 56).
You can set the decimal placement when you choose a Numeric field 
with a Fixed Output Format.

5. To add the field to your custom database, click the Create Field 
button.

6. To continue adding fields to your database, repeat steps 1–5.
7. When you finish creating the fields in your custom database, click OK 

to close the Create Custom Database dialog.

To Delete a Field in Your Custom Database
1. Select the field you want to delete in the Defined Fields box.
2. Click the Delete Field button.
When you finish creating the fields in your database, click OK to close the 
Create Custom Database dialog.
After you create a custom database, you can still add, modify, and delete 
fields (see “Customizing the Data Entry Form” on page 47).
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Customizing the Data Entry Form

Overview
The Data Entry form can be customized only by the administrator of the 
database. If you’re the administrator of the database and logged in as a 
Regular user, you need to switch to Administrator login before 
customizing the Data Entry form (see “Switching to a Different Login” on 
page 33).
Customize your Data Entry form by adding the fields, text, and graphics 
you need in your database, rearranging the fields, and setting the tab order. 
To customize your Data Entry form, open the Edit Data Entry Form 
window by clicking the Edit Data Entry Form button.

Properties Toolbar

Object Toolbar
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Adding Fields, Text, and Graphics
Using the Object Toolbar, you can add fields, text boxes, and objects to 
your Data Entry form.
• Fields are place holders for data, such as names and addresses. Every 

DataBase file has a set of fields for you to add and place on your 
database design (see “Adding Fields for Data” on page 156).

• Text boxes are used for text that you want to display or print the same 
on every form, such as the return address on a shipping label (see 
“Adding a Text Box” on page 159).

• Objects are shapes, lines, and clipart that you can add to your 
database design (see “Adding Pictures and Drawing Objects” on page 
169).

To quickly add a mailing address to your form, click the Mailing Address 
button in the Object Toolbar (see “Adding a Mailing Address Group” on 
page 156).

Editing the Properties of a Field
Use the Field Properties dialog to change the format of a field in the 
current form. The formats that are available depend on the selected field.
1. Open the Edit Data Entry Form window. 
2. Open the Format menu and choose Field Properties to open the Field 

Properties dialog.

3. Choose the field you want to change from the Field Name drop-down 
list.

4. Change the type of field by selecting an option in the Field Type box.
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5. Choose an Output Format from the list.

NOTE: The formats that are available depend on the 
selected field.

 

• To create a new field, click the New Field button (see “Creating a 
New Field” on page 54).

• To edit the available items in a list box field, click the Listbox 
Entries button (see “Editing List Box Fields” on page 50).

• To edit the formula for a calculated field, click the Formula 
button (see “Editing the Formula” on page 58).

6. Click OK to close the Field Properties dialog.

Renaming a Field
1. Make sure you’re in the Edit Data Entry Form window. 
2. Open the Format menu and choose Field Properties to open the Field 

Properties dialog.
3. Choose the field you want to rename from the Field Name drop-down 

list.
4. Click the Rename button to open the Edit Field Name dialog.

5. Type the new field name.
6. Click OK to close the Edit Field Name dialog.
7. Click OK again to close the Field Properties dialog.
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Editing List Box Fields
When you create a list box field, you can add, move, and delete the items 
in the list box.

To Add Items to a List Box
1. Open the Edit Data Entry Form window. 
2. Open the Format menu and choose Field Properties.
3. Choose the list box’s field name from the Field Name list.
4. Click the Listbox Entries button to open the List Field Entries dialog.

5. Click the Add button to open the Add New List Item dialog.

6. Type the text for the new list item.
7. Click OK to add the item and view the new list.
8. Click OK to close the List Field Entries dialog.
9. Click OK to close the Field Properties dialog.
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To Move Items in a List Box
1. Make sure you’re in the Edit Data Entry Form window. 
2. Open the Format menu in the and choose Field Properties to open 

the Field Properties dialog.
3. Choose the list box’s field name from the Field Name list.
4. Click the Listbox Entries button to open the List Field Entries dialog 

showing the available choices.

5. Click on the list item you want to move.
6. Click the Move Up or Move Down button to reposition the item.
7. Click OK to close the List Field Entries dialog.
8. Click OK to close the Field Properties dialog.
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To Delete Items From a List Box
1. Make sure you’re in the Edit Data Entry Form window. 
2. Open the Format menu in the and choose Field Properties to open 

the Field Properties dialog.
3. Choose the list box’s field name from the Field Name list.
4. Click the Listbox Entries button to open the List Field Entries dialog 

showing the available choices.

5. Click on the list item you want to remove.
6. Click the Delete button.
7. Click OK to close the List Field Entries dialog.
8. Click OK to close the Field Properties dialog.

Setting the Tab Order
You can change the order that the cursor moves through the fields in the 
Data Entry window when you press TAB or ENTER. You can even set it to 
skip rarely used fields.

NOTE: Setting the tab order only effects the order of the 
fields for data entry; it doesn’t change the layout of the Data 
Entry form.
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To Set the Tab Order
1. Open the Edit Data Entry Form window.
2. Open the Format menu and choose Tab Order to open the Tab Order 

dialog.

3. Set the tab order:
• To move a field earlier in the order, click the field name and then 

click the Up button.
• To move a field later in the order, click the field name and then 

click the Down button.
• To skip a field (or to include a field that is currently skipped), 

click the field name and then click the Skip button.
4. Click OK.
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Creating a New Field
Only the administrator of the database can add new fields. If you’re the 
administrator of the database and logged in as a Regular user, you need to 
switch to Administrator login before creating a new field (see “Switching 
to a Different Login” on page 33).
Create new fields in the Edit Data Entry Form window. To create a new 
field, click the New Field button in the Object toolbar, or click the New 
Field button in the Field Properties dialog (see “Editing the Properties of a 
Field” on page 48).

1. Enter a unique field name in the Field Name box.
The field name appears in the field list and on your forms.

2. Choose a Field Type option (see “Choosing the Field Type” on page 
55).
If you’re creating a Text or Listbox field, you can set the character 
length of the field in the Field Length box.

CAUTION: After you have created a new field, the 
Field Length is fixed and can’t be modified.

 

3. Choose an Output Format from the list (see “Choosing the Output 
Format” on page 56).

The available Output 
Formats depend on the 
Field Type.

 
You can set the decimal placement when you choose a Numeric field 
with a Fixed Output Format.

4. Click OK to add the field to your database.



DataBase Professional Customizing the Data Entry Form   •   55

Choosing the Field Type
DataBase allows you to choose from several different types of fields.

Text A text field is the standard, single-line data entry field. Unless 
you need special formatting or multiple lines of data in the 
field, choose this field type.

Numeric Numeric fields accept only numbers. Text characters aren’t 
allowed. Numeric fields can be used in the formula of a 
calculated field.

Currency Currency fields take their output format from your system 
settings. For example, U.S. dollars will always appear and 
print with a dollar sign ($) on the left and two places after the 
decimal. Currency fields can be used in the formula of a 
calculated field.

Notebox Notebox fields are similar to text fields, except that you can 
enter more than one line of data. Use notebox fields for 
unstructured, miscellaneous information in your records. 
Notebox fields don’t appear or print in the Data Table.

Date Date fields can print in the system-defined long or short date 
formats. You can use the date field in reports to subtotal by 
year, month, or day. Use the Preferences dialog to change the 
data entry and display format of date fields (see “Changing 
Date Field Preferences” on page 298).

Phone Phone fields can be used to copy and paste phone numbers 
into your dialing or fax programs. Choose the output format 
that works best in these programs.

ZIP Code ZIP Code fields are used to define the special mailing code 
used by the U.S. Postal Service.

Calculated Calculated fields are used to perform mathematical 
calculations on the numeric and currency fields in your 
database (see “Working With Calculated Fields” on page 57).

Checkbox Checkbox fields are used to enter simple yes or no answers, 
such as whether or not you have permission to send email to 
the people in your database.

Listbox Listbox fields allow you to choose from a list of items to enter 
into the field. To add items to the list, click the Listbox 
Entries button (see “Editing List Box Fields” on page 50).

History History fields allow you to enter date-stamped and task-
defined lines of data. You can use a history field to keep a 
record of calls to customers or to track shipments (see 
“Entering and Editing Data in the History Field” on page 71). 
History fields don’t appear or print in the Data Table.

Image Image fields allow you to use different images for each record 
in a database (see “Placing an Image in a Field” on page 74).
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Choosing the Output Format
The output formats that are available in the list depend on the type of field 
you choose to create. For example, text fields can be unformatted 
(<None>) or in all upper-case, all lower-case, or title-case (Capitalizes 
the First Letters Only).
Certain field types, such as number, currency, and date fields, derive their 
output formats from your system settings that are set in the Windows 
Control Panel. For information about changing your system settings, see 
your Windows documentation.
When you choose a fixed decimal format for a numeric field, you can 
enter the number of digits to display after the decimal by entering a 
number in the Fixed Decimals box.
Since the output formats are designed for how your data will look when 
printed, the format might not appear in the Data Entry form. To view your 
output formats, open the Print Preview window (see “Previewing Your 
Form” on page 195).

Deleting a Field From Your DataBase File
Only the administrator of the database can remove fields from the 
database. If you’re the administrator of the database and logged in as a 
Regular user, you need to switch to Administrator login before deleting a 
field from the database (see “Switching to a Different Login” on page 33).Before deleting a field 

from your database, you 
should make a backup 
(see “Backing Up Your 
Files” on page 285).

 
You can permanently delete fields from your database and from all of your 
forms in the Edit Data Entry Form window. If you only want to remove 
the field from a form or from the Data Table, see “Deleting a Field From a 
Form” on page 158 or “Choosing the Data Table Fields” on page 79.

CAUTION: Deleting a field from your database also 
deletes any data stored in that field.

 

1. Open the Format menu and choose Field Properties to open the Field 
Properties dialog.

2. Choose the field that you want to delete from the Field Name list.
3. Click the Delete button to permanently remove the field from your 

file and forms.
4. Click OK to close the Field Properties dialog.
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Working With Calculated Fields

Overview
There might be times when you want to use the fields in your database to 
make calculations and display the result in another field. You can create 
calculated fields using numeric and currency field types. For example, you 
could create a field that calculates the total price of an order or the number 
of days worked per year.
Only the administrator of the database can create or edit calculated fields. 
If you’re the administrator of the database and logged in as a Regular user, 
you need to switch to Administrator login before creating or editing a 
calculated field (see “Switching to a Different Login” on page 33).

Adding a Calculated Field
Create a calculated field by creating a new field in the Edit Data Entry 
Form window.
1. Click the Edit Data Entry Form button in the Data Entry window to 

open the Edit Data Entry Form window.
2. Click the New Field button to open the Create New Field dialog.

New Field
3. Enter a name for the calculated field in the Field Name box.
4. Choose the Calculated option.
5. Click the Formula button to add a formula to the Calculated field 

(see“Editing the Formula” on page 58). 
6. When you finish creating the formula for the calculated field, click 

OK to return to the Create New Field dialog.
7. Click OK to add the Calculated field to your database.
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Editing the Formula
Using the Formula Editor, you can create formulas using numeric and 
currency fields, symbols, and numbers. 
To open the Formula Editor, click the Formula button in either the Field 
Properties dialog or the Create New Field dialog.

Adding Existing Fields to the Formula
To add a Numeric or Currency field to a formula, click the Fields button 
and then choose a field from the list.
You can’t add a Calculated field to a formula. To use the calculation from 
a Calculated field in a formula, copy the calculation from the formula for 
the original field and then paste it into the formula for the new field.

NOTE: If the Fields button is dimmed, you don’t have any 
Numeric or Currency fields in your database. Only Numeric 
and Currency fields can be used in a the formula of a 
Calculated field.

 

Adding Mathematical Symbols to the Formula
Click the Symbols button to choose the mathematical symbol that you 
want to use in the formula and place it at the current cursor position.
Choose one of the following symbols:

(  Start of a grouping
)  End of a grouping
*  Multiplication
/  Division
+  Addition
-  Subtraction
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Entering Numbers in the Formula
Position the cursor where you want the number, and then press the number 
keys on your keyboard or click the Numbers button and choose a number 
from the list.

Checking for an Invalid Formula
To make sure that your formula is valid, click the Verify button. If the 
formula you entered isn’t acceptable, a message displays information 
about the problem.

Changing the Properties of a Calculated Field
You can format the characters in a calculated field just like any other field 
using the buttons in the Properties Toolbar or the options in the Object 
Properties dialog (see “Formatting Text in Fields and Text Boxes” on page 
160).

Deleting a Calculated Field
You can permanently delete calculated fields from your database and from 
the Data Entry form. If you only want to remove the field from the form, 
see “Deleting a Field From a Form” on page 158.
1. Click the Edit Data Entry Form button in the Data Entry window to 

open the Edit Data Entry Form window.
2. Open the Format menu and choose Field Properties to open the Field 

Properties dialog.
3. Choose the field that you want to delete from the Field Name list.
4. Click the Delete button to permanently remove the field from your 

file and forms.
5. Click OK to close the Field Properties dialog and return to the Edit 

Data Entry Form window.
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Importing Data From Other 
Programs

Overview
The database administrator can import data from another file into 
DataBase. When you import a file, the records are copied from the 
selected file and added to the end of the current database. The original file 
isn’t affected by this process.
Only the administrator of the database can import data. If you’re the 
administrator of the database and logged in as a Regular user, you need to 
switch to Administrator login before importing data (see “Switching to a 
Different Login” on page 33).

NOTE: DataBase can’t import calculated fields from 
another database program.
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Supported File Formats
DataBase can import data from the following file types:

• MyDataBase™
• MyContactManager®
• MyLabel Designer®
• MyMailList™
• Access® 2.0, 7.0, 8.0
• ACT!™ 2.x, 3.x, 4.0
• Approach® 2.x, 3.x
• dBASE® 3.x, 4.x, 5.x

• Excel® 3.x, 4.x, 5.0, 7.0, 8.0
• Lotus® 1-2-3
• Outlook®
• Paradox® 3.x, 4.x, 5.x, 7.x
• ASCII Text Files, such as: 

- Comma Separated Variable (*.csv) 
- Tab Separated Variable (*.tsv) 
- MySoftware Export (*.exp) 
- Fixed Field Length (*.txt)

If the file that you want to import isn’t supported, you might be able to use 
the original program to save the data in a format that DataBase does 
support, such as ASCII text in *.csv format. Most database programs can 
save their data in other formats, usually by using the Save As or Export 
option. To learn how to save your file in a different format, see the 
documentation for your original program.

Choosing the File to Import
1. Exit the program that created the file that you want to import.
2. Open the DataBase file that you want to import the database into.
3. Open the File menu and choose Import to open the Import dialog.

4. Choose the type of program that created the file you want to import 
from the Files of Type box.
For information about importing an Outlook file, see “Importing an 
Outlook File” on page 66.
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5. Locate the drive and folder where the file is saved.
6. Select the file you want to import.
7. Click OK.

Importing a Text File
When you import a text file, DataBase opens the Use First Record for 
Field Names dialog.

• If the first line of the file contains field names (such as 
First_Name, Last_Name,...), click Yes. This line isn’t 
imported as data.

• If the first line contains data (such as Bob,Smith,...), click No. 
This line is imported as one of your records.

After you click Yes or No, DataBase opens the Assign Import Fields 
dialog (see “Assigning Fields to Import” on page 68).

Importing an Access or Excel File with Tables
When you choose to import a Microsoft Access or Excel database that 
contains more than one table, the Database Tables dialog opens.

1. Choose the table you want to import.
2. Click OK.
For more information about tables, see your Access or Excel 
documentation.
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Importing an Excel File
To import data from a file that was created with Excel version 5.0 or 
earlier, you must first use Excel to set up a database in the spreadsheet.
In some cases, it might be easiest to save the Excel file in *.csv format and 
then import from the *.csv format.
For information about setting up a database in a spreadsheet, see your 
Excel documentation. 

Importing an Outlook File
DataBase can import a data file from your Outlook Contacts.

NOTE: If you’re using Outlook Express, you need to 
export your Outlook Express data file as a text file and then 
import it to DataBase Professional (see “Importing Data 
From Other Programs” on page 63).

 

1. Open the File menu and choose Import to display the Import dialog.

2. Choose Outlook from the Files of type drop-down list.
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3. Choose the Outlook.otl file in the Data folder and then click Open.

TIP: The Outlook.otl file is located in the Data folder of 
the DataBasePro folder. The standard installation path 
is: C:\Program Files\MySoftware\DataBasePro\Data

 

You might be asked to choose to import from either you Contacts or 
your Address Book Entries. Select the appropriate option and then 
click OK.
If you have more than one Contacts file in Outlook, the Select Contact 
Folder dialog opens.

4. Choose the data file from the Folders list.
5. Click OK to begin importing the data file.

The Assign Import Fields dialog appears (see “Assigning Fields to 
Import” on page 68).
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Assigning Fields to Import
After you choose an import file, DataBase opens the Assign Import Fields 
dialog. Use this dialog to match the fields in the import file to the fields in 
the current DataBase file.
If possible, some of the fields in the import file are automatically matched 
to fields in the DataBase file.
1. Confirm any automatic assignments that are listed in the large box at 

the top of the dialog.

Be sure to assign fields of 
the same data type. For 
example, numeric fields can 
only accept numeric data.

  
• To reassign a pair of fields, click the pair and then click 

Reassign.
• To start assigning the fields from scratch, click Reassign All. 

The field names appear in the boxes at the bottom of the dialog, 
so that you can match them again.

2. Match any remaining fields in the import file by clicking a field in the 
Fields in Import File list, and then clicking a field in the Fields in 
Current File list.

3. As the fields are matched, they appear in the list at the top.
4. After you finish matching the fields, click OK to import your data.

NOTE: The data in any unassigned fields won’t be 
imported into DataBase. DataBase adds the imported 
records to the end of your file. If you have already 
sorted your database, you need to sort again to put the 
records in order.

 



DataBase Professional Entering Data in the Data Entry Window   •   69

Entering Data in the 
Data Entry Window

Overview
Before entering data, the database administrator must place the fields you 
want to use on your Data Entry form in the Edit Data Entry Form window. 
For information about adding and removing fields, see “Setting Up a 
Database” on page 41.
You can enter the data for the fields in either the Data Entry or Data Table 
windows. For information about the Data Table, see “Entering Data in the 
Data Table” on page 77.
If you already have a database that you created using another program, the 
administrator can import that data into DataBase (see “Importing Data 
From Other Programs” on page 63).
To manage your database, you can find, sort, and filter the data. You can 
even remove duplicate records from your database (see “Sorting and 
Filtering Data” on page 97 and “Removing Duplicate Records” on page 
109).
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Viewing the Data Entry Window
The Data Entry window displays one record at a time. Each record is 
displayed like a single page or index card, and the whole database is 
organized like a stack of these cards.
Use the Data Entry window to enter data and view your records 
individually.

A list of the records 
appears on the left 
side of the Data Entry 
window.

  
Modify your Data Entry Form using the Edit Data Entry Form window. To 
open the Edit Data Entry Form window, click the Edit Data Entry Form 
button located above the Data Entry form.
For information about modifying your Data Entry Form see “Customizing 
the Data Entry Form” on page 47.

Printing the Data Entry Form
You can print your forms using the template design you choose or the 
design you create in the Edit Data Entry Form window. Open the File 
menu and choose Print > Data Entry Form. For more information, see 
“Printing Output Forms” on page 193).
You can also print the forms with the design you create in the Output 
Forms window. For information about using the Output Forms window, 
see “Customizing a Form Design” on page 123.
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Entering Data in the Fields
1. View the Data Entry window by clicking the Data Entry tab.
2. Click the field where you want to enter or edit data.

The name of the selected field appears above the record. If you’re 
using a form that has the field names inside of the edit boxes, the field 
name disappears when you click on a field or after you enter data into 
it.

3. Type your data.
4. Press TAB or ENTER to move the cursor to the next field.
5. Press PAGE DOWN to move to the next record.

To change the order that you move through the fields as you press TAB 
or ENTER, see “Setting the Tab Order” on page 52.

As you enter records in the database, they appear in the Record Index on 
the left. The field appearing in the Index is the same as the current sort 
field for the file (see “Sorting Your Data” on page 98).

NOTE: You can also enter and edit your data using the Data 
Table. For information about using the Data Table, see 
“Entering Data in the Data Table” on page 77.

 

Entering Data in a Rotated Field
To edit or enter data in a rotated field in the Data Entry window, click the 
field to open the Edit Field dialog.
Type the data in the dialog and click OK to accept your changes.

Entering and Editing Data in the History Field
Use the History field in the Data Entry window to record calls, meetings, 
to-do items, and other notes about each record in your database. 

For information about creating a history field, see “Creating a New Field” 
on page 54.
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Making a New Entry in the History Field
1. Double-click a blank line in the History field to open the New 

Contact History Entry dialog. 

TIP: You can also right-click in the History field and 
choose New from the shortcut menu to open the New 
Contact History dialog.

 

2. If you want to change the date of the entry, click the Date box and 
choose the date that you want from the calendar.
You can’t change the time.

3. Choose a category for the entry from the Activity Type drop-down 
list.
If the available options don’t meet your needs, you can create your 
own category (see “Customizing the Activity Type List” on page 74).

4. Enter your text in the Regarding box.
5. Click OK to close the dialog and display the information in your form.
You might want to create a Follow-Up Date field for entering a date to 
follow-up on your history field activity. You can use the Follow-Up Date 
information to generate reports, or to sort and filter your records.
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Editing an Existing Entry in the History Field
1. Double-click the entry that you want to edit to open the Edit Contact 

History Entry dialog. 

2. Choose another date from the Date drop-down list or a category from 
the Activity Type drop-down list, if needed.
If the available options in the Activity Type drop-down list don’t meet 
your needs, you can create your own category (see “Customizing the 
Activity Type List” on page 74).

3. Click in the Regarding box and edit the text as needed.
4. Continue editing new or existing entries:

• To save the changes you made and create a new entry for the 
current record, click the New Entry button.

• To edit other entries in the current record, click the Next or 
Previous buttons.

5. Click OK to save your changes and return to the Data Entry window.

Deleting an Entry in the History Field
To delete one of the entries in the history field, right-click the entry and 
choose Delete from the shortcut menu.

CAUTION: Opening the Edit menu and choosing Delete 
removes all of the data from all of the fields in the record.
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Customizing the Activity Type List
Some of the DataBase templates include a list of categories in the Activity 
Type list, so that you can easily categorize your notes when you enter 
history information. If the choices don’t meet your needs, you can enter a 
new category.
1. View the Activity Type list by doing one of the following:

• Double-click a blank line in the History field, or right-click and 
choose New from the shortcut menu, to open the New Contact 
History Entry dialog.

• Double-click the History entry that you want to edit, or right-
click and choose Edit from the shortcut menu, to open the Edit 
Contact History Entry dialog.

2. Click in the Activity Type box and enter your new category. The text 
must be less than 15 characters long.

CAUTION: Be very careful 
when you type the category 
name, because it can’t be 
removed or edited later.

  
3. Click OK to save the new list item.

Placing an Image in a Field
To place images in your records that can change from record to record, use 
an Image field. If you don’t have an Image field available, the database 
administrator can create one (see “Creating a New Field” on page 54).
When you click in an empty Image field in the Data Entry window, the 
Pick Picture dialog opens allowing you to choose an image file (see “To 
Add Clipart to Your Form” on page 172).
• To change an existing image in a record, double-click the image field 

or right-click the image field and choose Change Image to open the 
Pick Picture dialog.

• To remove an image from a record, right-click the image field and 
choose Delete Image, and then click Yes in the confirmation 
message.

• To save the image in a new image file, right click the image field and 
choose Export Image to open the Save As dialog.
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Creating a New Record
There are several ways to create a new record. Pick the one that works best 
for you.
• Click the New Record button above the Index on the left side of the 

Data Entry window.
• Open the Data menu and choose New Record.
• Click on the blank entry at the bottom of the Index. You might need to 

scroll down in the Index to view this entry.
• Press PAGE DOWN if you’re viewing the last record in your database.

Moving Between Records
There are several ways to display the different records in your database. 
Pick the one that works best for you.
• Press PAGE DOWN or PAGE UP to move to the next or previous record.
• Click on the navigation buttons in the toolbar to move to the first 

record, previous record, next record, or last record. Navigation  
• Click on an Index entry to view the record for that entry.
• Open the Data menu and choose Go To to open the Go To dialog, and 

then enter a specific record number.
The record numbers appear above the record in the Data Entry 
window, and on the left side of the Data Table.
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Entering Data in the Data Table

Overview
You can enter the data for the fields in either the Data Entry or Data Table 
windows. For information about the Data Entry window, see “Entering 
Data in the Data Entry Window” on page 69.
If you already have a database that you created using another program, the 
administrator can import that data into DataBase (see “Importing Data 
From Other Programs” on page 63).
To manage your database, you can find, sort, and filter the data. You can 
even remove duplicate records from your database (see “Sorting and 
Filtering Data” on page 97 and “Removing Duplicate Records” on page 
109).
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Viewing the Data Table
The Data Table window displays the records in a table. Each field has a 
column in the table, and each record has a row. Enter your data in the cells 
where the rows and columns intersect.
In the Data Table window, you can select groups of records to print, or 
even print your data in a table.

To select a record in 
the Data Table, click 
the record number 
on the left.

  

You can format the Data Table by adjusting the height and width of the 
rows and columns, rearranging the columns, choosing the fields that are 
displayed, and changing the font of your column headings and data.

NOTE: History and Notebox fields don’t appear in the Data 
Table.

 

Entering Data in the Cells
1. The Data Table window allows you to view and edit your data in a 

table.
2. Click the Data Table tab to open the Data Table window.
3. Select the cell you want to edit by clicking in the cell.

• To replace the information in the selected cell, begin typing.
• To edit the data in the cell, click in the cell again to insert the 

cursor, and then make your changes.
4. Press TAB or the Arrow keys on your keyboard to move between cells.
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Choosing the Data Table Fields
Choose the fields that appear and print in the Data Table by setting the 
Data Table options.
1. Click the Data Table tab to open the Data Table window.
2. Open the View menu and choose Change Data Table Options to 

open the Data Table Options dialog.

Removing a field from the 
Data Table doesn’t remove 
the data from your database.

  

3. Click the Fields tab at the top of the dialog.
4. To add or remove a field from the Data Table, mark or clear the check 

box next to the field’s name. 
5. Click OK to apply your changes.
Use the other tabs in this dialog to format the Data Table for printing (see 
“Preparing the Data Table for Printing” on page 206).
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Changing the Data Table Font
Use the Data Table Options dialog to set the fonts and text alignment for 
your data and column headings.
1. Click the Data Table tab to open the Data Table window.
2. Open the View menu and choose Change Data Table Options to 

open the Data Table Options dialog. 

3. Click the Fields tab at the top of the dialog.
4. Open the Font dialog for data fields or column headings:

• To set the font for your data, click the Data Font button.
• To set the font for the column headings, click the Title Font 

button.
5. Choose the font and font options in the Font dialog.
6. Click OK to return to the Data Table Options dialog.
7. Set the alignment of text within a column by clicking the field name 

and then choosing the alignment from Field Column Properties.
8. Click OK to apply all of your changes.
For information about setting other Data Table options, see “Preparing the 
Data Table for Printing” on page 206.
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Changing the Format of the Data Table
You can change the height of all of the rows, change the width of each 
column, or change the position of the columns in the Data Table.

Resizing the Rows
Record numbers appear along the left side of the Data Table.
1. Position the cursor on the line below a record number.

The cursor changes to the resize cursor shown below.

To resize the rows, click and 
drag a line between rows.

   

2. Click and drag the cell up or down, and then release the mouse button 
to set the new height. 
All of the rows are resized to the new height.

Resizing a Column
The field names appear along the top of the Data Table.
1. Position the cursor on the line between the field names.

The cursor changes to the resize cursor shown below.

To resize the columns, click and 
drag a line between columns.

   

2. Click and drag the column to the right or left, and then release the 
mouse button to set the new column width. 
Only adjoining columns are affected.
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Moving the Columns
To change the order of the fields in the Data Table, rearrange the columns.
1. Point the cursor at the field name at the top of a column.

To move a column, click and 
drag a column heading.

   

2. Click and hold the mouse button down, and then drag the cursor to 
where you want to move the column.

3. Release the mouse button.
To add or remove fields from the Data Table window, use the Data Table 
Options dialog (see “Choosing the Data Table Fields” on page 79).

Changing the Color Options of the Rows
You can choose alternating colors for the rows in the Data Table.
1. Click the Data Table tab to open the Data Table window.
2. Open the Format menu and choose Data Table Options to open the 

Data Table Options dialog. 

3. Click the Background tab at the top of the dialog.
4. Choose the color setting you want from the Background Effects list.

A preview of the color setting appears in the lower area of the dialog.
5. Click OK to apply all of your changes.
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Duplicating Data

Overview
You can copy data from one record into another record or into a group of 
consecutive records. This avoids repetitive data entry when you have a 
group of similar records.
To manage your database, you can find, sort, and filter the data. You can 
even remove duplicate records from your database (see “Sorting and 
Filtering Data” on page 97 and “Removing Duplicate Records” on page 
109).

Copying Data From the Previous Record
DataBase offers a quick way to copy data from a field in the previous 
record to the same field in the current record. For example, if you know 
that record 50 should list the same company name as record 49, you can 
copy the company name into record 50.
1. Click the Data Entry tab to open the Data Entry window.
2. Display the record that you want the data copied to and click in the 

field where you want the data.
3. Open the Edit menu and choose Ditto Field (or press CTRL + D).
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Copying Data to Consecutive Records
DataBase allows you to copy data from one record into consecutive 
records. For example, if you have 20 addresses from the same area, you 
can type the city, state, and ZIP Code into one record and copy that data 
into the next 19 records. Then, you can go back and enter the non-
repetitive information into each record.
1. Open the Edit menu and choose Duplicate Record to open the Copy 

Record dialog. 

2. Enter the number of the record that contains the data you want to copy 
in the From box.

3. Decide where to copy the data:
• To copy the data into a single record, enter the number of the 

destination record in the To box, and then enter the same number 
in the Through box.

• To copy the data to consecutive records, enter the first and last 
record number in the To and Through boxes.

NOTE: If the number in the Through box is higher 
than the number of records in the database, new records 
are created.

 

4. Mark the Blank Fields check box if you want blank fields in the 
record you’re copying to erase data in the destination records.

5. Click OK to copy the data.
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Duplicating Data in the Data Table Cells
You can duplicate the information in your records by cutting or copying 
the information in selected cells and then pasting it into other cells.
• To copy information in selected cells and place the information on the 

Windows Clipboard, select the cells and then open the Edit menu and 
choose Copy Cells.

• To remove information in selected cells and place the information on 
the Windows Clipboard, select the cells and then open the Edit menu 
and choose Cut Cells.

• To paste information into selected cells that you previously cut or 
copied, select the cells and then open the Edit menu and choose Paste 
Cells.
DataBase automatically pastes the data into the number of cells that 
you cut or copied, even if you don’t select the same number of cells 
before pasting.

• To remove information in selected cells without placing the 
information on the Windows Clipboard, select the cells and then open 
the Edit menu and choose Delete Cells.
Deleting the information in selected cells removes the information, 
but doesn’t delete the field from your file.

Inserting Records in the Data Table
You can add a new record in the Data Table window by inserting a row at 
the top of the list, the bottom of the list, or anywhere in between.
To insert a record, select the row below where you want to insert the new 
record. Then, open the Edit menu and choose Insert 1 Blank Record 
(Row). The new blank record is inserted above the selected record. To add 
a record to the end of the list, select the blank record at the bottom.
You can add several records at a time by first selecting the same number of 
consecutive existing records as the number of records that you want to 
add. The menu option changes to tell you how many new records will be 
inserted. For example, if you want to add five new records, select five 
consecutive records below where you want to insert the new records, and 
then open the Edit menu and choose Insert 5 Blank Records (Rows).
For information about selecting mutiple records in the Data Table, see 
“Selecting a Group of Records” on page 108.
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Incrementing Fields
DataBase can automatically increment the value of numbers in your fields. 
For example, if you have a serial number field, and the first serial number 
is 1000, DataBase can automatically number the existing records after it as 
1001, 1002, 1003, and so on.Before incrementing a 

field in your database, 
you should make a backup 
(see “Backing Up Your 
Files” on page 285).

 
You can increment fields in the Data Entry window or the Data Table.
1. Open the Data menu and choose Increment Field to open the 

Increment Field dialog. 

2. Click the Increment Field drop-down list and choose the field you 
want to increment.

3. Type the rest of the values into the dialog:
• To enter the same value in the field for all of the records, 

increment by 0.
• If you want the number to have leading zeros, set a minimum 

number of digits.
4. Click OK to increment the field.
5. If the Overwrite Data dialog appears:

• Click Yes to replace the data that has already been entered in the 
field.

• Click No to skip the replacement for each record.
• Click Yes to All to replace the data in all of the fields.
• Click Cancel to return to the Data Entry window without 

incrementing the data.

NOTE: If you change the numbering of an incremented 
field, you must choose the Increment Field option again to 
adjust the numbers in the rest of your database.
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Finding and Replacing Data

Overview
DataBase provides powerful tools for helping you manipulate the data in 
your database. You can search and replace data, sort your data, filter your 
data, and automatically remove duplicate records.
The sort and filter information is saved separately with each user, allowing 
users to arrange the records in the way that works best for them.

Finding a Specific Record
There are three options for finding specific records with DataBase:
• Use the Quick Find buttons in the Data Entry and Data Table 

windows to quickly scroll to the section of the alphabet that you want 
to see.

• Use the Find dialog to look for specific search criteria, such as a 
company name.

• Use the Go To dialog to move directly to a specific record number.
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Using Quick Find
The column of letters on the left side of the Data Entry and Data Table 
windows are the Quick Find buttons. The Quick Find buttons search the 
Index area of the Data Entry window, or the first column appearing in the 
Data Table. When you click a Quick Find button, the first record that 
begins with the letter you clicked is displayed or highlighted. 
1. Make sure the field displayed in the Index, or the first column 

displayed in the Data Table is the field you want to search.
• To move a Data Table column, click and drag it (see “Moving the 

Columns” on page 82).
• To change the Index field, change the sort field (see “Sorting 

Your Data” on page 98).
2. Click on the letter that matches the data you want to find. 

If the letter isn’t displayed, use the scroll buttons at the top or bottom 
of the Quick Find buttons until the letter appears.
The first record that begins with the letter you clicked is displayed or 
highlighted.

For example, if you want to find the first 
person in your database whose last 
name begins with D, make sure that the 
last name field appears as the first 
column of the Data Table and then click 
the D Quick Find button.

   

Using the Find Dialog
The Find dialog allows you to easily find records based on the text they 
contain. To open the Find dialog, open the Edit menu and choose Find 
Record.
There are three methods for searching using the Find dialog:
• Simple searches for specific text in a specific field.
• Standard searches for specific text in any field.
• Advanced searches using multiple criteria.
DataBase looks for the first record that matches your criteria, and displays 
it in the Data Entry window, or highlights it in the Data Table.
The different search methods are explained in the following sections. 
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Using a Simple Search
A Simple search allows you to search for records containing specific text 
in a specific field. 
1. Open the Edit menu and choose Find Record to open the Find dialog. 

2. Click the Simple tab at the top of the Find dialog.
3. Click in the Find What box and type the text you want to find.

This isn’t a case-sensitive search, so it doesn’t matter whether or not 
you use capital letters.

4. Click the In Field list, and choose the field that you want to search.
Calculated fields aren’t 
listed in the Find dialog.

 
If you aren’t sure which field might contain the text, use a Standard 
search (see “Using a Standard Search” on page 90).

5. Click OK.   
DataBase displays or highlights the first record that contains the specified 
text. If it isn’t the record you’re looking for, open the Edit menu and 
choose Find Next, or enter stricter criteria in the Find dialog.
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Using a Standard Search
A Standard search allows you to search for records with specific text 
contained in any field.
1. Open the Edit menu and choose Find Record to open the Find dialog. 

2. Click the Standard tab at the top of the Find dialog.
3. Click in the Find What box and type the text you want to find.
4. Choose the other options you want to use:

• Mark Match Case to perform a case-sensitive search, so the 
upper and lower case letters in the text must be an exact match. 
For example, searching for “Smith” would find “Smith” but not 
“smith” or “SMITH.”

• Mark Find Whole Words Only to search only for records where 
the text is separated from any other text. For example, searching 
for “John” would find “John Smith” but not “Ken Johnson.”

5. Click OK.
DataBase displays or highlights the first record that contains the specified 
text. If it isn’t the record you’re looking for, open the Edit menu and 
choose Find Next, or enter stricter criteria in the Find dialog.
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Using an Advanced Search
An Advanced search allows you to search for records using multiple 
criteria, such as text contained in a field.
1. Open the Edit menu and choose Find Record to open the Find dialog. 

2. Click the Advanced tab at the top of the Find dialog.
3. Click in the top-left box and choose the field you want to search.
4. Click in the top-middle box and choose a criterion for the search.
5. If necessary, click in the top-right box to enter the text or number you 

want to find.
This isn’t a case-sensitive search, so it doesn’t matter whether or not 
you use capital letters.

6. Use the other boxes in the dialog to add more criteria to the search.
DataBase applies search criteria to each record individually. If you 
use multiple criteria, consider your conditional statements carefully:
• Combining criteria with And means that all of the search criteria 

must be found in the same record.
• Combining criteria with Or means that at least one of the search 

criteria is in the record.
For example, if you want to find the record for a customer whose last 
name is either Smith or Johnson, search for records where the last 
name field is Smith Or Johnson. If you used And, DataBase would try 
to find a record that contained both “Smith” and “Johnson” in the last 
name field. 

7. Click OK.
DataBase displays or highlights the first record that contains the specified 
text. If it isn’t the record you’re looking for, open the Edit menu and 
choose Find Next, or enter stricter criteria in the Find dialog.
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Finding a Record by Number
Find a specific record by entering its number in the Go To dialog.
The record numbers appear above the form in the Data Entry window, and 
on the left side of the Data Table.
1. Open the Data menu and choose Go To to open the Go To dialog. 

2. Enter the number of the record you want to display.
3. Click OK.
DataBase displays the record in the Data Entry window or highlights it in 
the Data Table.

Replacing Data
The Replace dialog allows you to search for data in your database and 
make changes to that data automatically.
There are three methods for searching and replacing:
• Simple searches for and replaces specific text in a specific field.
• Standard searches for and replaces specific text in any field.
• Advanced searches and replaces using multiple criteria.
To use the Replace dialog, open the Edit menu and choose Replace. Use 
the tabs at the top of the dialog to choose the search and replace method. 
Then, enter your search and replace criteria and click OK.

Before replacing data in 
your database, you should 
make a backup (see 
“Backing Up Your Files” 
on page 285).

 
The different search and replace methods are explained in detail in the 
following sections. 
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Using a Simple Search and Replace
A Simple search and replace allows you to search for records containing 
specific text in a specific field, and then replace that text.
1. Open the Edit menu and choose Replace to open the Replace dialog. 

2. Click the Simple tab at the top of the Replace dialog.
3. Click in the Find What box and type the text you want to find.

This isn’t a case-sensitive search, so it doesn’t matter whether or not 
you use capital letters.

4. Click the In Field list, and choose the field that you want to search.
If you aren’t sure which field might contain the text, use a Standard 
search and replace (see “Using a Standard Search and Replace” on 
page 94).
Calculated fields aren’t listed in the Replace dialog.

5. Type the new text for the field in the Replace with box.

CAUTION: All of the data 
in the field is replaced with 
the text in the Replace 
With box. If you only want 
to replace some of the text 
in the field, use a Standard 
search and replace (see 
“Using a Standard Search 
and Replace” on page 94).

 
6. Choose how the Replace feature should work:

• If you want to confirm each change, click the Replace button.
• If you want DataBase to make all of the changes automatically, 

click the Replace All button.
If you confirm each change, the Confirm Replace dialog opens every time 
DataBase finds a match. In that dialog, you have the option of making the 
change, skipping to the next match, or starting an automatic replace (see 
“Confirming Replacement Changes” on page 96). 
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Using a Standard Search and Replace
A Standard search and replace allows you to search for records with 
specific text contained in any field, and then replace the text.
1. Open the Edit menu and choose Replace to open the Replace dialog. 

2. Click the Standard tab at the top of the Replace dialog.
3. Click in the Find What box and type the text you want to find.
4. Choose the other options you want to use:
5. Mark Match Case to perform a case-sensitive search, so the upper 

and lower case letters in the text must be an exact match. For 
example, searching for “Smith” would find “Smith” but not “smith” 
or “SMITH.”

6. Mark Find Whole Words Only to search only for records where the 
text is separated from any other text. For example, searching for 
“John” would find “John Smith” but not “Ken Johnson.”

7. Type the new text in the Replace with box. 
Only the text specified in the Find What box is replaced.

8. Choose how you want the Replace feature to work:
• If you want to confirm each change, click the Replace button.
• If you want DataBase to make all of the changes automatically, 

click the Replace All button.
If you confirm each change, the Confirm Replace dialog opens every time 
DataBase finds a match. In that dialog, you have the option of making the 
change, skipping to the next match, or starting an automatic replace (see 
“Confirming Replacement Changes” on page 96).
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Using an Advanced Search and Replace
An Advanced search and replace allows you to search for records using 
multiple criteria, and then replace text in up to four fields at a time.
1. Open the Edit menu and choose Replace to open the Replace dialog.

CAUTION: All of the data in 
the field is replaced with the text 
in the Replace With box. If you 
only want to replace some of the 
text in the field, use a Standard 
search and replace (see “Using 
a Standard Search and Replace” 
on page 94).

  

2. Click the Advanced tab at the top of the Replace dialog.
3. Click in the top-left box and choose the field you want to search.
4. Click in the top-middle box and choose a criterion for the search.
5. If necessary, click in the top-right box to enter the text or number you 

want to find.
NOTE: This isn’t a 
case-sensitive search, 
so it doesn’t matter 
whether or not you 
use capital letters.

  
6. Use the other boxes in the dialog to add more criteria to the search.

DataBase applies the search criteria to each record individually. If you 
use multiple criteria, consider your conditional statements carefully:
• Combining criteria with And means that all of the search criteria 

must be found in the same record.
• Combining criteria with Or means that at least one of the search 

criteria is in the record.
For example, if you want to find the record for a customer whose last 
name is either Smith or Johnson, search for records where the last 
name field is Smith Or Johnson. If you used And, DataBase would try 
to find a record that contained both “Smith” and “Johnson” in the last 
name field.

7. Use the Replace portion of the dialog to choose up to four fields you 
want to change and to enter the new data for the chosen fields.
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8. Choose how you want the Replace feature to work:
• If you want to confirm each change, click the Replace button 

(see “Confirming Replacement Changes” on page 96).
• If you want DataBase to make all of the changes automatically, 

click the Replace All button. 

Confirming Replacement Changes
Unless you clicked the Replace All button in the Replace dialog, 
DataBase asks you to confirm the changes whenever it finds a record that 
meets your search criteria.

The Confirm Replace 
dialog lists all of the 
changes that will be 
made to the record.

  

Choose how you want the Replace feature to work:
• To confirm this change, click the Replace button.
• To have DataBase change all of the remaining records automatically, 

click the Replace All button.
• To continue checking the file without changing the displayed record, 

click Skip.
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Sorting and Filtering Data

Overview
DataBase provides powerful tools for helping you manipulate the data in 
your database. You can search and replace data, sort your data, filter your 
data, and automatically remove duplicate records.
The sort and filter information is saved separately with each user, allowing 
users to arrange the records in the way that works best for them.
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Sorting Your Data
You can sort your database to change the order that the records are printed 
and displayed in the Data Table and Data Entry windows. If you want to 
change the field that appears in the Index area on the left side of the Data 
Entry window, sort your records by the field you want to appear.
The easiest way to sort your records is by sorting the columns in the Data 
Table (see “Sorting Records in the Data Table” below). 
You can perform multi-level sorts using the Sort dialog (see “Using the 
Sort Dialog” on page 99).

NOTE: New records aren’t sorted automatically. Sort your 
database again after adding records.

 

Sorting Records in the Data Table
1. Click the Data Table tab to open the Data Table window.
2. Right-click on the heading of the column you want to sort by to open 

a shortcut menu.  

3. Choose your sort option from the shortcut menu.
• To sort your records in alphabetical order, choose Sort 

Ascending.
• To sort your records in reverse alphabetical order, choose Sort 

Descending.
After sorting, the number one appears in the column heading next to a 
triangle indicating the method of sorting the data in that column.
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Using the Sort Dialog
Use the Sort dialog to change the order that your records appear and print. 
You can also use the Sort dialog to change the field that appears in the 
Index area of the Data Entry window. In addition, the Sort dialog is used to 
create a Custom Sort for a Standard Report (see “Sorting Records for the 
Standard Report” on page 248).
1. Open the Data menu and choose Sort.

New records aren’t sorted 
automatically. Sort your 
database again after 
adding records.

  

You can sort the database in ascending (A–Z) or descending (Z–A) 
order using any field. DataBase can also sort up to three levels deep, 
so if two records have the same data in one field, they can be sorted 
by a different field.

2. Choose the sort field(s) from the list boxes.
If two or more records have the same data in the first sort field, those 
records are sorted according to the second field. If records have the 
same data in both the first and the second sort field, they’re sorted 
using data from the third field.

3. Choose the order of the sort (ascending or descending) for each field.
If you want a record to be sorted by the next sort field when the first 
sort field is blank, mark the Interlace check box.

4. Click OK to sort the current file.
For example, with the sort fields set as shown in the Sort dialog above, 
these records would be placed in the following order:

Last Name First Name Company
1. Andrews Sarah Treasured Possessions
2. Andrews W. M. W. M. Andrews Company
3. Boulrese Mary Century Personnel
4. (blank) (blank) Courier Customizing
5. Curry Margaret JoSaac Engineering

 

After sorting, numbers indicating the sort order appear in the Data Table 
column headings next to a triangle indicating the method of sorting the 
data in that column.
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Filtering Records
Filtering allows you to view and print only those records that meet the 
criteria you set.
There are three methods of filtering:
• Simple includes records that contain specific text in a specific field.
• Standard includes records that contain specific text in any field.
• Advanced includes records based on multiple filter criteria. You can 

save the criteria of an advanced filter to use it again.
To set your filter criteria, open the Data menu and choose Filter or click 
the Filter Records button in the toolbar to open the Filter dialog. Use the 
tabs at the top of the Filter dialog to choose the filtering method. Then, 
enter your filter criteria and click OK. After filtering, DataBase hides the 
records that don’t meet your criteria.

Filter Records

  
To turn off the filter and see all of your records, open the Data menu and 
choose Display All Records.

NOTE: If you want to select or print specific records from 
your list, select them in the Data Table window (see 
“Selecting a Group of Records” on page 108).

The different filtering methods are explained in the following sections.
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Using a Simple Filter
The Simple filter allows you to display records that contain specific text in 
a specific field. The field doesn’t need to be on the current form.
1. Open the Data menu and choose Filter or click the Filter Records 

button in the toolbar to open the Filter dialog.

Filter Records

  

2. Click the Simple tab at the top of the Filter dialog.
3. Click in the Find what box and type the text you want to include.

This isn’t a case-sensitive search, so it doesn’t matter whether or not 
you use capital letters.

4. Choose the field that should contain the text from the In Field list.
If you’re not sure which field may contain the text, use a Standard 
filter (see “Using a Standard Filter” on page 102).

5. Click OK.
The filter searches your file, and then displays only those records that 
meet the filter criteria. The rest of your list is hidden from view until you 
turn the filter off.
To turn the filter off and see all of your data, open the Data menu and 
choose Display All Records.
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Using a Standard Filter
The Standard filter allows you to search for records with specific text in 
any field. The field doesn’t need to be on the current form.
1. Open the Data menu and choose Filter or click the Filter Records 

button in the toolbar to open the Filter dialog.

Filter Records

  

2. Click the Standard tab at the top of the Filter dialog.
3. Click in the Find what box and type the text you want. 

Records that include this text are displayed.
4. Choose the other options you want to use:

• Mark Match Case to make the filter case-sensitive, so that the 
upper and lower case letters in the text must be an exact match. 
For example, typing “Smith” would include “Smith” but not 
“smith” or “SMITH.”

• Mark Find Whole Words Only to only look for records where 
the text is separated from any other text. For example, typing 
“John” would include “John” but not “Johnson.”

5. Click OK to filter your list.
The filter searches your file, and then displays only those records that 
meet the filter criteria. The rest of your list is hidden from view until you 
turn the filter off.
To turn the filter off and see all of your records, open the Data menu and 
choose Display All Records.
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Creating an Advanced Filter
The Advanced filter allows you to filter records based on multiple criteria, 
such as text contained in a field or the status of a check box. You can 
create several sets of filter criteria and save them to use them again.
1. Open the Data menu and choose Filter or click the Filter Records 

button in the toolbar to open the Filter dialog.

Filter Records

  

2. Click the Advanced tab at the top of the Filter dialog.
3. Click the New Filter button to create a new filter.

If you want to edit an existing filter, choose the filter from the Filter 
Name drop-down list. For more information, see “Modifying an 
Advanced Filter” on page 104.

4. Enter a name for the new filter in the Filter Name box.
5. Enter the criteria for the filter.This isn’t a case-sensitive 

search, so it doesn’t matter 
whether or not you use 
capital letters.

 
DataBase applies the filter criteria to each record individually. If you 
use multiple criteria, consider your conditional statements carefully:
• Combining criteria with And means that all of the filter criteria 

must be found in the same record.
• Combining criteria with Or means that at least one of the filter 

criteria is in the record.
For example, if you want to display only the records from Arizona 
and California, filter for records where the state field is AZ Or CA. If 
you used And, DataBase would try to find records that contained both 
AZ and CA in the state field.

6. Click Save and Apply to apply and save the filter.
The filter searches your file and then displays only those records that meet 
the filter criteria. The rest of your list is hidden from view until you turn 
the filter off.

To turn the filter off and 
see all of your records, 
open the Data menu and 
choose Display All Records.  
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Modifying an Advanced Filter
After creating an advanced filter, you can Edit, Delete, or Copy the filter. 

To Edit an Advanced Filter
1. Choose the filter from the Filter Name drop-down list.
2. Make any changes that you want to the current filter.

The changes you make will be saved with this filter. If you want to 
keep the current filter and make a new filter based on similar criteria, 
you can copy the selected filter and give it a new name (see “To Copy 
an Advanced Filter” on page 104).

3. Click Save and Apply.

To Delete an Advanced Filter
1. Choose the filter from the Filter Name drop-down list.
2. Click Delete Filter.
The filter is removed from the Filter Name list. If you deleted a filter by 
mistake, click the Cancel button to close the dialog.

To Copy an Advanced Filter
1. Choose the filter from the Filter Name drop-down list.
2. Click Copy Filter.
3. Enter a name for the new filter in the Filter Name drop-down list.
4. Make any changes that you want to the filter criteria (see “Creating an 

Advanced Filter” on page 103).
5. Click Save and Apply.

The original filter name and 
the new filter name appear 
in the Filter Name list.
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Choosing an Advanced Filter
You can choose and apply a saved filter using the Filter Chooser palette. 
To open the Filter Chooser palette, open the Data menu and choose 
Choose Filter or click the Choose Filter button in the toolbar.

Choose Filter
  

• To apply a saved filter to your data, choose the filter from the list.
• To modify a saved filter, double-click the filter in the list or right-click 

the filter and choose Edit Filter from the shortcut menu.
• To delete a filter, right-click the filter in the list and choose Delete 

Filter from the shortcut menu.
• To create a new filter, right-click the filter list and choose New Filter 

from the shortcut menu.
• To turn off all filters and display all of your records, choose Display 

All Records from the list.
The Filter Chooser palette can remain open, allowing you to choose and 
apply the filters you’ve saved. To close the Filter Chooser palette, click 
Close.
For information about creating and editing an advanced filter, see 
“Creating an Advanced Filter” on page 103.
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Managing Records

Overview
DataBase allows you to select a single record or multiple records for 
printing, copying, or deleting. You can also remove duplicate records form 
your database.
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Selecting a Group of Records
You can select a single record by clicking on any of the fields for that 
record in the Data Table window. When you return to the Data Entry 
window, the selected record appears.
To select a group of records, use one of the following methods:
• To select a group of consecutive records, click and drag along the 

record numbers on the left side of the Data Table window to highlight 
the records you want in the group. You can also select consecutive 
records by clicking the first record number in the group, and then 
holding the SHIFT key down and clicking the last record number in the 
group.

Click the record number for 
the first record in the group.

Hold down the SHIFT key and 
click the record number for 
the last record in the group.

   

• To select non-consecutive records, hold the CTRL key down and click 
each record number.

Hold down the CTRL key and 
click each record number that 
you want to include in the 
group.

   

You can use the Find dialog or the Sort dialog to help locate the records 
you want to select.
To remove a selected record from the group, hold down the CTRL key and 
click the record’s number.
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Removing Duplicate Records
DataBase can search for and remove duplicate records from your file. This 
can be a useful feature if you have gathered addresses from several 
different sources.
1. Open the Data menu and choose Search for Duplicates to open the 

Search for Duplicates dialog.

Because there might be errors 
or incomplete data in some 
records, you might need to 
search for duplicates several 
times using different criteria 
to remove all of the duplicate 
records from your database.

  

2. Choose which fields you want DataBase to use when comparing 
records.
Choose the fields carefully, since duplicate records might not be exact 
matches of each other. Using too many fields might not find some of 
the duplicates, but using too few fields might remove non-duplicate 
records.
For example, if you use the first name field, an error in one of the 
records would prevent it from being identified as a duplicate. If you 
don’t use the first name field, the records for two brothers living at the 
same address might be identified as duplicates.

3. Choose either automatic or manual confirmation of duplicate records:
• To automatically remove any records that meet the criteria you 

enter, mark the Auto-purge check box.
• To verify the duplicates yourself, clear the Auto-purge check 

box.
4. Decide whether you want to delete the duplicates or store them in a 

separate file.
To create a file for the duplicates, choose Moved to File and then 
click the Browse button to choose a name and location for the file.

5. Click OK to begin searching for possible duplicates.
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Verifying Duplicates
Unless you chose the Auto-purge option in the Search for Duplicates 
dialog, DataBase opens the Confirm Duplicates dialog each time it finds a 
set of suspected duplicates. 

To resize the columns so you can see your data better, position the cursor 
on the line between two field names. Then, click and drag the column. 
Release the mouse button to set the new column width.
1. Choose the records that you want to keep in your database by marking 

the Keep check boxes on the left side of the records.
• To keep all of the records listed in the dialog, click Keep All.
• To remove all of the records listed in the dialog, click Remove 

All.
• To return to the standard settings, so that only the last record from 

each set of duplicates is marked, click Restore Defaults.
2. Click OK to remove the records from your database. Click Cancel if 

you don’t want to make any of the changes.

Deleting Records
You can delete a single record or a group of records.
• To delete a single record, view it in the Data Entry window or select it 

in the Data Table window, and then press DELETE.
• To delete a group of records, select the records in the Data Table 

window and press DELETE, or use the Delete Record dialog to delete a 
group of consecutive records.

For information about selecting records in the Data Table window, see 
“Selecting a Group of Records” on page 108.
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Deleting Consecutive Records
To delete consecutive records, select the records in the Data Table window 
and press DELETE, or use the Delete Record dialog.
To use the Delete Record dialog:
1. Open the Edit menu and choose Delete Records to open the Delete 

Record dialog. 

2. Enter the first number of the group in the From box and the last 
number of the group in the Through box.

The record numbers 
appear above the 
record in the Data 
Entry window, and 
on the left side of the 
Data Table.

 
If you’re only deleting one record, enter the same record number in 
both boxes.

3. Click OK.
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OUTPUT FORMS

Choosing a Form for Printing 115

Customizing a Form Design 123

Creating a New Form Design 129

Working With Design Objects 141

Aligning Objects 147

Adding Text to a Form 155

Adding Pictures and Drawing Objects 169

Using Barcodes 183
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Choosing a Form for Printing

Overview
DataBase comes with several pre-designed labels and forms in the most 
popular sizes. If the form you’re looking for isn’t in the Forms Library, 
you can choose from a more extensive list in the Change Form Size dialog 
or create your own custom form size.
Regular users can customize only the forms in their Personal Output 
Forms list. The forms in the Shared Output Forms list and the Data 
Entry Form can be customized only by the database administrator.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login. You can’t add a form from a Regular user’s 
Personal Output Forms list to the Shared Output Forms list.
Regular user’s can copy forms from the Shared Output Forms list to their 
Personal Output Forms list. However, you can’t add a form from a 
Regular user’s Personal Output Forms list to the Shared Output Forms 
list.
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Viewing the Form Library
To display the Output Forms Window, click the Output Forms tab. A list 
of form types appears on the left side of the Output Forms window.

The Forms Library on the 
left side of the Output 
Forms window displays 
the different form designs 
in the file.

  

Using the Forms Library, you can choose or change the form displayed in 
the Output Forms window, rename existing forms, organize the list of 
forms, and create new forms.
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Choosing From the Form Library
To change the form that appears in the Output Forms window, choose a 
different form from the Forms Library. To view the Forms Library, click 
the Output Forms tab.
Regular users can choose from the Shared Output Forms list and their 
Personal Output Forms list.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
1. Double-click a folder to open it.

The different types of forms 
are organized into folders.

  

2. Click the form name that you want. 
The selected form appears on the right side of the window.

NOTE: If you have created a Custom Database, there 
will be no forms in the list until you create them (see 
“Creating a New Form” on page 119).

 

Renaming Forms and Folders
Regular users can only rename forms and folders in their Personal Output 
Forms list.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
1. Click the Output Forms tab to view the Forms Library.
2. Right-click the form or folder name that you want to change.
3. Choose Rename from the shortcut menu. 
4. Type the new name for the form or folder.
5. Press ENTER.
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Adding New Folders
Add new folders to organize your forms and folders in the Forms Library.
Regular users can only add new folders to their Personal Output Forms 
list.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
1. Click the Output Forms tab to view the Forms Library.
2. Choose a level for the folder:

• To place the new folder on the first level, right-click the file 
cabinet icon at the top of the list. 

File Cabinet
 

• To create a folder within a folder, right-click the folder where you 
want to place the new folder.

For example, if you want to create a Personal folder within your 
Address Labels folder, right-click the Address Labels folder in the 
Forms Library.

3. Choose New > New Folder from the shortcut menu that opens.
4. Type the name for the new folder.
5. Press ENTER.

Copying and Moving Forms Between Folders
Copying forms is a good way to begin a new form without starting from 
scratch. Moving forms can help you organize the forms in the Forms 
Library.
Regular users can fully customize their Personal Output Forms list. 
However, they can only copy from the Shared Output Forms list.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login. You can’t add a form from a Regular user’s 
Personal Output Forms list to the Shared Output Forms list.
Although Regular user’s can copy forms from the Shared Output Forms 
list to their Personal Output Forms list, they can’t add a form from their 
Personal Output Forms list to the Shared Output Forms list.
• When you “copy” a form, you make a copy of the original form and 

insert (paste) it into another location. The original form remains 
unchanged.

• When you “move” a form, you remove (cut) it from one location and 
insert (paste) it into another location.
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To Copy or Move a Form to Another Folder
Click the Output Forms tab to view the Forms Library.
1. Click on the folder or form that you want to copy or move.
2. Open the Edit menu and choose the option that you want to use:

• To make a copy of the item, choose Copy.
• To move the item, choose Cut.

3. Click on the folder where you want the form or folder.
If you want to make a copy of the form in the same folder as the 
original, click on the original folder.

You can only copy or move 
forms and folders in the 
same DataBase file. You 
can’t paste a form from one 
file into another file.

 
4. Open the Edit menu and choose Paste. 

Creating a New Form
The easiest way to create a new form design is make a copy of an existing 
form, and then customize it.
• For information about copying an existing form, see “Copying and 

Moving Forms Between Folders” on page 118.
• For information about customizing an existing form, see 

“Customizing a Form Design” on page 123.
Regular users can only add forms to Personal Output Forms list.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
If you want help starting the design of your new form, open the Format 
menu and choose New Form Using Wizard to start the Form Wizard. For 
information about using the Form Wizard, see “Using the Form Wizard” 
on page 130.
To create a new form without using the wizard, see “Designing a Form 
From Scratch” on page 139.
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Deleting Forms and Folders
You can delete forms or folders you don’t need.
Regular users can only delete forms and folders from their Personal 
Output Forms list.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
1. Click the Output Forms tab to view the Forms Library.
2. Right-click the folder or form that you want to delete.

CAUTION: Deleting a folder also deletes any forms 
contained within that folder.

 

3. Choose Delete from the shortcut menu.
A dialog opens to confirm that you want to delete the item.

4. Click Yes to delete the item.

Choosing From the Change Form Size Dialog
If you like the design of a form, but it isn’t set up for the correct form size 
or type, you can easily change it to the size or type you need.
For example, you can change the form from a 4" x 1" label to a 4¼" x 2" 
label, or from a shipping label to an envelope.
Regular users can only change the forms in their Personal Output Forms 
list.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
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To Change the Form Size
1. Open the Format menu and choose Change Form Size, or click the 

Change Form Size button, to open the Change Form Size dialog.
Change Form Size

  

2. Narrow the list of choices by doing one or all the following:
• If you have already purchased form stock that you want to print 

on, such as a box of shipping labels, type the part number into the 
Part Number box. DataBase looks for a match and displays a 
sample sheet in the dialog.

• If you aren’t sure of the part number, choose the Type, Brand, 
and Feed Method to match the type of form you have.

If you aren’t sure about the choices in a drop-down list, choose All.
3. Use the list at the bottom of the dialog to find the form size and type 

you want.
To sort the list by size, description, or part number, click on a column 
heading. For example, click on Description to sort the list by the 
descriptions.

4. Click on the form size you want to preview the selected item.
If the preview doesn’t quite match your forms, you might want to use 
it as the basis for a custom form size (see “Creating a Custom Form 
Size” on page 122).

5. When the preview matches your form, click OK.

CAUTION: If the preview doesn’t match, you might be 
trying to print on photocopier labels, and not labels for laser 
or ink-jet printers. If this is the case, consider buying new 
labels. Photocopier labels weren’t designed to withstand the 
heat or bending that occurs in printers, and might damage 
your printer.
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Creating a Custom Form Size
If you don’t see the form size you want, you can create a new size.

CAUTION: If you’re designing a form, and you don’t see 
the size you need in the Change Form Size dialog, you 
might be trying to use photocopier labels instead of labels 
made for laser or ink-jet printers. If this is the case, consider 
buying new labels. Photocopier labels weren’t designed to 
withstand the heat or bending that occurs in printers, and 
might damage your printer.

 

To Make a Custom Form Size
1. Open the Format menu and choose Change Form Size to open the 

Change Form Size dialog.
2. Choose the form size closest to what you want.
3. Click the Custom button to open the Customize Size dialog.

Depending on the form you 
selected, the Custom 
button might be dimmed to 
indicate it can’t be 
customized.

 
4. Enter a description and the specifications for the new size.
5. Click the Preview button to see how the changes affect the page.
6. Click OK to return to the Change Form Size dialog.
7. Click OK in the Change Form Size dialog to change the current form 

to the new size.
The custom size is available in the Change Form Size dialog from now on, 
but it’ll only be available for the current file. If you open another file, 
you’ll have to create the custom size again.

Buying Paper for Your Labels and Forms
DataBase works with any label or form size you can find. Many form sizes 
are listed in the Change Form Size dialog, or you can make a custom size. 
Most computer and office supply stores offer a wide selection of these 
forms. Forms and labels can also be ordered directly from the 
manufacturer. Ordering forms direct can often be less expensive.
For ordering information, open the Help menu and choose Ordering 
Information.

NOTE: Don’t use photocopier labels. Photocopier labels 
weren’t designed to withstand the heat or bending that 
occurs in printers, and might damage your printer.
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Customizing a Form Design

Overview
Although DataBase has many forms that cover most needs, there will be 
times when you want to customize a form. 
Regular users can only customize the forms in their Personal Output 
Forms list. The forms in the Shared Output Forms list and the Data 
Entry Form can only be customized by the database administrator.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login. 
Regular user’s can copy forms from the Shared Output Forms list to their 
Personal Output Forms list. However, you can’t add a form from a 
Regular user’s Personal Output Forms list to the Shared Output Forms.
To modify the Data Entry Form open the Edit Data Entry Form window 
(see “Entering Data in the Data Entry Window” on page 69). If you’re 
satisfied with the design in the Data Entry window, you can print it (see 
“Printing the Data Entry Form” on page 70).
You can change the design of a form you want to print in the Output Forms 
window. For example, you can change a form size from a 3" x 1" address 
label to a 5" x 2" shipping label by opening the Format menu and 
choosing Change Form Size or by clicking the Change Form Size 
button. For more information about changing the form size, see “Choosing 
a Form for Printing” on page 115.  

Change Form Size

 
In the Output Forms window, you can move, resize, and add objects to the 
form. Use the tools along the right side of the window to change the 
form’s design.

NOTE: You can’t enter or edit your records in the Output 
Forms window.
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Editing Your Form Design
Before you begin designing a form, read the following sections to learn 
about the type of form you’re designing.
Regular users can only customize the forms in their Personal Output 
Forms list. The forms in the Shared Output Forms list and the Data 
Entry Form can only be customized by the database administrator.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login. 
Regular user’s can copy forms from the Shared Output Forms list to their 
Personal Output Forms list. However, you can’t add a form from a 
Regular user’s Personal Output Forms list to the Shared Output Forms 
list.

Designing Labels, Cards, and Envelopes
If you’re designing labels, cards, or envelopes, the design displayed in the 
window is a representation of a typical record. Use the toolbar on the left 
side of the Output Forms window to add fields, text, and graphics.
The design on-screen should look almost exactly like you would want a 
printed label, card, or envelope to look.

Designing Booklets
Booklet forms print several records on one page. When you design a 
booklet form, your form shows how one record will appear on the page. 
The number of records that actually print on the page depends on the form 
size and type. You can check or change the form size by opening the 
Format menu and choosing Change Form Size.
The example below illustrates the difference between the design view of 
the booklet and the printed booklet.

Design View: Printed Output:

Record Layout

Header

Record #1

Record #2

Record #3

Footer

  

To edit the header or footer of the booklet pages, open the Format menu in 
the Output Forms window and choose Header/Footer (see “Adding 
Headers and Footers to Booklets” on page 166).
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Designing Form Letters
Form letters can be created in either the Output Forms window or with the 
Email Editor. The method you use to create the form letter depends on the 
layout and content you need to include.
• The Output Forms Window allows for exact placement of text, 

fields, and graphics. This can be essential when creating form letters 
like flyers or advertisements.

• The Email Editor allows you to format fonts, a feature not available 
in the Output Forms window. However, the Email Editor lacks the 
design and placement of fields and text found in the Design window. 
For more information, see “Creating Form Letters” on page 235.

Creating a Form Letter in the Design Window
Designs for form letters are similar to labels. The design should look like a 
typical form letter.
The key to designing form letters is that instead of adding the fields to the 
design, you type the field names into text boxes, along with the text for the 
form letter (see “Adding a Text Box” on page 159). 
When you get to a place where you want to insert data from your database, 
type two less-than signs (<<) followed by the field name, and then type 
two greater-than signs (>>).

Dear <<First Name>>,

Thank you for your interest in My Company

  

Use the Object Toolbar to add text boxes and graphics to your form design 
(see “Adding Text to a Form” on page 155). 
When you print the form letter, the field names are replaced by data. If you 
want to see how the form letter will look, open the File menu and choose 
Print Preview > Active Output Form. The Preview window displays your 
data as it’ll print.
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Customizing the Output Forms Window
You can customize the way the Output Forms Window looks.

Properties Toolbar

Object Toolbar

  

The view of your Output Forms in the work area can be enlarged or 
reduced, the Properties Toolbar and the Object Toolbar can be 
repositioned or removed, and the rulers can be switched on and off. 
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Enlarging or Reducing the Screen View
You can select a percentage to enlarge or reduce the form on the screen 
from the Zoom drop-down list in the main toolbar.  

Other zoom options are available in the Zooming dialog.
1. Open the View menu and choose Zoom, or click the Zoom button in 

the toolbar, to open the Zooming dialog.
Zoom

  

2. Choose the view size you want from the options on the left.
The preview on the right displays how 10-point type will look at the 
zoom level you chose.

3. Click OK.
The Zooming dialog is also available in the Data Entry window.
Zoom options can also be selected from the shortcut menu that pops up 
when you right-click on the work area.

NOTE: Zooming the screen view changes the size that the 
form displays in the Output Forms window or Data Entry 
window. However, it won’t change the actual size of the 
form that is printed.
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Moving the Properties Toolbar
The Properties Toolbar can be attached to the top or the bottom of the 
work area, or it can be left floating. It can also be removed from the 
screen.  

To move the Properties Toolbar:
• Click and drag it to any location on the screen.
• Attach it to the top or bottom of the work area by dragging it until it 

touches or overlaps the edge of the work area.
To switch the Properties Toolbar on or off, open the View menu and 
choose Properties Toolbar.

Moving the Object Toolbar
The Object Toolbar can be attached to the left or the right of the work area, 
or it can be left floating. It can also be removed from the screen.
To move the Object Toolbar:
• Click and drag it to any location on the screen.
• Attach it to the left or right side of the work area by dragging it until it 

touches or overlaps the edge of the Output Forms window.
To switch the Object Toolbar on or off, open the View menu and choose 
Object Toolbar.

Object Toolbar

 

Viewing the Rulers
Use the rulers to help size and align objects on your form. Guidelines 
extend from an object to the rulers when the object is selected.
To switch the rulers on or off, open the View menu and choose Rulers.
To switch the rulers to metric units (centimeters instead of inches):
1. Open the View menu and choose Grid to open the Grid dialog.
2. Mark the Use Metric Units check box at the bottom of the dialog.
3. Click OK.
For more information about grid options, see “Using the Grid” on page 
148.
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Creating a New Form Design

Overview
The easiest way to create a new form design is make a copy of an existing 
form, and then customize it.
• For information about copying an existing form, see “Copying and 

Moving Forms Between Folders” on page 118.
• For information about customizing an existing form, see 

“Customizing a Form Design” on page 123.
Regular users can only add forms to Personal Output Forms list.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
If you want help starting the design of your new form, open the Format 
menu and choose New Form Using Wizard to start the Form Wizard. For 
information about using the Form Wizard, see “Using the Form Wizard” 
on page 130.
To create a new form without using the wizard, see “Designing a Form 
From Scratch” on page 139.
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Using the Form Wizard
The Form Wizard helps you choose the correct form size to match your 
label or paper stock, add a clipart image to your design, and choose the 
fields that you want on the new design. Use the wizard when existing 
forms in the Form Library don’t meet your needs or aren’t easily modified 
for you to use.
After completing the Form Wizard, the DataBase Design window opens 
so that you can further modify the form using the Object toolbar (see 
“Customizing a Form Design” on page 123).
If you find a form in the Form Library that can be modified to meet your 
needs, you can make a copy of the existing form and then customize it in 
the Design window. For information, see “Copying and Moving Forms 
Between Folders” on page 118 and “Customizing a Form Design” on page 
123.

Starting the Form Wizard
1. Click the Design tab to view the Design window.
2. Click the folder in the Form Library where you want to place the new 

form.
3. Open the Format menu and choose New Form Using Wizard to open 

the New Form dialog. 

4. Type a name for the new form and click OK to open the first step of 
the Form Wizard.
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Choosing a Form Size
The Form Wizard allows you to choose the form you want to use for 
printing your records. You can enter the part number and brand, or choose 
from a list that describes the forms.

Entering the Part Number and Brand
When the Form Wizard opens, you can choose the name of the paper 
manufacturer and enter the part number of the label or paper stock. If you 
don’t know this information, click Next. 

1. Enter the part number in the Part Number box. 
The part number probably is printed on the outside of the package of 
labels or cards. If you don’t know the part number, leave this box 
blank.

2. To choose the brand of label or paper stock that you want to use, click 
the Brand drop-down list and choose the brand. 
If you don’t know the brand or can’t find it in the list, choose <All>. If 
you’ve already entered a part number for a brand that isn’t in the list, 
delete the part number in the Part Number box before continuing.

3. Click Next.

NOTE: If you don’t know the part number or the brand, the 
Form Wizard can help you choose a form in the next step.
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Verifying or Choosing a Form
The second step of the Form Wizard allows you to either verify that the 
part number you entered in the previous step matches your label or paper 
stock or to choose a form from the list.

Verifying a Form
The Part Number and Brand you entered in the first step of the Form 
Wizard appear in Step 2. 

If you entered a part number, the form size and description are selected in 
the list and a sheet preview appears on the right side of the dialog.
Verify the information in the display to make sure that it matches the form 
you want to use.
• If the information is correct, click Next to open the next step of the 

Form Wizard.
• If the information isn’t correct, make sure that the part number is 

entered correctly or choose a form from the list (see “Choosing a 
Form” on page 133).

If you entered only the brand in the first step, the forms of the brand you 
entered are listed in the description list in step 2. You can scroll the list of 
forms to choose the form you want to use (see “Choosing a Form” on page 
133).
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Choosing a Form
If you didn’t enter a part number in the previous step of the Form Wizard, 
you can choose the form in the list displayed in Step 2. 

You can reduce the number of forms listed by entering information in the 
Printer Type, Brand, or Label Type drop-down lists.
1. Click in the Printer Type drop-down list and choose your printer type.

• Choose Form Feed to display continuous-feed forms.
• Choose Sheet Feed to display forms designed for use in a laser 

or ink-jet printer.
• Choose Both to display both Form Feed and Sheet Feed forms in 

the form list.
2. Click in the Label Type drop-down list to choose the type of form 

you’re using, such as address label, envelope, or shipping label.
If you’re not sure of the form type, choose <All>.

3. Scroll down through the list and click a form description to display a 
preview of the forms on the right.

4. After you choose a form that matches the labels or cards you’re using, 
click Next to view the next step in the Form Wizard.

NOTE: If you can’t find your forms in the list, choose the 
closest match. You can customize the form size (see 
“Creating a Custom Form Size” on page 122).

Choosing an Image File
The third step of the Form Wizard allows you to choose an image file to 
place on your form. You can choose a clipart image from the DataBase 
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Clipart folder or choose an image file of your choice. After you’re finished 
using the Form Wizard, you can modify the image and add more graphics 
to your form. 

1. Click the Select Image button to open the Pick Picture dialog. 

2. Choose the image file that you want to place on your form.
For more information 
about adding images to 
your forms, see “Adding 
Clipart” on page 172.

 
3. Click OK to view the clipart on the right side of the Form Wizard.

To place the image as a background on your form, check the Use 
Image for Background box in the Form Wizard (see “Adding a 
Background Image” on page 170).

4. When you’re finished adding the image to your form, click Next.
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Choosing the Type of Form Design
In the fourth step of the Form Wizard, you can choose the type of form 
you want to design. 

• Address label lets you choose the address information that you want 
to include on your form (see “Adding an Address to Your Form” on 
page 136).

• Other lets you choose any of the available fields to place on your 
form (see “Adding Fields to Other Kinds of Labels” on page 138).

After choosing one of these two options, click Next to continue.
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Adding an Address to Your Form
If you chose to create an Address label in the previous step, the Form 
Wizard displays the following step for choosing the address information 
that you want on your form. 

In this step of the Form Wizard you can enter your return address and 
choose to add a mailing address to your form.
To create a return address in the Form Wizard, check the Place a return 
address on your label box.
Click in the return address box and type the return address that you want to 
print on your forms.
To add a mailing address, check the Place a mailing address on your 
label box. After the Form Wizard closes, the Mailing Address dialog 
opens allowing you to choose a mailing address type. For information 
about choosing a mailing address type, see “Selecting a Mailing Address” 
on page 137.
To close the Form Wizard, click Finish.
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Selecting a Mailing Address
When you choose Place a mailing address on your label, the Mailing 
Address dialog opens.
The Mailing Address dialog allows you to choose the group of fields for 
the address. These fields are placed inside of an Alignment Box. An 
Alignment Box keeps the fields in a group, so they can be moved as a unit. 
It also suppresses blank lines and extra spaces and can optionally shrink 
text to fit within the box when the forms are printed. For more information 
about using alignment boxes, see “Using an Alignment Box” on page 150. 

1. Choose an address type in the list at the top of the dialog.
The fields included in each mailing address type are listed in the 
lower box.

2. Click OK to close the Mailing Address dialog and open the Design 
window.

3. Move the cursor to the work area and click to place the address fields 
there.

For information about modifying the form design, see “Customizing a 
Form Design” on page 123.
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Adding Fields to Other Kinds of Labels
You enter the data for your forms in fields, such as Last Name, Address, or 
Work Phone. The field names describe the data contained in the field.
When you select Other, rather than Address label, as your label type in 
the New Label Wizard, you can add to your label many available fields.

Choose the fields you want from the Available Fields list. The fields in 
the Fields to be Placed on Label list are placed on your form.

To add a field to the Fields to be Placed on Label list, choose the 
field from the Available Fields list and then click the right double-
arrow button located in the middle of the dialog.
To remove a field from the Fields to be Placed on Label list, click 
the field listed on the right and then click the left double-arrow 
button.

When you’re working with your form in the Design window, you can add 
fields, move fields, and remove fields. For more information about adding 
fields to your form, see “Adding Fields for Data” on page 156.
When you’re finished choosing the fields, click Finish.
For information about modifying the form design, see “Customizing a 
Form Design” on page 123.
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Designing a Form From Scratch
You can create a new label without using the New Label Wizard.
1. Click the Output Forms tab to view the Output Forms window.
2. Click the folder in the Form Library where you want to place the new 

form.
3. Open the Format menu and choose New Form to open the New Form 

dialog.

4. Type a name for the new form and click OK to open the Change Form 
Size dialog.

5. Choose the type (label, envelope, etc.) and size of the new form (see 
“Choosing From the Change Form Size Dialog” on page 120).

6. Click OK in the Change Form Size dialog to open the Design window.
The new design name appears in the folder for the label-type you 
selected.

7. Use the Design window to design the form (see “Customizing a Form 
Design” on page 123).
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Working With Design Objects

Overview
An object is an item you can move, resize, add, or remove from the form. 
Objects include text boxes, fields, clipart, rectangles, circles, lines, and 
OLE objects. Before you can work with an object, you need to select it.
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Selecting a Single Object
Select a single object by clicking on it. A selected object has a rectangular 
frame.  

To cancel the selection of an object, click anywhere on the work area away 
from the object.
To select an object within an already selected object, cancel the selection 
of the larger object, and then click the smaller object to select it.

The bug can’t be selected, 
because it’s inside of the 
selected circle.

Click on the work area, away 
from the circle, to cancel the 
selection of the circle.

Click on the bug to select it.

   

NOTE: You can also cancel the selection of an object by 
clicking the arrow button in the Object Toolbar.
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Selecting a Group of Objects
Several objects can be selected together to allow you to move, copy, or 
delete them as a group.
Select a group of objects by holding the SHIFT key down and clicking on 
each object.
A group can also be selected by clicking and dragging to place a lasso on 
or around the desired objects. Any objects within or touching the borders 
of the lasso will be selected.

Start the Lasso outside of 
any objects on your form.

Drag the Lasso around any part 
of an object to include it in the group.

   

To select all of the objects in your form, open the Edit menu and choose 
Select All.
To cancel the selection of an object from a group, hold down the SHIFT key 
and click on it.
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Moving and Sizing Objects
A selected object is framed by a box with small rectangles in the corners 
and triangles on the sides. These small rectangles and triangles are the 
“handles” that allow you to resize the object. Clicking on a selected object 
and holding the mouse button down allows you to move or size the object.

Click and drag the edge of an 
object to move the object. 

Click and drag one of the 
handles on the edge of an 
object to size the object.

  

The shape of the cursor indicates whether clicking and dragging will move 
or size the object.
• Crossed arrows appear below the cursor to allow you to move an 

object when you click on the edge of the object.  
• A double-headed arrow appears to allow you to change the size of an 

object when you click on the object’s handle.   
To delete an object from the form, select the object, and then press the 
DELETE key.
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Changing the Object Stacking Order
As you move objects in the design, they might overlap each other. You can 
move overlapped objects in front or in back of other objects to change how 
the objects display and print.
1. Click the object to select it.
2. Open the Format menu and choose a Placement option to change the 

object’s position:
• To move the object one level closer, choose Placement > Bring 

Forward.
• To send the object one level deeper, choose Placement > Send 

Back.
• To move the object to the top of the stack, choose Placement > 

Bring to Front.
• To move the object to the bottom of the stack, choose Placement 

> Send to Back. 
For example, if a picture is hiding a text box, you can change the stacking 
order so that the picture is behind the text. To do this, select the picture, 
and then open the Format menu and choose Placement > Send to Back.  
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Aligning Objects

Overview
DataBase give you three ways to align the objects on a form:
• Use the Grid to manually align objects along the grid lines (see 

“Using the Grid” on page 148).
• Use the Align dialog to align several objects relative to each other. 

For example, you could use the Align dialog to line up clipart with the 
top of your return address (see “Using the Align Dialog” on page 
149).

• Use alignment boxes to “pack” your fields together so that blank 
fields don’t cause blank lines when you print (see “Using an 
Alignment Box” on page 150).
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Using the Grid
You can display a grid to help you place objects on your form. Arrange the 
objects using the grid, or have DataBase automatically “snap” the objects 
to the nearest grid lines as you move them.If the objects on your 

design don’t move smoothly, 
the Snap objects to Grid 
check box might be marked. 
Clear this check box to 
allow fine-tuning of object 
placement.

 
1. Open the View menu and choose Grid to open the Grid dialog. 

2. Enter your grid settings:
• Mark Display Grid if you want to display a grid on the form 

design. The grid doesn’t print.
• Mark Snap to Grid if you want the objects to “snap” to the 

nearest grid lines when you move them.
3. Choose a style for displaying the grid:

• Choose Grid Lines to overlay grid lines on the design.
• Choose Grid Dots to overlay dots at the intersection of each grid 

line.
4. Type or choose the grid spacing in the Height and Width boxes.

If you want to display the rulers and grid using centimeters instead of 
inches, mark the Use Metric Units check box.

5. Click OK to accept the settings.

NOTE: The grid is for display purposes only. It won’t print.
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Using the Align Dialog
Use the Align dialog to arrange a group of objects on your form. The 
objects are aligned relative to one another. For example, if you choose the 
Right Align option, the right sides of objects are aligned with the right 
side of the right-most object.
1. Select the objects you want to align.
2. Open the Format menu and choose Align to open the Align dialog.

If the menu item is dimmed, then no objects are selected. 

3. Choose the options you want.
If some of the options are dimmed, you only have one object selected.
To align and group the selected fields towards the upper left-most 
field, click the Quick Arrange button.
When you choose an option in the Align dialog, the selected objects 
move on your form to preview your choice. To view the preview, you 
might need to move the Align dialog by clicking and dragging the 
title bar of the dialog.
To restore your form to the way it looked before you opened the Align 
dialog, click Cancel.

4. Click OK to accept the changes.
If you’re aligning text boxes or fields, make sure the text alignment 
matches the object alignment. For example, right align the text when you 
align the right sides of the text objects. To change the text alignment, see 
“Aligning the Text in a Text Box or Data Field” on page 161.
For example, the text in the illustration below is already centered within 
the text box, but the text box isn’t centered within the rectangle. The 
objects are selected and then aligned horizontally and vertically using the 
Center options.

ALL RIGHTS RESERVED ALL RIGHTS RESERVED
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Using an Alignment Box
An alignment box allows you to align and arrange the text objects on your 
form, so that blank lines and spaces between text objects are eliminated 
when you print. 
You can also select to proportionally shrink text to fit within the borders of 
an alignment box.

To Add an Alignment Box
You can add an alignment box to a form in either the Output Forms 
window or the Edit Data Entry Form window. To open the Edit Data Entry 
Form window, click the Edit Data Entry Form button in the Data Entry 
window.
1. Open the Insert menu and choose Alignment Box or click the 

Alignment Box button in the Object Toolbar.  Alignment Box  
When you place the mailing address group on your form, the fields 
are grouped within an alignment box (see “Adding a Mailing Address 
Group” on page 156).

2. Click anywhere on the work area to place the alignment box.
You can also click and drag to add the fields and text boxes already on 
your form to the alignment box.

A red border around an 
alignment box indicates that the 
fields in the alignment box are 
locked (see “To Change the 
Properties of an Alignment 
Box” on page 152).

   

NOTE: The border around an alignment box appears on 
your screen, but doesn’t print.
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To Move an Alignment Box
1. Position the cursor over the border of the alignment box. The cursor 

changes from the normal pointer to the move cursor shown below.

To move an alignment box, 
click and drag the edge.

  

NOTE: If the cursor is over a field, you’ll only move 
that field unless the alignment box is locked.

 

2. Click and drag the border of the alignment box to move it.
3. Click outside of the alignment box to cancel the selection of it.

NOTE: Dragging an alignment box over a field doesn’t add 
the field to the alignment box. You must drag the field into 
the alignment box.

 

To Resize an Alignment Box
1. Click on the border of the alignment box to select it.
2. Position the cursor over one of the alignment box’s resizing handles. 

The cursor changes from the normal pointer to the resize cursor 
shown below.

To size an alignment 
box, click and drag a 
handle.

  

3. Click and drag the handle to resize the alignment box.

NOTE: Changing the width of an alignment box 
automatically resizes the width of all of the fields 
within it. To keep the fields from resizing, hold down 
the SHIFT key as you resize the alignment box.

 

4. Click outside of the alignment box to cancel the selection. 
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To Place Text Objects in an Alignment Box
When you place an alignment box on a form, any fields or text boxes 
partially within its boundaries are automatically moved into the box. To 
place another object in an alignment box, or to move an object already in 
the box, click and drag it.

Only fields and text boxes can 
be placed in an alignment 
box. You can’t place clipart, 
drawing objects, or barcode 
fields in an alignment box.

 
1. Click outside of the alignment box, so that it isn’t selected.
2. Click and drag the field or text box into the alignment box. As you 

drag the object, the cursor changes to show whether the item will be 
placed between two rows or inserted into a row. 

To Change the Properties of an Alignment Box
The properties of the alignment box affect the properties of the fields and 
text boxes within it.
1. Click the border of the alignment box to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. In the Alignment Box tab, set the alignment for all of the fields and 
text in the alignment box.
• To have DataBase reduce the font size if there is too much data to 

fit in the alignment box, mark the Shrink to fit check box.
• To lock the fields in the alignment box, mark the Lock Fields 

check box.
A red border around an 
alignment box indicates 
that the fields in the 
alignment box are locked.

 

NOTE: When the fields are locked, they can’t be 
moved or deleted. However, fields can be added to 
an alignment box when Lock Fields is marked in 
the Object Properties dialog.

 

• To set the font for all of the fields and text boxes within the 
alignment box, click the Font tab.

4. Click OK.
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To Delete an Alignment Box
1. If the alignment box contains fields or text boxes that you want to 

keep on the form, move the items out of the alignment box by clicking 
and dragging them.
You can’t remove the fields from a locked alignment box. A red 
border around an alignment box indicates that the fields in the 
alignment box are locked (see “To Change the Properties of an 
Alignment Box” on page 152).

2. Click on the border of the alignment box to select it.
3. Press the DELETE key.

CAUTION: If the alignment box contains any fields or text 
boxes when you delete it, those fields and text boxes are 
removed from your form.
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Adding Text to a Form

Overview
Regular users can only customize the forms in their Personal Output 
Forms list. The forms in the Shared Output Forms list and the Data 
Entry Form can only be customized by the database administrator.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
You can design your Data Entry form or your Output form the way you 
want it to look on screen and when it prints. Add text and graphics to your 
form using the Object Toolbar that is available in both the Edit Data Entry 
Form window and the Output Forms window.
Add fields for your data in the Edit Data Entry Form window, and then 
enter the data in these fields in the Data Entry window. Fields can be 
placed on your output forms to print your records on labels, envelopes, 
and other types of forms.
Add text directly on the form in both the Edit Data Entry Form window 
and the Output Forms window using text boxes. The text in a text box 
appears and prints the same with every record.
Change the font, size, and alignment of the text in fields and text boxes to 
create the look you want. You can even convert a field to appear and print 
as a barcode.
If you’re creating a booklet, such as an address book, you can add headers 
and footers that print the same on each page.
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Adding Fields for Data
The Field list near the bottom of the Object Toolbar contains the names of 
the fields that you can add to your form. Each field has a descriptive name 
to help you identify the field when you’re entering your data. 
If you can’t find a field that has a name to describe the kind of data you 
want to enter, the database administrator can create a new data field (see 
“Customizing the Data Entry Form” on page 47).

NOTE: The data fields are empty until you enter 
information in either the Data Entry or Data Table windows.

 

Adding a Mailing Address Group
DataBase includes an easy way to add the most common address fields to 
your form. The Mailing Address group is placed on your form inside of an 
alignment box. The alignment box keeps the data fields in a group so they 
can be moved as a unit. It also suppresses extra blank lines and spaces 
when the forms are printed (see “Using an Alignment Box” on page 150).

To Add a Mailing Address Group
You can add a mailing address to your form using the Output Forms 
window or the Edit Data Entry Form window.
1. Open the Insert menu and choose Mailing Address, or click the 

Mailing button in the Object Toolbar.  Mailing Address  
The Mailing Address dialog appears allowing you to choose a mailing 
group. 

2. Choose an address type in the top box and view the field names in the 
selected address type in the bottom box.

3. After choosing the Mailing Address type, click OK.
4. Position the cursor over the form and click the mouse button. 
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Choosing a Field From the Field List
1. Click the name of the field that you want in the Field list near the 

bottom of the Object Toolbar.   
2. Position the cursor on the form and click the mouse button, or click 

and drag, to remove the field from the list and place it on the form.

NOTE: If the field you want isn’t listed, it might be on the 
form already. Fields can only be in one place on a form. If 
you need to use a field more than once, type the field name 
into a text box (see “Inserting a Field Into a Text Box” 
below).

 

Inserting a Field Into a Text Box
If you want to print data inside of a text box or use a field more than once 
on your form, insert the field name into a text box. This allows you to 
make personalized forms, such as adding a personalized line on an 
envelope.
1. Add a text box to your form, if it isn’t there already (see “Adding a 

Text Box” on page 159).
2. Insert the cursor in the text box at the point where you want the field 

data to print.
3. Type two less-than signs (<<).
4. Type the field name exactly as it’s shown in the Field list in the Object 

Toolbar. 
It doesn’t matter whether or not you use capital letters.

5. Type two greater-than signs (>>).
The text box should look something like this:

Exclusively for <<First Name>> <<Last Name>>!

  

When you print or preview the records, DataBase replaces the field 
names with the data from your records.

Exclusively for Sarah Andrews!
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Adding a Barcode
DataBase supports POSTNET, Code 39, Codabar, Interleaved 2 of 5, Code 
128, UPC-A, UPC-E, EAN-13, and EAN-8 barcodes.
• To add a product barcode to your form, open the Insert menu and 

choose Product Barcode, or click the Product Barcode button in the 
Object toolbar.  

Product Barcode
 

• To add a POSTNET barcode to your form, open the Insert menu and 
choose Postal Barcode.

You can also convert a field already on your form to a product barcode. 
For more information about adding barcodes to your form, see “Using 
Barcodes” on page 183. 

Deleting Fields
You can delete fields from a form you’re working with. The database 
administrator can also delete fields from the entire database file.

Deleting a Field From a Form
Deleting a field from a form returns it to the Field list in the Object 
Toolbar. The field is only removed from the current form.
To delete a field from a form, click the field and then press DELETE to 
return the field to the Field list in the Object Toolbar.
For information about deleting a field from your database, see “Deleting a 
Field From Your DataBase File” on page 56.
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Adding a Text Box
Text boxes are used to enter text that you want to include with every 
record, such as your company motto on a shipping label. If you want to 
add text that changes from record to record, add a field (see “Adding 
Fields for Data” on page 156).
1. Open the Insert menu and choose Text or click the Text button in the 

Object Toolbar.  
Text

 
2. Position the cursor on the form and click the mouse button, or click 

and drag, to place a text box containing the text Enter text here.  

3. Type your text in the box to automatically replace the original text.
To change the font of the text in the box, select the text box and then 
choose the font from the Properties Toolbar above the label. All of the text 
will change to the new font. You can only use one font, size, style, and 
color for each text box on your form.

Adding a Return Address
DataBase adds a return address to your form by inserting a text box when 
you click the Return Address button.
To place the return address text box on your form, open the Insert menu 
and choose Return Address or click the Return Address button in the 
Object Toolbar. Then, position the cursor on the form and click the mouse 
button, or click and drag, to add the return address to your form.  

Return Address

 
The first time you use the Return Address feature in each database file, 
you need to type your return address in the box. DataBase remembers this 
information and uses it the next time you click the Return Address 
button. If your return address changes, edit the text in the box. DataBase 
remembers the changes.
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Formatting Text in Fields and Text Boxes
You can format text using the buttons in the Properties Toolbar or the 
options in the Object Properties dialog.
To format the text using the Properties Toolbar, select the field or text box 
and then click a button in the toolbar.  

In the Object Properties dialog, you can:
• Set the alignment of text within a field or text box
• Rotate fields and text on the form
• Choose your fonts and font color
• Insert product barcodes
• Set the field name placement

To Use the Object Properties Dialog
1. Click on the field or text box to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 
3. Click the tab at the top of the dialog for the property you want to 

change and choose the options that you want.
4. Click another tab to change other properties, or click OK to close the 

Object Properties dialog and apply your changes.
The different text formatting options are explained in detail in the 
following sections.
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Aligning the Text in a Text Box or Data Field
You can align text within the field or text box.
1. Click on the field or text box to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click on the Attributes tab to set the alignment of text within the field 
or text box.

4. Choose the option you want.
If the options are dimmed, the field or text box might be inside of an 
alignment box. To set the alignment of the text in the field or text box, 
set the alignment box properties (see “To Change the Properties of an 
Alignment Box” on page 152).

5. Click another tab to change other properties, or click OK to close the 
Object Properties dialog and apply your changes.
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Rotating the Text
You can rotate the fields and text objects on your form in 90-degree 
increments and align the letters vertically in a field.

NOTE: DataBase can’t rotate fields that are within an 
alignment box.

 

1. Click on the field or text box to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click on the Orientation tab.
4. Choose the options you want. 

The Test window shows you how the object will rotate.
5. Click another tab to change other properties, or click OK to close the 

Object Properties dialog and apply your changes.
You can also rotate objects and text by clicking the Rotate Object and 
Rotate Text buttons in the Output Forms window.
• To rotate an object, select the object and then click the Rotate Object 

button.
• To rotate the letters in a field, select the field and then click the Rotate 

Text button.

Rotate Object Rotate Text
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Choosing the Font
When you choose a font for the text in a field or text box, the selected font 
applies to all of the text in the field or text box.
1. Click on the field or text box to select it.
2. Open the Format menu and choose Font to open the Object 

Properties dialog. 

3. Click on the Font tab to choose the font for the text in the field or text 
box.
As you make choices, the Sample box shows how the text will appear 
on your form.

4. Scroll in the Font box and choose a font that you want to use for your 
text.

5. Choose a Font style and Size from the available options.
6. Choose the effects that you want to apply to your text.

• Check the Strikethrough box to display the text with a horizontal 
line through the center of the text.

• Check the Underline box to display underlined text.
• Click in the Color box to open the color palette and choose a 

color for the text.
7. Click another tab to change other properties, or click OK to close the 

Object Properties dialog and apply your changes.
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Setting the Field Name Placement
In most of the pre-designed forms, the field names appear inside of the 
field box. You can change this so that field names appear outside of the 
field box.
To select a field in the Data Entry window, click the Edit Data Entry Form 
button. To select a field in the Output Forms window, click the Output 
Forms tab.
1. Click the field in the design window to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click the Name Placement tab.
4. Choose the position for the field name.

If the field name is placed outside of the field box and you want to 
print it as well as display it, check the Print Field Name box.

5. Click another tab to change other properties, or click OK to close the 
Object Properties dialog and apply your changes.
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Converting a Field to a Barcode
You can display and print a field as a product barcode. Convert a field to a 
product barcode in either the Edit Data Entry Form window or the Output 
Forms window.
1. Click on the field to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click the Barcode tab.
4. Mark the Display as Barcode check box.

To choose the type of barcode to use, click the Format button (see 
“Changing the Barcode Type and Specifications” on page 186).

DataBase supports 
Code 39, Codabar, 
Interleaved 2 of 5, 
Code 128, UPC-A, 
UPC-E, EAN-13, and 
EAN-8 product 
barcodes.

 
5. Click another tab to change other properties, or click OK to close the 

Object Properties dialog and apply your changes.
For more information about adding barcodes to your form, see “Using 
Barcodes” on page 183. 
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Adding Headers and Footers to Booklets
Use headers and footers to print the date, page numbers, or a title in your 
booklet. Headers and footers print on every page in the booklet.
1. Click the Output Forms tab. 
2. Open the Format menu and choose Header/Footer, or click the 

Header/Footer button, to open the Booklet Properties dialog.Header/Footer   

3. Check the Use Header box in the Header tab or the Use Footer box 
in the Footer tab and then choose the options you want.
• Type the header title or footer title in the Title box.
• Click the Justify drop-down arrow and then choose Left, Center, 

or Right.
• You can choose to display a Page #, the Date, and a Line above 

or below the header or footer and then set the position of each.
• To choose the font for the header or footer text, click the Font 

button.
4. When you finish designing the Header and Footer, click OK.

Removing Blank Lines and Spaces
When you preview or print your forms, there might be blank lines or 
spaces for fields where there is no data. The data might also be too close 
together or too far apart, if the data in each field varies in length.
To add a single space between each field on the same line and remove 
blank lines when there is no data, place your fields in an alignment box.
For more information about alignment boxes, see “Using an Alignment 
Box” on page 150.
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Sequencing Your Records
DataBase allows you to set up a field that will increment on your forms.
Select the field either the Data Entry or Data Table window so you can 
enter the information and increment the field (see “Incrementing Fields” 
on page 86).
For example, to make a set of numbered raffle tickets, place the field in the 
Output Forms window for the numbers, and then set the incrementing 
options in either the Data Entry or Data Table window.  
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Adding Pictures and Drawing 
Objects

Overview
Regular users can only customize the forms in their Personal Output 
Forms list. The forms in the Shared Output Forms list and the Data 
Entry Form can only be customized by the database administrator.
The administrator doesn’t have a Personal Output Forms list when using 
the Administrator login.
You can add background images, pictures, and drawing objects to your 
form either by importing clipart or using the built-in drawing tools. Use 
the clipart included with DataBase or import graphics from other 
programs to create a personalized form.
Any picture can be resized and arranged with other objects using the tools 
and options in DataBase. However, graphics can’t be included in an 
alignment box.
Using DataBase you can include pictures and objects on your forms using 
the following methods.
• Adding a Background Image (see page 170)
• Adding Clipart (see page 172)
• Drawing Lines (see page 176)
• Drawing Rectangles and Circles (see page 177)
• Changing the Attributes of Drawing Objects (see page 179)
• Adding Objects From Another Program (see page 181)
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Adding a Background Image
You can add a background image to a form, center or fit the image to the 
form, and rotate the image on the form.

DataBase can read BMP, GIF, 
PNG, RLE, DIB, TIF, PCX, 
DCX, WPG, JPG, IMG, TGA, 
WMF, and EPS graphic 
formats (LZW encoded TIF 
files aren’t supported).

 
When you add a background image to a form, DataBase remembers the 
location of the image file, but doesn’t actually add it to your DataBase file. 
This saves disk space, but DataBase won’t be able to find the image file if 
it’s moved or if you copy your file to another computer without also 
copying the image (see “Transferring Files to Another Computer” on page 
289).

Creating a Background Image
1. Open the Insert menu and choose Create Background Image, to 

open the Pick Picture dialog. 

The Pick Picture dialog displays the Clipart folder that was installed 
with the program. You can find more clipart on the DataBase CD.

2. Choose the clipart file you want.
A preview of the picture appears on the right side of the dialog.

3. Click OK to place the image as a background on your form. 

4. Chose whether to save the clipart file in the database clipart folder.
If you click Yes, a copy of the clipart file will be placed in the 
database clipart folder. The original file will remain unchanged.
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Placing the Image on the Form
The background image can be placed on the form in the following ways.
• Fit Background Image to Form fits the image to the form size.
• Center Background Image centers the image over the form.
After choosing the image you want, the image appears on the form. 
• To resize the image to the shape of the form, open the Insert menu 

and choose Fit Background Image to Form.
• To center the image on the form, open the Insert menu and choose 

Center Background Image.

Rotating the Background Image
You can rotate the image clockwise on the form using the Background 
Image Properties dialog.
You can rotate the background image in 90-degree increments.
1. Open the Insert menu and choose Background Image Properties to 

open the Object Properties dialog.

The Test box shows you how 
the background will rotate.

  

2. Click the Orientation tab.
3. Choose the amount of rotation. 
4. Click OK.

Replacing a Background Image
To choose a different image to replace the background image, open the 
Insert menu and choose Replace Background Image to display the Pick 
Picture dialog (see “Creating a Background Image” on page 170).

Removing a Background Image
To remove a background image, open the Insert menu and choose 
Remove Background Image.
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Adding Clipart
You can easily add clipart to your form. Clipart can be resized or rotated 
after you add it to your form.DataBase can read BMP, GIF, 

PNG, RLE, DIB, TIF, PCX, 
DCX, WPG, JPG, IMG, TGA, 
WMF, and EPS graphic 
formats (LZW encoded TIF 
files aren’t supported).

 
When you add clipart to a form, DataBase remembers the location of the 
clipart file, but doesn’t actually add it to your DataBase file. This saves 
disk space, but DataBase won’t be able to find the clipart file if it’s moved 
or if you copy your file to another computer without also copying the 
clipart (see “Transferring Files to Another Computer” on page 289).
If you want to place images that change from record to record, see 
“Placing an Image in a Field” on page 74.

To Add Clipart to Your Form
You can add clipart to a form in the Output Forms window or the Edit Data 
Entry Form window. To open the Edit Data Entry Form window, click the 
Edit Data Entry Form button in the Data Entry window. 
1. Open the Insert menu and choose Clipart, or click the Clipart button 

in the Object Toolbar, to open the Pick Picture dialog.  
Clipart

  

The Pick Picture dialog displays the Clipart folder that was installed 
with the program. You can find more clipart on the DataBase CD.

2. Choose the clipart file you want.
A preview of the picture appears on the right side of the dialog.

3. Click OK. 

4. Chose whether to save the clipart file in the database clipart folder.
If you click Yes, a copy of the clipart file will be placed in the 
database clipart folder. The original file will remain unchanged.

5. Position the cursor on the form where you want the picture, and then 
click to place it.

If you want to make the 
picture a specific size, 
you can click and drag 
when you place it.  
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Moving and Sizing Clipart
To move a picture, click and drag it. To size a picture, click and drag a 
sizing handle.  

To size a picture proportionally (so it doesn’t look squeezed or stretched), 
hold down the SHIFT key as you size the picture. This also restores a 
squeezed image to its original proportions.
You can set a picture to always size proportionally using the Object 
Properties dialog.

To Set a Picture to Size Proportionally
1. Click the picture on your form to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click the Clipart tab.
4. Mark the Preserve aspect ratio when resizing check box.
5. Click OK.
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Rotating Clipart
You can rotate clipart in 90-degree increments.
1. Click the picture on your form to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click the Orientation tab.
4. Choose the amount of rotation. 

The Test box shows you how the clipart will rotate.
5. Click OK.
You can also rotate the clipart by clicking the Rotate button in the 
Properties toolbar.  Rotate  
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Adjusting the Brightness of Clipart
1. Click the picture on your form to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 
3. Click the Clipart tab.
4. Click the Advanced button to open the Advanced Configuration 

dialog.

Brightness adjusts the 
lightness and darkness of 
the entire picture.

Contrast adjusts the 
lightness and darkness at 
the lightest and darkest 
extremes of the colors in 
the picture.

Gamma adjusts the 
lightness and darkness of 
the mid-range spectrum of 
the colors in the picture.

Blur softens the edges of 
the picture.

  

5. Drag the sliders for Brightness, Contrast, Gamma, and Blur or enter 
values in the boxes on the right.
The Original Image always stays the same, and the Adjusted Image 
shows you how the image will look with the adjustments you make.

6. Choose Invert and Emboss effects by checking the box next to the 
effect you want.
• Invert swaps the colors of the picture, much like a photographic 

negative.
• Emboss create a three-dimensional effect on a gray background.
To return the settings to the original positions, click the Reset button.

7. Click OK to apply your changes.

The clipart in the 
original file remains 
unchanged after you 
make adjustments.

 
8. Click OK to close the Clipart Properties dialog.
DataBase remembers the adjustments that you made and applies the 
adjustments each time you open the file that contains an adjusted picture. 
For images in fields, all of the images in each record are adjusted based on 
the selections you made.
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Drawing Lines
You can add lines of any length or angle to your form.
1. Open the Insert menu and choose Line or click the Line button in the 

Object Toolbar.   
2. Click on the form where you want to position the line.

To determine the length and angle of the line, click and drag when 
you place it.

Moving and Sizing a Line
To reposition the line on your form, click the middle of the line and drag it. 
You can resize or change the angle of the line by clicking and dragging 
one of the handles on either end.  

Changing the Thickness and Color of a Line
The thickness and color of a line can be easily changed using Properties 
toolbar.
• To change the thickness of a line, click the Line Thickness button 

and choose from the list.
Line Thickness

   
• To change the color of a line, click the Line Color button and choose 

from the color palette.Line Color    
You can also change the attributes of a line in the Object Properties dialog 
(see “Changing the Outline of a Rectangle or Circle” on page 178).
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Drawing Rectangles and Circles
You can add circles, rectangles, and rounded rectangles to your form. You 
can even place a border near the edge of your form.
1. Open the Insert menu and choose a shape or click one of the shape 

buttons on the Object Toolbar.
• To place a circle or ellipse on your form, open the Insert menu 

and choose Circle or click the Circle button.

Circle

   
• To place a rectangle on your form, open the Insert menu and 

choose Rectangle or click the Rectangle button.
Rectangle

   
• To place a rectangle with rounded corners on your form, open the 

Insert menu and choose Rounded Rectangle or click the 
Rounded Rectangle button.

Rounded Rectangle

   
2. Click on the form where you want to position the shape.

To define the size of the shape, click and drag when you place it.

To Place a Border Around the Edge of Your Form
1. Open the Insert menu and choose a shape or click one of the shape 

buttons on the Object Toolbar.
2. Click on the form to place the shape.
3. Right-click the shape and choose Border from the shortcut menu.
The shape is sized and placed near the edges of your form to create a 
border.
If you’re using a sheet feed printer, the border helps define the printable 
region of the form for you.

Moving and Sizing a Rectangle or Circle
To reposition a shape on your form, click and drag the edge of the shape. 
You can size the shape by clicking and dragging one of the handles on a 
side or corner.  

Change a rectangle to a square, or an ellipse to a circle, by holding the 
SHIFT key down while dragging a handle.
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Changing the Outline of a Rectangle or Circle
The thickness and color of the outline of a shape can be easily changed 
using Properties toolbar.
• To change the thickness of the outline, click the Line Thickness 

button and choose from the list.
Line Thickness

   
• To change the color of the outline, click the Line Color button and 

choose from the color palette.

Line Color

   
You can also change the attributes of the outline in the Object Properties 
dialog (see “Changing the Attributes of Drawing Objects” on page 179).

Changing the Fill Color of a Rectangle or Circle
You can easily change the color of the inside of a shape using the 
Properties toolbar.
• To change the color of the inside of a circle or rectangle, click the Fill 

Color button and choose from the color palette.
Fill Color

   
• To make the inside of a circle or shape transparent, click the Fill Color 

button and choose None from the color palette.
You can also change the fill color of a shape in the Object Properties 
dialog.
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Changing the Attributes of Drawing Objects
In addition to using the Properties Toolbar for changing the attributes of a 
drawing object, you can use the Object Properties dialog.
1. Click the drawing object on your form to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog.

To choose a 
color that isn’t in the 
palette, click Custom.  
For information about 
creating a custom color, 
see “Choosing a Custom 
Color” on page 180.

  

3. Choose the attribute you want to change. 
• If you want to change the thickness or color of a line or the 

outline of a shape, click the Line tab.
• If you want to change the color of the inside of a shape, click the 

Fill tab.
4. Choose the color from the palette or click Custom to create a custom 

color.
5. A preview of the color appears in the dialog.

To make the inside of a shape transparent, choose None. 
6. Choose the thickness of the line or outline, if you’re in the Line tab.
7. Click OK.
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Choosing a Custom Color
There are 48 colors available on the color palette in the Object Properties 
dialog.
If you want to create a custom color for the selected object, click Custom 
in the color palette.
The Color dialog displays a wide range of colors. 

1. Click an empty Custom colors box, and then click in the large box 
on the right to select the color. 

2. Click anywhere in the bar on the far right.
A preview of the color appears in the small box below it. 

3. Drag the arrow next to the saturation control scroll bar on the right to 
adjust the color level.

You can change this color by clicking somewhere else in the large box and 
dragging the saturation control, or entering numbers in the boxes on the 
lower-right.

NOTE: The values in the boxes must be less than 256.

 

If you want to save the custom color, click Add to Custom Colors. When 
you’re satisfied with your color selection, click OK.
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Adding Objects From Another Program
DataBase is compatible with the Windows feature known as Object 
Linking and Embedding, or OLE. With this feature, you can use objects 
created in other programs for your forms, or use another program to create 
objects within DataBase.
For example, you can create a company logo in a drawing program, place 
it on your form, and then edit the logo at any time from DataBase using 
the tools of the original drawing program.
You can also insert OLE text objects, allowing you to use the tools of your 
word processing program within DataBase.

Comparing Linking with Embedding
The basic difference between linking and embedding is where the OLE 
object is stored. Linking and embedding have different advantages. 
When you embed an object with OLE, you insert a copy of the object into 
your DataBase file. Editing the object within DataBase doesn’t affect the 
original file. If you plan to transfer your list to another computer, you 
might want to embed your object to simplify the transfer process (see 
“Transferring Files to Another Computer” on page 289).
When you link an object with OLE, you insert a reference or pointer to the 
object which allows DataBase to find the object in the program that 
created it and insert the object onto your form. Unlike pasting or 
embedding, you aren’t actually making a copy of the object, so there is 
only one copy of the object on your computer. This means that you can 
edit the object one time and have the changes appear everywhere the 
object is linked.
For example, if you have created a logo with a drawing program and 
linked it to both your mailing labels and to your letterhead in a word 
processing program, you can update the logo in the drawing program and 
have the changes appear automatically the next time you open DataBase 
or the word processor file.
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Inserting an OLE Object
1. Open the Insert menu and choose Object to open the Insert Object 

dialog. 

2. Choose the object that you want to insert.
• If you want to create a new object, choose the Create New option 

and then choose the type of object from the Object Type list. The 
object will be embedded in your DataBase file.

• If you want to insert an object that you’ve already created and 
saved using another program, choose the Create from File option 
and then locate the file on your computer. The object will be 
embedded in your DataBase file unless you mark the Link check 
box.

3. Click OK.
4. Click on your form to place the object for editing.

Editing an OLE Object
Depending on the program used to create an OLE object, double-clicking 
an OLE object opens the program in which it was created. For certain 
programs, however, some of the DataBase menus and toolbars are 
temporarily replaced by those of the original program.

To Edit an OLE Object
1. Double-click the OLE object.Some OLE objects, such as 

sound or video clips, play 
when you double-click them. 
To edit one of these objects, 
open the Edit menu and 
choose Object.

 
2. Edit the object.
3. Do one of the following:

• If you’re editing the object in a separate program window, open 
the File menu and choose either Exit or Quit to return to 
DataBase.

• If you’re editing the object in a program that temporarily replaces 
the DataBase menus and toolbar, click anywhere outside of the 
OLE object to return to DataBase.
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Using Barcodes

Overview
A postal or product barcode can be added to your form by clicking one of 
the two barcode buttons located in the Object Toolbar. The barcode is 
associated with a data field that you place on your form. 
DataBase supports POSTNET, Code 39, Codabar, Interleaved 2 of 5, Code 
128, UPC-A, UPC-E, EAN-13, and EAN-8 barcodes.
The POSTNET barcode was developed by the USPS to encode ZIP Code 
information about mail pieces, so that they can be read by barcode sorting 
machines. A POSTNET barcode will only print on records that have a 
ZIP+4 Code.
Since DataBase doesn’t perform the complicated sorting required for Bulk 
Mail, adding a postal barcode to your form doesn’t qualify your mailing 
pieces for automated postage discounts. For information about how you 
can receive Bulk Mail discounts, contact the USPS or go to  
http://www.mypostageratesaver.com.
Add a barcode to your form in the Design window and enter the data for 
the barcode in the Data Entry or Data Table window.

http://www.mypostageratesaver.com
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Adding a Postal Barcode
Postal barcodes turn ZIP+4 Codes into barcodes. DataBase only prints 
barcodes for addresses that have ZIP+4 Codes. Add the ZIP Code 
information in either the Data Entry or Data Table window.

NOTE: The form must be at least 3½ inches wide, to 
prevent the barcode from being cut off when you print.

 

1. Open the Insert menu and choose Postal Barcode to open the Postal 
Barcode dialog. 

2. Choose the ZIP Code field that you want barcoded.
3. Click OK.
4. Click on the form to place the barcode.
The United States Postal Service recommends that you place the barcode 
directly above the first line (recipient’s name) of the address.

NOTE: You won’t receive postage discounts for using 
barcodes on your forms unless you meet the strict address 
correction and Presort requirements for Bulk Mail. If you 
want to receive Bulk Mail discounts, you might want to 
purchase MySoftware’s MyMailList Deluxe or 
MyPostageRateSaver.
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Adding a Product Barcode
Product barcodes are placed as fields on your form in the Output Forms or 
Edit Data Entry Form windows. Enter the barcode data in either the Data 
Entry or Data Table window.

To Add a Product Barcode
1. Open the Insert menu and choose Product Barcode, or click the 

Product Barcode button to open the Select Barcode Type dialog.  Product Barcode   

2. Choose the type of barcode that you want on your form.
3. Choose the field that you want barcoded.
4. Click OK.
5. Click on the form to place the barcode.
To further define how the barcode works, see “Changing the Barcode Type 
and Specifications” on page 186.
Enter the data for the barcode in either the Data Entry or Data Table 
window.
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Changing the Barcode Type and Specifications
After you’ve placed a barcode field on your form (see “Adding a Product 
Barcode” on page 185), you can change the barcode type and 
specifications.
1. Click the barcode field on your form to select it.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 
3. Click the Barcode tab.
4. Mark the Display as Barcode check box, if it isn’t already marked.
5. Click the Format button to open the Barcode Specifications dialog. 

6. Choose the type of barcode you want to use from the Barcode Name 
drop-down list. 
The type of barcode you choose affects what options are available in 
the Barcode Specifications dialog. To learn more about the features 
and specifications in this dialog, see “Barcode Options” on page 187.
For complete information about what specifications to use, see the 
documentation for your barcode reader.

7. Click OK to close the Barcode Specifications dialog.
8. Click another tab to change other properties, or click OK to close the 

Object Properties dialog and apply your changes.
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Barcode Options
The Barcode Specifications dialog allows you to specify and customize a 
barcode. 

Select the barcode type from the Barcode Name drop-down list. DataBase 
supports Code 39, Codabar, Interleaved 2 of 5, Code 128, UPC-A, UPC-E, 
EAN-13, and EAN-8 barcodes in this dialog.
Select the Start Code from the drop-down list to define the starting point 
of your barcode, if your barcode type requires it. If no codes are listed, 
then no codes are available for the type of barcode you have selected.
Select the Stop Code from the drop-down list to define the stopping point 
of your barcode, if your barcode type requires it. If no codes are listed, 
then no codes are available for the type of barcode you have selected.
Mark the Checksum box to add a checksum to your barcode. Clear this 
box to leave the checksum out. If this feature is dimmed, then the barcode 
type you’ve selected doesn’t support checksums.
Enter the width of the narrowest bar or space on your barcode in the 
X Dimension box. The measurement is entered in Mils (1 Mil = 0.010"). 
Changing the value in the X Dimension box changes the size of every bar 
and space in a proportional manner. The actual dimension printed might 
vary depending on your printer.
Enter the percentage of difference between the narrowest and widest bar 
or space on your barcode in the N Ratio box. The percentage you enter 
will be how much wider the widest bar or space is compared to the 
narrowest. The actual dimension printed might vary depending on your 
printer.
Enter the multiple for the width of the Quiet Zone that goes at the 
beginning and end of your barcode. The width of the quiet zone is 
computed by multiplying this number times the X Dimension. The 
number entered here must be 10 or larger.
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Select a percentage from the Increase space width by drop-down list to 
increase the width of the spaces in your barcode. Changing the 
X Dimension and N Ratio lets you define how you would like the barcode 
to ideally print. However, due to the type of ink or label stock you’re 
using, you might find that the ink bleeds to a certain degree. Compensate 
for ink bleed by selecting from this list or the Increase bar width by drop-
down list.
Select a percentage from the Increase bar width by drop-down list to 
increase the width of the bars in your barcode. Changing the X Dimension 
and N Ratio lets you define how you would like the barcode to ideally 
print. However, due to the type of ink or label stock you’re using, you 
might find that the ink bleeds to a certain degree. Compensate for ink 
bleed by selecting from this list or the Increase bar width by drop-down 
list.
Choose the location where the Human Readable Information (HRI) prints. 
The HRI is the text printed with the barcode to represent the encoded data.
• None prevents the HRI from printing.
• Top prints the HRI above the barcode.
• Bottom prints the HRI below the barcode.
For complete information about what specifications to use, see the 
documentation for your barcode reader.

Changing the Properties of a Product Barcode
In addition to the specifications used to define a product barcode, you can 
rotate it, change its color, or change the font of the Human Readable 
Information. 
1. Click the barcode on your form to select it.
2. Open the Format menu and choose Object Properties.
3. Choose the options you want for the barcode.

• To rotate the barcode, click the Orientation tab and choose an 
option. The Test box shows how the barcode will be rotated.

• To change the color of the barcode or the font options of the 
Human Readable Information, click the Font tab and choose an 
option.

4. Click OK.

CAUTION: Changing the properties of a barcode might 
reduce its readability. For more information, see the 
documentation for your barcode reader.
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Entering Barcode Data
You need to enter information into a barcode field in either the Data Entry 
or Data Table window. For information about adding a barcode to your 
form, see “Using Barcodes” on page 183. 
A barcode field works like other fields: the data can be different on each 
record. To make the barcode data the same in every record, enter the data 
in one record and then copy it to the other records. If the data is numeric, 
you can let DataBase do the work for you by setting the field to increment 
by zero (see “Incrementing Fields” on page 86).
If all of your output forms are going to have the exact same information in 
the barcode and in all of the data fields, you only need to enter the data for 
the barcode once. Then, you can select the number of copies of the form to 
print in the Print dialog (see “Printing Output Forms” on page 193). 

Entering Postal Barcode Data
A Postal barcode won’t print if there are less than 9 numbers in the ZIP 
Code field. You can enter the ZIP+4 Code as nine consecutive digits 
(940254227) or place a hyphen after the fifth character (94025-4227).
Delivery Point codes are supported if you have imported a database that 
supports Delivery Point codes. You’ll need to map the databse field that 
contains the Delivery Point data to the Delivery Point Field in the 
DataBase file (see “Importing Data From Other Programs” on page 63).
The Delivery Point Field is a special, “hidden” data field. You can’t place 
it on your form nor can you edit the contents of this field. DataBase 
automatically adds the two-digit Delivery Point data to the end of a nine-
digit ZIP Code for each record, if the Delivery Point data was imported.

NOTE: You won’t receive postage discounts for using 
barcodes on your forms unless you meet the strict address 
correction and Presort requirements for Bulk Mail. If you 
want to receive Bulk Mail discounts, you might want to 
purchase MySoftware’s MyMailList Deluxe or 
MyPostageRateSaver. For information about Bulk Mail 
software, call MySoftware Customer Service at 1-800-325-
0834 or go to http://www.mypostageratesaver.com.

 

http://www.mypostageratesaver.com
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Entering Control Characters
If you’re using control characters in your barcode, you must enclose the 
control characters in angle brackets (< >). For example, if you want to 
enter a carriage return in code set A of a Code 128 barcode, enter: <CR>.

NOTE: You can’t print a less-than symbol (<) in your 
barcode. Non-control characters following this symbol will 
be considered invalid.

 

Incrementing a Barcode
DataBase allows you to set up your barcode to serialize, or increment, 
from record to record. Place a barcode where you want it on your form 
design, and then select it for incrementing in either the Data Entry or Data 
Table window (see “Incrementing Fields” on page 86).

Printing Barcodes
Barcodes print on your forms along with the rest of the objects and data. 
The data in the associated field for a barcode dictates how the barcode 
prints for each record.

Printing Postal Barcodes
There are two requirements for printing postal barcodes:
• There must be a postal barcode on the form that appears in the Forms 

window (see “Adding a Postal Barcode” on page 184).
• A postal barcode won’t print unless the address contains a ZIP+4 

Code (nine digits). If the ZIP code only has 5 digits, the postal 
barcode won’t print.

DataBase can only preview and print POSTNET Barcodes for records that 
have ZIP+4 Codes. Forms that have a Barcode will display a sample 
Barcode in the Data Entry window for all records. However, a ZIP+4 must 
exist in a record for the Postnet Barcode to preview and print.

NOTE: ZIP+4 Barcodes are not the same as Delivery Point 
Barcodes. ZIP+4 Barcodes have 52 bars, while Delivery 
point Barcodes have 62 bars. The additional 10 bars are 
generated from a Delivery Point field for Automated Bulk 
Mail. DataBase doesn’t allow editing of the Delivery Point 
field. To learn more about Delivery Point Barcoding and 
Automated Bulk Mail, call MySoftware Customer Service 
at 1-800-325-0834 or go to http://
www.mypostageratesaver.com.

 

http://www.mypostageratesaver.com
http://www.mypostageratesaver.com
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Printing Output Forms

Overview
There are four ways to print your data:
• In the format displayed in the Output Forms window
• In the format displayed in the Data Entry window
• In the Data Table format
• In a report
If you only want to print certain records in your list, you can choose which 
records you want. Before you print, you can check to make sure the data 
will fit on your forms by checking for overflow. You can also view an on-
screen preview of your data to make sure the data looks the way you want 
it to before you begin printing.
For information about printing your data in a report, see “Reports” on 
page 239.

Checking for Data Overflow
DataBase can check for data that will be cut off when you print your form. 
There are three reasons that data might be cut off:
• The data might extend past the edge of the form.
• The field might not be long enough to show all of its data.
• The alignment box containing the field isn’t long enough, and the 

Shrink to fit check box isn’t marked (see “To Change the Properties 
of an Alignment Box” on page 152).

Only the database administrator can change the size of a field or the 
properties of an alignment box on a shared form.
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To Scan for Data Overflow
1. Open the Data menu and choose Scan for Overflow to open the Scan 

For Overflow dialog. 

2. Click in the Start Scan At Record box and type the record number 
where you want the scan to begin.
If DataBase finds a record that overflows, it lists the record number 
and field where the overflow occurs.

3. Click Start Scan to begin scanning your records.
To stop scanning records, click Stop Scan. When you click Start 
Scan again, the scan will start where it left off.

4. Choose to either edit the data or edit the form design.
• To edit the data in the record, click the record in the list and then 

click the Edit Record button to display that record in the Data 
Entry window.

• To edit the form design, click the record in the list and then click 
the Edit Design button to open the Output Forms window.

Only the database administrator can change the size of a field or the 
properties of an alignment box on a shared form.

NOTE: DataBase only lists one field per record, even 
if there is overflow in other fields, so repeat the scan 
after you fix the known overflow problems.
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Previewing Your Form
Use the Print Preview feature to see how your data will look before you 
print.
1. Open the File menu and choose Print Preview and then choose one of 

the following options to open the Print Preview window:
• Data Entry Form to preview the Data Entry Form design
• Active Output Form to preview Output Form that is open in the 

Output Forms window. 

2. Click to zoom in or out on the page:
• To zoom in, click the page.
• To zoom out, right-click the page.

3. Use the toolbar in the Preview window to scroll to different pages, set 
the view to one or two pages, check your printer settings, and begin 
printing.

If the preview looks correct, click the Print button on the left end of the 
toolbar to begin printing your list.
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Skipping Labels or Cards on the First Page
You can skip over the used areas on the first sheet of labels or cards if 
you’re using a sheet-feed printer. This doesn’t prevent any records from 
printing, it just prints the records in different locations on the page. For 
example, you might have printed three business cards on a sheet of ten 
cards. When you print more cards, you’ll want to prevent DataBase from 
printing on the cards that are already used.
1. Open the File menu and choose Print > Active Output Form to open 

the Print dialog.
To print your Data Entry 
Form, open the File menu 
and choose  
Print > Data Entry Form.

 
2. Click the Skip Labels or Skip Cards button to open a dialog that 

displays a sample page of labels or cards. 

3. Click on the areas you want to skip. 
Skipped areas are marked with an X. To remove an X, click the area 
again, or click the Clear All Skipped Labels or Clear All Skipped 
Cards button.

4. Click OK to return to the Print Setup dialog.

CAUTION: Running sheets of labels through a printer 
might cause labels to begin peeling off of the sheet. Don’t 
run a sheet through the printer again if labels are missing, or 
it looks like labels are beginning to peel off.
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Printing the Forms
Print your records in the format of the form in the Data Entry window or 
the Active Output Forms window.
1. Open the File menu and choose Print and then choose one of the 

following options to open the Print dialog:
2. Data Entry Form prints the Data Entry Form design
3. Active Output Form prints the Output Form that is open is the Output 

Forms window  

4. Make sure the correct printer is selected.
5. Select the records to print from the options in the Print Range box.

• All records
• Consecutive records
• Only the records that are selected in the Data Table (see 

“Selecting a Group of Records” on page 108).
6. Enter the number of copies of each record you want to print.

The number you enter determines the number of forms to print for 
each record. For example, if you want to print a full sheet of 30 return 
address labels, enter 30. 

7. If you’re making multiple copies of more than one record, set the 
Collate option.

NOTE: You can’t collate 
copies if you have chosen 
to skip labels or cards on 
the first sheet.

 
• Check the Collate box to print the entire set of records once, and 

then print the entire set again until the number of copies you 
entered have been printed.

• Uncheck the Collate box to print the first record the number of 
times you entered in the Copies box, followed by the second 
record, etc. 

8. Click Print to begin printing your records.
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Using Sheet-Feed Labels
Sheet-feed labels are those designed for use in a laser or ink-jet printer. 
These printers have a non-printable area around the borders of the sheet. 
The printable region on a sheet of labels is indicated by a light gray, dotted 
line in the Preview window. The non-printable region extends about .125" 
to .5" all around the edge of the page; the width of the non-printable region 
varies from printer to printer.
To make sure all of the text and graphics on your label will fit in the 
printable region, you can place a border on your label. Any images or text 
placed within the border will be in the printable region. Add a border to 
your labels in the Output Forms window, and then move any objects that 
are outside of the border. The border can be deleted after the other objects 
are moved if you don’t want it to print.
For information about adding a border to your label, see “Drawing 
Rectangles and Circles” on page 177.

Aligning Labels for Your Printer
The alignment of your data on the printed labels should be correct for most 
printers. However, if the standard settings don’t work for your printer, you 
can easily change the way sheet-feed labels print by using the Print 
Calibrate feature.
Before you recalibrate the printer, you should check the alignment of the 
labels (see “To Check the Alignment of the Printed Labels” on page 199).

NOTE: If you’re using a pin-feed printer, you must adjust 
the alignment manually. For more information, see 
“Adjusting Form-Feed Printers” on page 200.
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To Check the Alignment of the Printed Labels
Before calibrating your laser or ink-jet printer, you should make sure that 
your labels are being fed into the printer correctly. Slightly crooked sheets 
can make labels look misaligned. 
You should also make sure that the specifications for the form size match 
the stock you’re using:
1. View the Output Forms window by clicking the Output Forms tab.
2. Open the Format menu and choose Change Form Size to open the 

Change Form Size dialog with the current form size already selected.
3. Click the Custom button to open the Customize Size dialog, which 

shows you the exact specifications of the selected form size.
If the specifications don’t match, you can try to find a size that does 
match, or make a new custom size.

CAUTION: If the label specifications don’t match, 
you might be trying to print on photocopier labels, and 
not labels for laser or ink-jet printers. If this is the case, 
you should consider buying new labels. Photocopier 
labels aren’t designed to withstand the heat or bending 
that occurs in printers, and might damage your printer.

 

Calibrating Sheet-Feed Printers
If you’re printing on sheet-feed labels (for laser or ink-jet printers), you 
can adjust the horizontal and vertical alignment of the printed labels.
1. Place a blank sheet of labels in your printer.
2. Open the File menu and choose Print Preview > Active Output Form 

to open the preview window.
3. Click the Calibrate button to open the Laser Print Alignment dialog.
4. Click the Calibrate button in the dialog to print two sets of grid lines 

on the page of labels. 
5. Look at the vertical grid and find the number that crosses the bottom 

of the first row of labels. Enter this number in step 4 of the dialog.
6. Look at the horizontal grid and find the number that crosses the right 

edge of the first column of labels. Enter this number in step 5 of the 
dialog.

7. Click OK to save the new settings.
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Using Form-Feed Labels
When using a form-feed printer, be sure you’re using the correct printer 
driver. Some printer drivers aren’t designed for printing labels. If you 
encounter a problem with labels being skipped, it might be a problem with 
your printer driver. For information about getting the latest printer driver 
for your printer, see “Updating Printer Drivers” on page 314.

Adjusting Form-Feed Printers
If you’re using a form-feed or dot-matrix printer, and your data isn’t 
aligned properly, you must adjust the alignment manually.
If the data is crooked when it prints, make sure that the paper or other 
material has been loaded correctly.
To center the data on the printing stock, try this:
1. Turn off the printer.
2. Turn the printer’s platen knob up or down to adjust the alignment.
3. Turn the printer back on.
4. Print a small number of records to test the new alignment.
5. Repeat steps 2-4 until the data prints correctly.
For more information about loading your printing stock and aligning your 
data, see your printer’s documentation.
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Printing Envelopes

Overview
When you choose to print an envelope, DataBase attempts to determine 
your printer’s envelope-feed orientation, so that the address information is 
placed correctly.

Testing the Envelope Setup
Before you print your data, print a test envelope to make sure that the 
envelope feeds correctly, and that addresses print in the correct locations.
1. Click the Output Forms tab and choose a design from the Envelopes 

folder.
2. Open the File menu and choose Print > Active Output Form to open 

the Print dialog.
3. Set the Print Range to print only one record by entering the same 

record number in both the From box and the To box. 
4. For example, From 1 To 1.
5. Place an envelope in your printer as directed by the printer’s 

documentation.
6. Click Print to print a sample envelope.
After printing a test envelope, you can change DataBase’s envelope-feed 
settings, or adjust the address locations as needed.
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Changing the Envelope Feed Settings
When you choose to print an envelope, DataBase attempts to determine 
your printer’s envelope feed orientation so that the address information is 
placed correctly. If DataBase can’t determine the correct settings, you’ll 
have to specify the feed orientation yourself.

IMPORTANT: DataBase can only identify the envelope 
orientation that the printer expects. Changing the feed 
method and flap orientation options in the Envelope Setup 
dialog won’t change how the printer actually prints.

 

To Change the Envelope Feed Settings
1. Make sure an envelope form appears in the Output Forms window. 
2. Open the File menu and choose Print > Form to open the Print dialog.
3. Click the Envelope Setup button to open the Envelope Setup dialog. 

4. Make sure the correct printer appears in the Printer Name area.
5. Choose the location of your envelopes within the printer from the 

Feed From list.
6. Refer to your printer’s documentation to see how envelopes should be 

fed into the printer.
7. Click an option in the Feed Method box to indicate the envelope’s 

position in the printer’s paper tray.
8. Choose an option from the Envelope Flap Orientation box to 

indicate the position of the envelope flap.
9. Click OK to keep the new settings and return to the Print dialog.
After adjusting the feed method, print another test envelope to see if 
further adjustments are needed (see “Testing the Envelope Setup” on page 
201).

DataBase stores the feed 
method until you print an 
envelope on a different 
printer, choose a different 
paper size, or update your 
printer driver.

 
If the envelope feeds into the printer correctly, but you need to adjust the 
position of the addresses, you can change the envelope margins (see 
“Adjusting the Envelope Margins” on page 203).
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Adjusting the Envelope Margins
You can make minor adjustments to the location of the return address and 
recipient’s address by changing the envelope margins.
1. Make sure an envelope appears in the Output Forms window. 
2. To choose an envelope, click the Output Forms tab and choose a 

design from the Envelopes folder.
3. Open the File menu and choose Print > Active Output Form to open 

the Print dialog.
4. Click the Envelope Setup button to open the Envelope Setup dialog. 
5. Click the Envelope Margins tab.

Adjusting the envelope margins 
won’t change the form design.

  

6. Enter a number in the Horizontal box or click the arrows to adjust the 
horizontal position of the addresses.

7. Enter a number in the Vertical box or click the arrows to adjust the 
vertical position of the addresses. 
As you adjust the numbers, the Preview changes to show you where 
the addresses will print on the envelope.

8. Click OK to keep your changes and return to the Print dialog, or click 
Apply to keep your changes and make other changes to the envelope 
setup.

After adjusting the margins, print another test envelope to see if further 
changes are needed (see “Testing the Envelope Setup” on page 201).
DataBase stores the margin settings until you print an envelope on a 
different printer, choose a different paper size, or update your printer 
driver.
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Printing the Data Table

Overview
To print your data in a table, print the Data Table. Before you print, you 
can format the data table to fit on a specific page size, and format the data 
so that it’s easy to read.

NOTE: History and Notebox fields don’t appear or print in 
the Data Table.
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Preparing the Data Table for Printing
Use the Data Table Options dialog to set the fields, fonts, printing options, 
margins, header, and footer for the Data Table.
If you want to change the width of columns or the height of the rows, see 
“Changing the Format of the Data Table” on page 81.
1. Click the Data Table tab to open the Data Table window.
2. Open the View menu and choose Change Data Table Options to 

open the Data Table Options dialog. 

3. Click the Fields tab at the top of the dialog to add or remove fields 
and define the printing options for fields (see “Setting the Data Table 
Fields for Printing” on page 207).

4. Click the Size tab at the top of the dialog to choose the page size you 
want to use (see “Setting the Data Table Printing Size” on page 208).

5. Click the Header tab or the Footer tab to set a header or a footer for 
the page (see “Setting Headers and Footers for the Data Table” on 
page 209).
The same header and footer prints on every page.

6. Click the Background tab to set the background colors for the rows 
in the Data Table (see “Setting the Data Table Background Colors” on 
page 210).
The backgound colors appear on-screen only; they don’t print.

7. Click OK to accept your changes.
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Setting the Data Table Fields for Printing
1. Click the Fields tab at the top of the Data Table Options dialog. 

2. Add or remove a field from the Data Table by checking or unchecking 
the box next to the field’s name.

3. Open the Font dialog for data fields or column headings:
• To set the font for your data, click the Data Font button.
• To set the font for the column headings, click the Title Font 

button.
4. Choose the font and font options in the Font dialog.
5. Click OK to return to the Data Table Options dialog.
6. Set the alignment of text within a column by clicking the field name 

and then choosing the alignment from Field Column Properties.
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7. Choose printing options by checking of unchecking the boxes next to 
the options:
• Check the Double-space box to print a blank line between each 

record.
• Check the Show grid lines box to print a separator line between 

every third record in your list.
• Check the Use Data Table column widths box to use the column 

widths that are displayed in the Data Table window.
• Uncheck the Use Data Table column widths box to shrink or 

expand each column to fit the data in the field.
• Check the Don’t print blank columns box to skip any columns 

that don’t contain data.
• Check the Center on page box to center the printed data on the 

page. (Use this option for one-page printouts only.)
• Check the Repeat first column on second page box to print the 

first column of data on both the first page and the second page. 
This might make the data easier to read after it’s printed.

8. Click another tab to change more options or click OK to apply your 
changes and close the Data Table Options dialog.

Setting the Data Table Printing Size
1. Click the Size tab at the top of the Data Table Options dialog. 

2. Choose the paper size you want.
If you chose Half Page or Daytimer, you can print lines to guide you 
when cutting the paper by checking the Show Cropping Lines box.

3. Enter the page margins for the paper size you selected.
4. Click another tab to change more options or click OK to apply your 

changes and close the Data Table Options dialog.
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Setting Headers and Footers for the Data Table
1. Click the Background tab at the top of the Data Table Options dialog. 

2. Check the Use Header box in the Header tab or the Use Footer box 
in the Footer tab.

3. Type the header title or footer title in the Title box.
4. Click the Justify drop-down arrow and then choose Left, Center, or 

Right to align the title text.
You can choose to display a Page # and the Date, and then set the 
position of each.

5. Click the Font button to choose the font for the header or footer text.
6. Check the Display box under Line to print a horizontal line in the 

header or footer.
The line prints above the header or footer text unless you check the  
Put line underneath box.

7. Enter the height of the header or footer to determine where the header 
or footer prints relative to the page size and margins.

8. Click another tab to change more options or click OK to apply your 
changes and close the Data Table Options dialog.
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Setting the Data Table Background Colors
1. Click the Background tab at the top of the Data Table Options dialog. 

2. Choose the color setting you want from the Background Effects list.
A preview of the color setting appears in the lower area of the dialog.

3. Click another tab to change more options or click OK to apply your 
changes and close the Data Table Options dialog.

Previewing the Data Table
You can preview the Data Table before you print it.
1. Click the Data Table tab to open the Data Table.
2. Choose a page orientation for the preview:

• To see how the data will print in portrait orientation, open the File 
menu and choose Print Preview > Data Table > Portrait.

• To see how the data will print in landscape orientation, open the 
File menu and choose Print Preview > Data Table > Landscape.

After the Preview window opens, use the toolbar at the top of the 
window to move between pages and zoom in or out of the preview.

3. Click the Print button to print the Data Table from the preview 
window.
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Printing the Data Table
Print your list in a table by printing the Data Table.
1. Click the Data Table tab to view the Data Table.
2. Open the File menu and choose Print > Data Table to open the Print 

dialog.
3. Make sure the correct printer is selected.
4. Click the Properties button to open the Printer Properties dialog.
5. Choose either Portrait or Landscape orientation.

For information about setting the properties for your printer, see your 
printer’s documentation.

6. Click OK to return to the Print dialog.
7. Choose the range of records that you want to print.
8. Set the number of copies.
9. Click OK to begin printing.
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Sending Email Messages

Overview
The email editor in DataBase lets you create email messages, as well as a 
printed, professional-looking form letters. You can use HTML formatted 
email and include special fonts, colors, pictures, and hyperlinks, or use the 
Plain Text format, which removes some of the formatting, but can be more 
readable by more email-reading software. Form letters print as you see 
them on the screen.

Writing Email Letters
Using the Email design window in DataBase, you can create an email text 
message and then send the message to the email addresses in your mailing 
list.
You can use either HTML or Plain Text format for this email message by 
choosing an option in the Format menu. Using HTML-formatted email 
preserves most of the formatting that you see in your message editor, and 
presents a more visually attractive message. Using Plain Text removes 
some of the formatting, but might be more readable by more email-
reading software.
There are four basic steps for sending an email message using DataBase.
• Step 1: Setting Email Preferences (see page 214)
• Step 2: Creating an Email Message (see page 215)
• Step 3: Previewing an Email Message (see page 227)
• Step 4: Sending Email Messages (see page 227)



214   •   Sending Email Messages DataBase Professional

Step 1: Setting Email Preferences
Before you can use DataBase to send email, you need to set the following 
email preferences.
• Return Information including your name and email address
• Database Fields specifying the email field name
• Email Server information
To set these preferences, open the Email menu and choose Preferences. 

1. Enter your name in the From Name box.
2. Enter your email address in the From Email Address box.

When the recipient opens 
the email, the From 
Name and the From 
Email Address appear at 
the top of the email.

 
3. Click the Primary Email Address drop-down arrow and choose the 

field that contains the email address for each record in the data base.
4. If you created a field to keep track of the date when you send an email 

to someone, click the Last Sent Date drop-down arrow and choose 
the field.

5. Enter your SMTP mail server in the SMTP Mail Server box.
Contact your Internet 
Service Provider (ISP) or 
your company’s system 
administrator for the 
Email Server information.

 
6. The following information might be optional depending on the 

requirements of your ISP. 
• Your POP3 Mail Server

For most ISPs, you should leave POP3 Mail Server blank.
• The email server Domain Name

• The user ID and Password that you use to log into your email 
server

NOTE: If you use AOL or Hotmail for your email server, 
you might be able to enter your AOL or Hotmail email 
address in the Return Information but you can’t use AOL or 
Hotmail to send email messages using DataBase.
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Step 2: Creating an Email Message
You can create an email message using the Email design window in 
DataBase. The email message is saved with the database file that is open 
when you create the email message. After creating an email message, you 
can modify the email message, rename the email message, and create 
copies of the email message.
To display the Email design window, click the Email tab. 

Creating a New Email Message
1. Click the Saved folder in the Personal Mails list.
2. If you’re logged is as the administrator, click the Saved folder in the 

Shared Mail list.
3. Click the Manage Message button and choose New Message to 

open the New Message dialog.
4. Enter a name for the message in Enter an Email Message Name box. 

5. Click OK to close the New Message dialog.
The new Email Message Name appears in the Email Messages list 
and the Email Editor appears.

It’s a good idea to give the 
message a name that will 
help you identify the 
content of the message.
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Adding Recipients to an Email
1. Click the To button in the Email Editor to open the Send To dialog.

2. Choose one of the Select Recipients options.
• All Records in the Database includes everyone in the current 

database.
• All Records in the currently applied filter includes only those 

records selected by the current filter. For information about using 
Filters, see “Filtering Records” on page 100.

• Selected Records in the Data Table includes only those records 
currently selected from the data table. For more information, see 
“Selecting a Group of Records” on page 108.

• Selected Recipient Group from available filters allows you to 
specify your recipients from filters you have created. These 
appear in the Recipient Groups area of this dialog. For 
information about using Filters, see “Filtering Records” on page 
100.
To use available filters, select a filter in the Recipient Groups 
list and then click the Add button to move the filter to the To list.

3. Click OK to return to the Email Editor.
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Composing an Email Message
Enter the content of your message in the lower part of the Email Editor.

This is the body of the email message, where you can type text and insert 
fields (“Inserting a Field in a Message” on page 224), hyperlinks 
(“Inserting a Hyperlink” on page 225), and pictures (“Adding Pictures to 
the Message” on page 219).
After creating the message, open the Message menu and choose Save or 
click the Save button in the toolbar to save this message.

To Choose the Format of the Message
The email message can be composed as either Plain Text or HTML 
formatted.
• Plain Text formatted messages are sent as text only with no graphics 

or special effects and are less likely to get refused be some email 
services.

• HTML formatted messages can be made to look like a webpage with 
graphics, colors, and special text, but not all email services support 
HTML formatted messages.

To choose the format of the email message, open the Format menu and 
choose either Plain Text or HTML
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Formatting the Message Text
When you choose the HTML format for the email message, you can 
include special fonts, colors, styles, and text alignment.

Font

Size

Color

Style

Alignment

• Font selects the type of font to use. Click the drop-down list and 
choose from the list of fonts installed on your system.

TIP: Not all recipients will have the same fonts on their 
computers as you do. Try to use common fonts, such as 
Arial or Times New Roman when composing HTML-
formatted email messages.

• Size selects the size of the font. Click the drop-down list and choose 
from the list of available sizes.

• Color changes the color of the text. Click the drop-down list to choose 
a color, or click More Colors to create a custom color.

• Style options change the style of the font. The bold, italic, and 
underline styles can be combined to create the desired look.

• Alignment options align the text to the left, center, or right.

To Change the Text Format
Select the text to want to change by clicking at the beginning of the text, 
holding the left mouse button down, and moving the mouse to select the 
desired text. While the text is selected, choose from the formatting options 
to see the text change.
If you want to enter new text with special formatting, select the type of 
formatting first before adding your new text.
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Adding Pictures to the Message
Pictures can be placed in-line with text, or aligned using the left, center, 
and right alignment buttons (see “Formatting the Message Text” on page 
218).
To add a picture to a message, click where you want the picture in the 
message, and then open the Insert menu and choose Picture to display the 
Open dialog.

Locate the folder where the picture is saved, choose the file you want, and 
then click Open.

To Resize a Picture
1. Click the picture to select it.
2. Place the cursor over one of the handles to change the cursor to the 

resize cursor (double-arrow).

To resize the picture, click 
and drag the handle.

  

3. Click and drag the handle to resize the picture.
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Modifying an Email Message Name
After creating an email message, you can Copy, Rename, and Delete the 
message.

To Copy an Email Message
You can create a new email message from an email message listed in the 
Email Messages list using the Copy Message dialog.
1. Click the email message name to select the message that you want to 

copy.
2. Click the Manage Message button and choose Copy Message to 

open the Copy Message dialog. 

3. Enter a name for the message you’re creating in the Enter a Name for 
the Copied Message box.

4. Click OK. 
The original message name and the new message name appear in the 
Email Messages list.
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To Rename an Email Message
1. Click the email message you want to rename in the Email Messages 

box.
2. Clickthe Manage Message button and choose Rename Message to 

open the Rename Message dialog. 

3. Replace the email message name with the new name in the Enter a 
New Name for the Selected Message box.

4. Click OK. 
The new message name appears in the Email Messages list and the 
original message name is removed from the list.

To Delete an Email Message
1. Click the email message listed in the Email Messages box.
2. Click the Manage Message button and choose Delete Message or 

press DELETE on you keyboard.
A warning dialog appears describing the email message you’re going 
to delete and asks if you would like to continue.

3. Click Yes.
The email message name is removed from the Email Messages list.

Editing an Email Message
Choose the email message from the list, click the Manage Message 
button, and choose Edit Message to open the Email Editor. You can 
change the subject, attachments, body, and recipients of the message. For 
more information, see “Composing an Email Message” on page 217.
To save the message, open the Message menu and choose Save or click 
the Save button in the toolbar.
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Checking Your Spelling
Click in the body of the message and then open the Tools menu and 
choose Check Spelling or click the Spell Check button.
If the spell checker finds a misspelled word, the Spelling dialog appears. 

• Click Ignore if you want the spell checker to ignore the misspelling of 
the selected word.

• Click Ignore All if you want the spell checker to ignore this spelling 
throughout the body of the email.

• Click a word in the Suggestions box and then click Change to 
change the selected word to the suggested word.

• Click a word in the Suggestions box and then click Change All to 
change this misspelled word throughout the body of the email.

• Click Add to add the word to the spell checker dictionary.
• Click AutoCorrect to automatically correct for this word.
• Click Options to open the Spell Checker Options dialog.
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To Set the Spell Checker Options
To set spell-checking options, open the Tools menu and choose Spell 
Checker Options, or click the Spell Check Options button to open the 
Spell Checker Options dialog. 

• Select from the available Spelling options by checking the boxes next 
to the options you want to use.

• Click the Dictionaries button next to the Custom dictionary drop-
down list to locate a Custom dictionary file.

• Click the Dictionaries button next to the Main dictionary file drop-
down list to locate a dictionary file.

When you’re finished setting the Spell Checker Options, click OK.
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Inserting a Field in a Message
You can insert fields in the subject line and the body of your email 
message. When you send the email message, the data in the field for each 
record appears in the message.
For example, you can personalize your message by inserting the first name 
field at the top of the body of the message. When the email is opened, the 
recipient’s name appears at the top of the message.
1. Click in the subject line or the body of the message where you want 

the field placed.
2. Click the Insert Field button to open the Insert Field dialog. 

3. Choose a field name from the list.
4. Click OK.
Be sure that all the records in the mailing list contain data in the field that 
you choose. If a record doesn’t contain data in the field, the email displays 
a blank space instead of information. For example, you can enter Dear 
and then choose the First Name field from the Insert Field dialog. When 
you send the email message, the records that don’t have a first name in the 
First Name field will display empty space after the word Dear.
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Inserting a Hyperlink
1. Choose the location in the email message for the hyperlink.
2. Open the Insert menu and choose Hyperlink to open the Apply 

Hyperlink dialog. 

If you highlight a word or some text before opening the Apply 
Hyperlink dialog, the text automatically appears as the Link Text.

3. Type the text for the hyperlink in the Link Text box.
4. Type hyperlink location in the Link Code (or URL) box.

• To link to a web page, start with http:// 
• To link to an email address, start with mailto:

5. Click OK to add the link.

Attaching Files to an Email Message
When you attach files to an email message, the files are sent to the 
recipients along with the message. The list of attached files is saved with 
the message.
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To Attach a File to a Message
1. Click the email message in the Email Messages list.
2. Click the Manage Message button and choose Edit Message to open 

the email editor.
3. Click the Attach button to display the Open dialog. 

4. Locate and open the folder where the file is saved.
5. Select the file you want to attach.
6. Click Open to add the file to the Attachment line.

To Delete an Attachment
1. Click the email message in the Email Messages list.
2. Click the Manage Message button and choose Edit Message to open 

the email editor.
3. Choose the file from the Attachment drop-down list.
4. Click Remove to remove the file.

Storing an Email Message
The email messages listed in the Email tab are stored with the DataBase 
file. To save the messages, save the file before closing it.
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Step 3: Previewing an Email Message
You can preview an email message before sending it to email addresses in 
your records. 
1. Click the email message in the Email Messages list.
2. Click the Manage Message button and choose Edit Message to open 

the email editor.
3. Open the Message menu and choose Preview Email or click the 

Preview Email button to display a preview of the email message 
using the data from the first selected record.
If there are no recipents for the message, the field names appear in the 
preview (see “Adding Recipients to an Email” on page 216).

4. When you’re finished previewing the message, click the X in the 
upper-right corner to close the message preview.

Step 4: Sending Email Messages
When you want to send an email message that you have created in 
DataBase follow these steps.
1. Open the database that contains the message and the records of the 

recipients.
2. Choose the email message name in the Email window.
3. Select the records of the recipents you want (see “Adding Recipients 

to an Email” on page 216).
4. Click the Send Email button to send the message.
After sending the email message, an email confirmation summary report 
appears.

When To Send an Email Message
While DataBase is sending your email message you might not be able to 
access your email service. We recommend that you plan to send an email 
message to your mailing list at a time of day when you may not need to 
use your email service for other email messages.
DataBase can send approximately 16 messages per minute or 1000 
messages per hour.
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Sending the Email Message
To send the selected message, click the Send Email button. A window 
appears with some important information about email rules. For more 
information, see “Establishing Good Email Customer Relationships” on 
page 230.
A confirmation dialog appears with a message to confirm the number of 
emails to be sent and ask if you would like continue. 

Click Yes in the Email Confirmation dialog to begin the process of 
sending the email. A progress indicator appears showing the percentage of 
emails sent. The Cancel button gives you the option of canceling the 
sending process stopping the remaining emails from being sent.
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Using the Emailer Summary
After the emails are sent, the Email Summary displays a list of the email 
addresses where you sent this email. 

Each email address has a status assigned to it to let you know whether or 
not the email was successfully sent to that address. The list displays the 
recipients of the email along with the status of the email that was sent to 
each recipient. Use the scroll bars on the right and the bottom to view the 
entire list. To sort the list, click one of the column headings.
The following messages may appear in the status column:
Success The message was sent successfully.
Fail The message was not able to be sent. This may be due to an 

incorrect entry in the Email Preferences dialog or an 
incorrectly entered email address.

Skipped The email address is missing, so the program skipped this 
recipient. To send future emails to this recipient, enter an 
email address in the contact information for this recipient.

Canceled  The email was not sent, because the email process was 
interrupted.

 The summary below the list displays the following information:
Missing Email 
Addresses

The number of selected recipients that do not have an email 
address in the email field.

Successful Sends The number of emails that were successfully sent.
Failed Sends The number of emails that failed to be sent. This may be 

due to an incorrect entry in the Email Preferences dialog or 
an incorrectly entered email address.

Total Emails 
Processed

The total number of emails processed, including Missing 
Email Addresses, Successful Sends, and Failed Sends.
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Viewing the Message History
The message history dialog shows a list of all instances a selected message 
has been sent. To view the history of a message, choose the message and 
then click the Manage Message button and choose Message History. 

Each sending instance appears on a separate line telling when the message 
was sent, to whom it was sent, the total number of recipients, and the 
success rate. The history list can be sorted by clicking a column heading.

Establishing Good Email Customer Relationships
Respecting and protecting the privacy rights of your customers is a 
fundamental element of email marketing.
When sending email to customers in your mailing list, be sure to follow 
these guidelines.
• Don’t Send Unsolicited Email Messages (see page 231)
• Provide Notice Within Email Messages (see page 232)
• Send Relevant Content (see page 233)
• Protect Recipient’s Personal Information (see page 233)
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Don’t Send Unsolicited Email Messages
Sending customers an email message that is part of a mass mailing without 
their permission, or sending an email to an inappropriate list is considered 
SPAM or Unsolicited Commercial Email. 
The following table provides you with guidelines for sending acceptable 
email messages.

Acceptable Email For Example...
The customer has opted-in 
to receive the email.

“you’re receiving this email because you opted-in 
to receive our newsletter.”

The email updates the status 
of an order.

“Thank you for your recent order. Please make 
note of this reference number: 4231.”

The email is in regards to an 
invoice or receipt.

“Thank you for using our service. Below is your 
invoice for the month of December.”

The email acknowledges 
receipt of communications.

“Thank you for your message. We received it and 
will get back to you as soon as possible.”

Gaining Consent
Consent is the process in which a recipient actively gives permission to be 
added to your list to receive future communications. Consent can be given 
by marking a check box or clicking a button that you provide on your 
business Web site.
Refrain from using pre-checked opt-in boxes to gain consent. A pre-
checked box doesn’t qualify as gaining consent. Forcing your customers to 
actively clear a box in order to not receive emails from your company is a 
form of opt-out, not opt-in.
Invite your customers to opt-in to your email list. Include the following in 
your invitation to opt-in.
• Let the customer know how you obtained their names and/or email 

addresses.
• Invite the customer to register for future emails.
• Inform the customer that they won’t be added to your email list if they 

ignore or delete the invitation email.
• Let the customer know how they can register complaints and 

unsubscribe.
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Collecting Personal Information
Provide your customers with a clear and conspicuous notice at the point of 
collection of their personal information. Include in your notice the primary 
purpose for collecting their personal information. 
When your customers are informed about why you want information from 
them, they will feel more comfortable about giving it to you and will more 
likely give you permission to send them email messages.

Provide Notice Within Email Messages
When you send email messages to your customers, be sure to include the 
following information.
• The name of your company
• A valid “From” address to which customers can reply
• A prominent notice stating how the customer can contact you and 

unsubscribe to your email list

NOTE: When sending emails to AOL addresses, your 
emails should also include information about how you 
obtained the customer’s email address, your mailing 
address, and whether it’s a one-time mailing or a recurring 
mailing.

Removing Unsubscribers From Your Email List
Customers who unsubscribe to your email list shouldn’t receive any future 
emails unless they opt-in again. Removing all unsubscribes from the email 
list before your next mailing will prevent you from sending an email to 
recipients who have recently requested to be unsubscribed.
An easy way to filter your email list of unsubscribers is to mark a Do Not 
Email List check box in the Data Entry window. Before you send an email 
message, those records marked with Do Not Email List can be filtered out 
of the list so that they won’t receive the email message.
You can also use a Do Not Call List check box in a similar way to filter out 
those who do not want to be called on the telephone.
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Send Relevant Content
Send email messages that contain information that your customers are 
interested in. This practice will lower your unsubscribe rate and increase 
customer satisfaction.

Protect Recipient’s Personal Information
Take reasonable measures to limit access to customer’s personal 
information and to ensure that individuals with access to the personal 
information don’t utilize it for unauthorized purposes. 
For more information about protecting consumer privacy, contact the 
Direct Marketing Association (DMA) at http://www.the-dma.org/.

http://www.the-dma.org/
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Creating Form Letters

Overview
You can use the email message editor to create a printed, professional-
looking form letter with special fonts, colors, and graphics.
The steps used to create a form letter are similar to those of creating an 
email message. In fact, the form letter and email can be the same letter.
Form letters, like email messages, can also use fields within the message 
body to personalize the letter. In addition, the To button is used to 
determine for whom the letters are printed. For more information, see 
“Adding Recipients to an Email” on page 216.

TIP: Hyperlinks with link text, such as Click Here, don’t 
display the actual link code (or URL) in the body of printed 
form letters (see “Inserting a Hyperlink” on page 225). If 
you want to include a link address, add it to the message 
text.

 

For information about creating email messages, see “Sending Email 
Messages” on page 213.
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Using Headers and Footers
Headers and Footers are editable portions of the letter located at the top 
and bottom of the letter. These sections can contain pictures, headlines, 
addresses, or other information to create a more professional letter. 
Headers and footers do not appear in email messages.

To Add a Header and Footer
Open the Edit menu and choose Header/Footer. The dotted line separates 
the header and footer from the body of the message. You can click in 
either the header (top) or the footer (bottom) and enter formatted text, add 
fields, or insert pictures.
To turn off editing the header or footer, open the Edit menu and choose the 
Header/Footer again. This leaves the header and footer visible, while 
preventing you from making any unwanted changes.

To View the Header and Footer
Open the View menu and choose Header/Footer to show or hide the 
header and footer. 

TIP: Headers and Footers always print, so be sure to view 
them before printing the form letter. 

Adding Page Numbers
Page numbers can be added to the header or footer of the letter. The page 
numbers automatically adjust as additional pages are added.
1. Open the Edit menu and choose Header/Footer to turn on editing for 

the header and footer.
2. Click in the header or footer where you want to insert the page 

number.
3. Open the Insert menu, choose Page Numbering and then choose one 

of the options.
• Page Number inserts the number of the page, such as 1, 2, 3, etc.
• Total Number of Pages inserts the page number of the total 

number of pages, such as 1 of 4, 2 of 4, 3 of 4, etc.
You can use the formatting options to change the way the page numbers 
look. For more information, see “Formatting the Message Text” on page 
218.
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Previewing Form Letters
You can preview a message to see how it will look as a printed form letter.
1. Click the email message in the Email Messages list.
2. Click the Manage Message button and choose Edit Message to open 

the email editor.
3. Open the Message menu and choose Print Preview or click the Print 

Preview Message button in the toolbar to display a preview of the 
form letter using the data from the selected records in your database.
If there are no recipents for the message, the field names appear in the 
preview (see “Adding Recipients to an Email” on page 216).
You can use the buttons in the toolbar at the top of the preview 
window to print, setup your printer, navigate through the pages, 
change the page view, and close the window.

4. When you’re finished previewing the message, click the Print button 
to print the letters or click the Close button to close the window.
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Printing Form Letters
1. Click the email message in the Email Messages list.
2. Click the Manage Message button and choose Edit Message to open 

the email editor.
3. Open the Message menu and choose Print or click the Print 

Message button in the toolbar to open the Print Message dialog..

4. Make sure the correct printer is selected.
5. Select the records to print from the options in the Print Range box.

• The selected Recipient Group (filter)
• All records
• A range of records

6. Enter the number of copies of each record you want to print.
The number you enter determines the number of letters to print for 
each record. For example, if you want to print two copies for each 
record, enter 2. 

7. If you’re making multiple copies of more than one record, set the 
Collate option. 
• Check the Collate box to print the entire set of records once, and 

then print the entire set again until the number of copies you 
entered have been printed.

• Uncheck the Collate box to print the first record the number of 
times you entered in the Copies box, followed by the second 
record, etc.

8. Click Print to begin printing your letters.
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Creating Standard Reports

Overview
DataBase allows you to create and print standard and custom reports from 
your database.
• Standard reports appear and print your data in a table. You can choose 

the fields to include in your report, calculate subtotals, filter the 
records for your report, and format the text that will appear in your 
report.

• Custom reports have a flexible design that allows you to determine 
which data fields to use and how the report will appear and print. For 
more information about working with the Custom Reports window, 
see “Creating Custom Reports” on page 257.

Regular users can customize the reports in their Personal Reports list 
only. The reports in the Shared Reports list can be customized only by 
the database administrator.
The administrator doesn’t have a Personal Reports list when using the 
Administrator login. 
Regular user’s can copy forms from the Shared Reports list to their 
Personal Reports list. However, you can’t add a form from a Regular 
user’s Personal Reports list to the Shared Reports list.
To view the Standard Reports window, click the Standard Reports tab.
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Choosing an Existing Standard Report
To view the existing standard reports, click the Standard Reports tab. The 
existing reports appear in the left panel of the Reports window.

If you’re using a custom 
database, you need to 
create the reports.

  

To choose a standard report, click a report name on the left.

You can make changes 
to the report in the 
right side of the 
Reports window.

 
• Regular users can choose the reports in the Shared Reports list or in 

their Personal Reports list. 
• The administrator doesn’t have a Personal Reports list when using 

the Administrator login. 
The forms in the Shared Reports list can be customized only by the 
database administrator.
You can’t add a form from a Regular user’s Personal Reports list to the 
Shared Reports list.
Regular user’s can copy forms from the Shared Reports list to their 
Personal Reports list. However, you can’t add a form from a Regular 
user’s Personal Reports list to the Shared Reports list.
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Editing a Standard Report
You can make changes to an existing standard report, create new reports, 
and delete reports in the Standard Reports window. You can use a report in 
the list as a template by making a copy of the report and renaming it. 
If you want to modify a standard report, you can make changes to the 
format, the sorting and filtering of records, and the total and subtotal 
configuration.
The forms in the Shared Reports list can be customized only by the 
database administrator. However, Regular users can copy a shared report 
to their Personal Reports list to customize it. You can’t add a form from a 
Regular user’s Personal Reports list to the Shared Reports list.

Copying a Standard Report
When you create a copy of a standard report you give a new name to the 
copy of the original report while keeping the original report unchanged. 
You can modify the copy using the Standard Reports window.
To create a copy of a standard report, select a report name listed on the left 
side of the Standard Reports window and then click the Copy Report 
button. Name the new report in the Copy Report dialog and then click OK. 

Renaming a Standard Report
To rename a standard report, select a report name listed on the left side of 
the Reports window and then click the Rename button. 

Enter a new name and then click OK.
The reports in the Shared Reports list can only be renamed by the 
database administrator.
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Creating a New Standard Report
1. Click the New Report button to open the New Report dialog. 

2. Enter the report name in the New Report dialog.
3. Click OK to close the New Report dialog.
The report name appears on the left side of the Standard Report window.

Deleting a Standard Report
You can delete a standard report from your DataBase file. Select the report 
in the list of reports on the left side of the Standard Reports window. 
The reports in the Shared Reports list can be deleted only by the database 
administrator.
To delete the report from your data file, click Delete.

NOTE: When you delete a standard report, the data in the 
fields of the report remains in the database.

 

Setting Up the Page Layout for a Standard Report
When you create or print a standard report, you can choose the page 
orientation and other printer-specific layout options. You can also set 
readability options, such as drawing lines and setting margins.
• For information about choosing the page orientation, see “Choosing 

the Page Orientation” below.
• For printer-specific layout options, click the Print Setup button to 

open the Print Setup dialog for your printer (see the documentation 
for your printer).

• For information about drawing lines and setting margins, see “Setting 
Readability Options” on page 253.
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Choosing the Page Orientation
To set the report page orientation, choose one of these options.

Portrait The report prints with the top of the page along the short side of 
the paper.

Landscape The report prints with the top of the page along the long side of 
the paper.

Adding and Removing Columns in the Standard Report
Format the columns in your standard report in the Column Selection 
section of the Standard Reports window. 

Choose the fields you want to include in your report in the Field Selection 
box. You can also set the order of the fields, the Column Width, and enter 
a Column Heading in the Field Selection box.
The reports in the Shared Reports list can be customized only by the 
database administrator.

Choosing the Fields for the Standard Report
All of the fields in your data file are listed in the Field Selection box. 
• To choose a field that you want to appear in your report, check the 

box next to the field. 
• To choose all the fields in the field list, click the Select All button.
• To uncheck all the field boxes, click Unselect All.
Only the fields that you check will appear in your report.
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Changing the Order of the Columns
You can change the order that the fields appear in your report by clicking 
the Move Up and Move Down buttons.
To move a field to a new position, choose a field in the field list.
• To move the column to the left, click the Move Up button.
• To move the column to the right, click the Move Down button. 
Continue to click the Move Up or Move Down buttons until the field is in 
position you want.

Setting the Size of a Column
You can define a different column width for each field in your report.
To set the column width for a field, click the field name in the list and 
enter the width in inches in the Column Width box.
When you choose an Image field, you can set the height of the field for the 
report by entering the height in the Image Field Height box.

Finding the Maximum Column Width
When the data in a field is longer than the column width, it won’t all 
appear in the column. DataBase can scan the data in the fields of each 
column to find the record with the maximum text, and then use this text 
length to set the width for each of the columns in the report.
1. To begin the text scan, click the Find Max Widths button.

When DataBase is finished scanning the text, the Set Column Width 
dialog displays a list of all the fields scanned and the suggested 
column settings. 

2. To accept the suggested column widths, click OK.



DataBase Professional Creating Standard Reports   •   247

Setting the Text in the Column Heading
Enter the Column Heading for a selected field in your report in the 
Column Heading box. The text you enter appears at the top of the column 
for the selected field.
• To set the alignment of the Column Heading, click the Heading 

Justification drop-down arrow and choose Left, Right, or Center.
• To display a line under the Column Heading, check the Display a 

Line Beneath Column Headings box.
• To define the font settings for the Column Headings in your report, 

click the Headings Font button. Choose the font options in the Font 
dialog (see “Choosing the Font” on page 163) and then click OK to 
return to the Standard Reports window.

Formatting the Text in the Column
To set the alignment of the text that appears in the columns of your report, 
click the Text Justification drop-down arrow and choose Left, Right, or 
Center.
To specify the font size and style for the text in your report, click the Data 
Font button. Choose the font options in the Font dialog (see “Choosing the 
Font” on page 163) and then click OK to return the Reports window.
After changing the font, you might want to check for the recommended 
maximum column widths (see “Finding the Maximum Column Width” on 
page 246).

Setting the Text-Wrap Option
To wrap the text within a column, check the Wrap Text box. 
To specify the number of lines to wrap, click in the box to the right of the 
phrase Limit Text Wrapping to and enter the number of lines.  

NOTE: If Wrap Text isn’t marked, only one line of text 
within a field will display in the report. Notebox and 
History fields will print multiple lines even if this check box 
isn’t marked (see “Defining Notebox and History Field 
Data” below).
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Defining Notebox and History Field Data
To specify the maximum rows of the history field that you want to display 
or a Notebox field to wrap, enter a number in the box after the phrase 
Limit Printing of History and Note Fields to. For example, if you want to 
display 10 rows of the history field you would enter 10 in the Lines box.  

Sorting and Filtering the Data for the Standard Report
DataBase makes it easy to work with your data and select the records that 
you want to include in your standard report. You can sort your records to 
determine the order of the records in the report or apply a filter so that only 
particular records are included in your report.
To sort and filter the data for your standard report, scroll down to the 
Sorting, Filtering, Subtotal Properties section of the Standard Reports 
window.

The reports in the Shared 
Reports list can be 
customized only by the 
database administrator.

 

Sorting Records for the Standard Report
You have three options for sorting your records:
• Use Active Sort allows you to sort your records using the same sort 

that you defined in the Data Table or the Data Entry window (see 
“Sorting Your Data” on page 98).

• Use Custom Sort allows you to define a new sort that applies only to 
the report you’re creating. When you create a custom sort, the new 
sort settings are saved with the report; The sort settings that you 
defined in the Data Table or Data Entry window aren’t changed. To 
open the sort dialog and define the custom sort settings, click the 
Custom Sort button (see “Using the Sort Dialog” on page 99).

• Use Sort with Subtotals allows you to sort your records and define 
columns of numeric, currency, and calculated fields to total and 
subtotal for your report (see “Determining the Total and Subtotal 
Configuration” on page 249).

You can define both a Custom Sort and a Subtotal Configuration, but only 
one type of sort can be applied to a report when it’s previewed or printed. 
The Custom Sort and the Subtotal Configuration that you create are saved 
with the report so that you can choose either option when you preview or 
print the report.
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Filtering Records for the Standard Report
You have two options for filtering records:
• Use Active Filter allows you to filter your records using the same 

filter that you that you defined in the Data Table or the Data Entry 
window (see “Filtering Records” on page 100).

• Use Custom Filter allows you to define a new filter that applies only 
to the report you’re creating. When you create a custom filter, the new 
filter settings are saved with the report. The filter settings that you 
applied to the Data Table or Data Entry window aren’t changed. To 
open the filter dialog and define the custom filter settings, click the 
Custom Filter button (see “Filtering Records” on page 100).

Determining the Total and Subtotal Configuration
DataBase allows you to total and subtotal numeric, currency, and 
calculated fields between records according to the criteria you set. You can 
set up to three nested subtotal sorts.
To calculate subtotals between records, choose the Use Sort with 
Subtotals option (see “Setting the Subtotal Configurations” below).

NOTE: You can’t use a Custom Sort and a Sort with 
Subtotals at the same time in a standard report.

 

To display a total of the values in a numeric, currency, or calculated field 
at the end of the report, mark the Show Total check box (see “Configuring 
the Standard Report Total” on page 252).
The reports in the Shared Reports list can be customized only by the 
database administrator.
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Setting the Subtotal Configurations
To set the primary sort with subtotal, check the Show Subtotal/Sort 1 
box. check the other Show Subtotal/Sort boxes if needed.
Click the Configure button to open the Configure Subtotal dialog and 
define the settings for the primary subtotal. 

When you’re finished defining the settings for the subtotal, click OK to 
close the Configure Subtotal dialog. 
The Configure Subtotal dialog is described in the following sections.

Setting the Text for the Titles
To identify the subtotals in your report, you can give each subtotal a title. 
Click in the Subtotal Title box and enter the text for the title. 
When you’re finished defining the settings for the subtotal you can format 
the font (see “Formatting the Font for the Subtotal Text” on page 252).
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Determining When to Calculate the Subtotal
You can define three layers of subtotals for a report. Subtotal 1 is the 
Primary subtotal followed by Subtotal 2 and then Subtotal 3.

Subtotal values appear in the 
Subtitle Title row under the 
column that is subtotaled.

 
For example, you may want to know which products have been sold in 
each territory and by which sales representative. You could set the subtotal 
fields as follows:
• Subtotal 1 field define as Territory
• Subtotal 2 field define as Sales Representative
• Subtotal 3 field define as Product 
When the report filters your data using the subtotals, it prints the sales 
reprentative names for each territory and the products that they sold.
To define a subtotal field, choose a field in the Set Subtotal Break/Sort 
Field drop-down list. When the data in the field changes, the subtotal 
appears.
When you choose a Date field, select an option for Trigger Date Field On:

Year The subtotal is calculated when the year changes.
Month The subtotal is calculated when the month changes.
Day The subtotal is calculated each day.

Determining Which Fields to Subtotal
DataBase can calculate a subtotal value for numeric, currency, and 
calculated fields. 
To choose a field to subtotal, choose the Subtotal Fields option and then 
select the fields to be subtotaled when the Subtotal Break/Sort Field 
changes. Choose fields by checking the box next to the fields you want to 
subtotal.
To group the data when the Subtotal Break/Sort Field changes without 
subtotaling a column, choose the No Subtotal option. If you want to print 
a title line for the sort, uncheck the Don’t Print Title Line box and enter 
the title in the Subtotal Title box.

Counting the Records in the Subtotal
To display the number of records included in the subtotal, check the 
Display Record Count in Grouping box at the bottom of the Configure 
Subtotal dialog. 
If you choose the No Subtotal option and check the Don’t Print Title Line 
box, the record count won’t be included.
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Formatting the Font for the Subtotal Text
To choose the font for text that appears in the Subtotal portion of your 
report, click the Font button for the Subtotal/Sort in the Standard Reports 
window (see “Choosing the Font” on page 163).

Configuring the Standard Report Total
Check the Show Total box and click the Configure button to open the 
Configure Total dialog and define the settings. 

1. Enter a title for the total in the Total Title box.
2. Choose the Total Fields option and then choose the fields listed in the 

box that you want to total.
You can total only numeric, currency, and calculated fields. If the 
field you want to total isn’t in the list, you need to change the field 
type of that field (see “Choosing the Field Type” on page 55).

3. Check the Display Record Count in Grouping box to print the 
number of records in the total. 
The Record Count appears in the far-right column.

4. Click OK to close the Configure Total dialog.
To set the font of the Title for the Total, click the Font button (see 
“Choosing the Font” on page 163).
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Setting Readability Options
You can set spacing and rules for your report by checking the following 
boxes:

Double Spaced Sets the line spacing of the report.
Show Column 
Separator Lines

Displays vertical column lines between the fields in 
the report

Show Row Separator 
Lines Every

Displays horizontal lines between records in your 
report.
Enter the frequency of the Row Separator Lines in 
the Records box.

The reports in the Shared Reports list can be customized only by the 
database administrator.

Setting the Margins
To set the margins for the report, click the Set Margins button to open the 
Margins dialog. 

Enter the distance from the edge of the page in the boxes:

Top Enter the distance you want between the top of the page and the top 
of the first line in the report.

Left Enter the distance you want between the left edge of the page and 
the left edge of unindented lines.

Right Enter the distance you want between the right edge of the page and 
the right end of a line that has no right indent.

Bottom Enter the distance you want between the bottom of the page and the 
bottom of the last line in the report.

 

To move the cursor from one margin setting to the next, press the TAB key.
When you’re finished entering your margin settings, click OK.
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Editing Header and Footer Information
You can display a header and/or a footer in your report that includes a title 
for the report, page number(s), and the date. You can also add a line above 
or below a header or footer. The Header Properties and Footer 
Properties sections are near the bottom of the Standard Reports window.
• To include a header in your report, check the Use Header box.
• To include a footer in your report, check the Use Footer box.
The reports in the Shared Reports list can be customized only by the 
database administrator.

Setting the Text for the Title
To print the title for your report in the header or footer, click in the Title 
box and enter the title of your report.
To set the position of the title, click the Justify drop-down arrow and 
choose Left, Right, or Center.
To set the font for the title, click Title Font button and specify the font 
settings in the Font dialog (see “Choosing the Font” on page 163).

Setting the Page Number and Date
To display a page number in the header or footer, check the Display box in 
the Page # box.
To display a date in the header or footer, check the Display box in the Date 
box.
To set the alignment of the page number or date, click the Justify drop-
down arrow and choose Left, Right, or Center.
To set the font for the page number and the date, click Page #/Date Font 
button and specify the font settings in the Font dialog (see “Choosing the 
Font” on page 163).

Drawing a Line Above or Below the Text
To print a line above the header or footer, choose the Above Header or 
Above Footer option.
To print a line below the header or footer, choose the Below Header or 
Below Footer option.

Setting the Height of the Header or Footer
You can specify the amount of space below the top margin for the header 
or the amount of space above the bottom margin for the footer. 
To specify the space, click in the box to the right of Header Height or 
Footer Height and enter the amount in inches.
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Previewing a Standard Report
To generate and preview the report before you print, click Preview. 

From the Preview window, you can print the report, create a PDF version 
of the report, navigate the pages of the report, and zoom in and out on the 
report.
To close the Preview window and return to the Standard Reports window, 
click the Close button.

Printing a Standard Report
When you finish preparing the settings for your report, you can print the 
report. To open the Print dialog, click Print. For information about using 
the Print dialog, see “Printing Output Forms” on page 193.
Click OK in the Print dialog to generate and print your report.
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Exporting a Standard Report
When you finish preparing the settings for your report, you can export the 
report to a file. You can convert the report to an unformatted text file 
(*.txt), a formatted text file (*.rtf), a print-ready file (*.pdf), or a web-ready 
file (*.htm, *.html).
1. Choose the report from a list on the left.
2. Click the Convert to File button to open the Save As dialog.
3. Choose the format for the file from the Save as type drop-down list.
4. Navigate to and open the folder where you want to save the file.
5. Enter a name for the file.
6. Click Save to save the exported report file.
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Creating Custom Reports

Overview
DataBase allows you to create and print standard and custom reports from 
your database.
• Standard reports appear and print your data in a table. You can choose 

the fields to include in your report, calculate subtotals, filter the 
records for your report, and format the text that will appear in your 
report.  For more information about working with the Standard 
Reports window, see “Creating Standard Reports” on page 241.

• Custom reports have a flexible design that allows you to determine 
which data fields to use and how the report will appear and print.

Regular users can customize the reports in their Personal Reports list 
only. The reports in the Shared Reports list can be customized only by 
the database administrator.
The administrator doesn’t have a Personal Reports list when using the 
Administrator login. 
Regular user’s can copy forms from the Shared Reports list to their 
Personal Reports list. However, you can’t add a form from a Regular 
user’s Personal Reports list to the Shared Reports list.
To view the Custom Reports window, click the Custom Reports tab.
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Choosing a Custom Report
To view the custom reports, click the Custom Reports tab. The list of 
reports appear in the left panel of the Custom Reports window. 

To choose a custom report, click a report name on the left.
• Regular users can choose the reports in the Shared Reports list or in 

their Personal Reports list. 
• The administrator doesn’t have a Personal Reports list when using 

the Administrator login. 
You can make changes to the report in the right side of the Reports 
window.
The forms in the Shared Reports list can be customized only by the 
database administrator.
You can’t add a form from a Regular user’s Personal Reports list to the 
Shared Reports list.
Regular user’s can copy forms from the Shared Reports list to their 
Personal Reports list. However, you can’t add a form from a Regular 
user’s Personal Reports list to the Shared Reports list.
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Organizing Custom Reports
You can copy, rename, and delete existing custom reports in the Custom 
Reports window.
The forms in the Shared Reports list can be customized only by the 
database administrator. However, Regular users can copy a shared report 
to their Personal Reports list to customize it. You can’t add a form from a 
Regular user’s Personal Reports list to the Shared Reports list.

Copying a Custom Report
When you create a copy of a custom report you give a new name to the 
copy of the original report while keeping the original report unchanged.
To create a copy of a custom report, right-click a report name listed on the 
left side of the Custom Reports window and then choose Copy Report.  

Name the new report in the Copy Report dialog and then click OK.

Renaming a Custom Report
To rename a custom report, right-click a report name listed on the left side 
of the Custom Reports window and then choose Rename Report. 

Enter a new name and then click OK.
The reports in the Shared Reports list can only be renamed by the 
database administrator.
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Deleting a Custom Report
To delete a custom report from your DataBase file, select the report in the 
list of reports on the left side of the Custom Reports window and then 
press DELETE on your keyboard. After clicking Yes in the confirmation 
dialog, the report is permantly removed.
The reports in the Shared Reports list can be deleted only by the database 
administrator.

NOTE: When you delete a custom report, the data in the 
fields of the report remains in the database.

 

Creating a Custom Report
You can use the wizard to help you create a new report, or create a blank 
report that you can customize from scratch.
• To create a new report using the wizard, open the Report menu and 

choose New Report > New Report With Wizard (see “Using the New 
Report Wizard” on page 261).

• To create a blank report, open the Report menu and choose New 
Report > New Blank Report to open the New Report dialog. 

Enter a name for the new report and click OK to open a new blank 
report with the report name in the header.
For information about designing the report (see “Customizing a 
Custom Report” on page 267).
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Using the New Report Wizard
To start the New Report Wizard, open the Report menu and choose New 
Report > New Report With Wizard, or click the New Report button and 
choose New Report With Wizard. 

New Report 
Button

 

In the first step of the wizard, select the fields that you want to use in your 
report.
• To add a field to the report, select the field in the Available Fields list 

and then click the top arrow button between the lists.
• To add all of the fields to the report, click the second arrow button 

between the lists.
• To remove all of the fields from the report, click the third arrow 

button between the lists.
• To remove a field from the report, select the field in the Selected 

Fields list and then click the last arrow button between the lists.
After selecting the field for the report, click Next to continue.
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Selecting Sort Groups in the Wizard
In the second step of the wizard, select the fields that you want to use for 
sorting the data in the report. 

To sort the report by a field, select the field in the Available Fields list and 
then click the upper arrow button between the lists to place the field in the 
Exist Groups list. To remove a field from the Exist Groups list, select it 
and then click the lower arrow button between the lists.
You can choose to sort Ascending or Descending, and to keep none, part, 
or all of the information together in the report.
If you want the data from the sort field to appear in the header or footer of 
the group, choose the Header or Footer option. If you don’t want the data 
to appear in the header or footer, choose Not Shown.
If you have more than one sort group, you can determine the order of the 
sort by selecting a group and clicking the Up and Down buttons to move 
the selected group earlier or later in the sort order.
After you finish defining your sort groups, click Next to continue.
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Adding Totals in the Wizard
In the third step of the wizard, select the sort groups that you want to use 
to show subtotals in the report. 

To subtotal by a sort group in the report, select the sort group in the 
Groups list and then click the Add SubTotal button below the Groups list 
to place the field in the SubTotals list. To remove a sort group from the 
SubTotals list, select it and then click the Remove SubTotal button below 
the SubTotals list. 
To add a grand total, select Entire Report in the Groups list and then click 
the Add Grandtotal button below the Groups list to it add to the 
Grandtotals list. To remove a sort group from the Grandtotals list, select 
it and then click the Remove Grandtotal button below the Grandtotals 
list. 
To define a subtotal, select the sort group in the Group list and the subtotal 
in the SubTotals list, and then define the subtotal using the options on the 
right. To define a grand total, select Entire Report in the Groups list and 
the grand total in the Grandtotals list before defining the options.
If you have numeric fields in your database you can choose to Count the 
number of records or subtotal the Sum of a numeric field by selecting the 
subtotal Type and the field to Calculate On. Only numeric and calculated 
fields appear in the Calculate On drop-down list.
Define the where the total appears on the report by choosing the Header or 
Footer option.
After you finish defining your totals, click Next to continue.
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Defining a Filter in the Wizard
In the fourth step of the wizard, define the filter for the report. 

You can choose a Simple, Standard, or Advanced filter by clicking one 
of the tabs at the top of the wizard. The filters you define for custom 
reports are independent from the filters you define for the database, but the 
procedures for defining filters is very similar. For information about 
defining filters, see “Filtering Records” on page 100.
If you want to use all of your data in the report without filtering, check the 
Display All Records box at the top of the wizard.
After you finish defining your filter, click Next to continue.
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Choosing a Text Style in the Wizard
In the fifth step of the wizard, choose a text style for the report. 

Choose a style from the list on the right. A preview of the style appears on 
the left.
After choosing a text style, click Next to continue.
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Naming the Report in the Wizard
In the sixth step of the wizard, enter a name and choose the page 
orientation for the report. 

Enter the name of the report in the Report Name box. This name appears 
in the Reports list on the left side of the Custom Reports window and in 
the header of the report.
Choose either Landscape or Portrait page orientation for the report.
You can choose to view the report in the design view or the preview after 
closing the wizard by choosing either Design Report or Preview Report.
After naming the report and choosing the layout and view options, click 
Finish to close the wizard.
You can further customize the report using the features in the toolbars and 
menus in the Custom Reports window (see “Customizing a Custom 
Report” on page 267).
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Customizing a Custom Report
Below the tabs in the Custom Report window is a second set of menus and 
toolbars that contain features for customizing and working with reports.  

The toolbars can be turned off and on by opening the View menu and 
choosing Toolbars, and then selecting the toolbar from the list. You can 
also drag the toolbars into different positions.
The design area on the right side of the Custom Reports window lets you 
define the layout of your report. In the Design view, the grid lines help you 
align the fields and text in the report. 
• To turn the gridlines off and on in the Design view, open the View 

menu and choose Show Grid.
• To have the fields and text boxes attach to the grid lines when you 

move them, open the View menu and choose Snap to Grid.
To switch between the Design view and the Preview, open the View menu 
and choose Design or Preview, or click the Design or Preview buttons in 
the toolbar.

Preview 
Button

Design 
Button  
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Defining the Structure of a Custom Report
Custom reports use a “nested” structure of headers, footers, and details. 

• The Report Header and Report Footer appear at the beginning and 
end of the entire report.

• The Page Header and Page Footer appear at the top and bottom of 
each page in the report.

• The Group Header and Group Footer appear at the top and bottom 
of each group. You can have multiple group headers and footers in a 
report.

• The Detail section appears within a group and can contain the data 
from the individual records in your database.

You can add fields, text, and graphics to any of the header, footer, or detail 
areas of your report. To change the height of a section, click and drag the 
line below the section.
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Choosing the Page Layout for a Custom Report
When you create or print a custom report, you can choose the page 
orientation and set the page margins. To set up the page for a report, select 
the report in the left pane and then open the Report menu and choose 
Page Setup to open the Page Setup dialog. 

Define the paper size by choosing an option from the Size drop-down list. 
The available page sizes depend on the printer you’re using. You can also 
choose the paper tray on you printer where your report paper will be.
Choose one of the Orientation options:
• Portrait prints the report with the top of the page along the short side 

of the paper.
• Landscape prints the report with the top of the page along the long 

side of the paper.
Set the page margins by entering numbers in the Left, Right, Top, and 
Bottom boxes.
Click OK to close the dialog and save your selections.

Adding Data Fields to a Custom Report
You can add fields from your database to any of the header, footer, or 
detail areas of your report.
To add a data field, open the Insert menu and choose Data Fields or click 
the Insert Data Field button in the toolbar to open a list of the available 
fields in your database. Choose a data field from the list and then click in 
the Design area of the report to place the field.  

You can click and drag the field to move it to any location on the report. 
To resize the field, click and drag one of the sizing handles.
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Adding Special Fields to a Custom Report
Special fields add specific content about the report to the report design. 
For example, you can add the page number to the page footer or add the 
date that the report was created or printed. You can add special fields to 
any of the header, footer, or detail areas of your report.
To add a special field, open the Insert menu and choose Special Fields or 
click the Insert Special Field button in the toolbar to open a list of the 
available special fields. Choose a special field from the list and then click 
in the Design area of the report to place the field.
You can click and drag the field to move it to any location on the report. 
To resize the field, click and drag one of the sizing handles.

Adding Text to a Custom Report
You can add text to any of the header, footer, or detail areas of your report.
To add text, open the Insert menu and choose Text or click the Insert Text 
Field button. Then, click in the Design area of the report to place the text 
field.
To edit the text in the field, double-click in the field to highlight the text. 
After you finish editing the text, click the design area to deselect the field.
You can click and drag the text field to move it to any location on the 
report. To resize the text field, click and drag one of the sizing handles.

Formatting Text in Custom Report Fields
You can change the font, size, and color of text in the fields of your report 
using the options in the toolbars or the Object Properties dialog. All of the 
text in a selected data field, special field, or text field changes when you 
choose formatting options.
The Field Property toolbar gives you quick access to several text options 
for the text on your report.  

To change the text format of a field using the Field Property toolbar, select 
the field and then click an option in the toolbar.
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To Format Text Using the Object Properties Dialog
1. Select the field that contains the text you want to format.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click the Font tab to choose the font for the text in the field.
As you make choices, the Sample box shows how the text will appear 
on your report.

4. Scroll in the Font box and choose a font that you want to use for your 
text.

5. Choose a Font style and Size from the available options.
6. Choose the effects that you want to apply to your text.

• Check the Strikethrough box to display the text with a horizontal 
line through the center of the text.

• Check the Underline box to display underlined text.
• Click in the Color box to open the color palette and choose a 

color for the text.
7. Click another tab to change other properties, or click OK to close the 

Object Properties dialog and apply your changes.
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Aligning and Rotating Text in Custom Report Fields
The Object Properties dialog allows you to align and rotate the text within 
fields, as well as change the format of the font. For information about 
changing the font format, see “Formatting Text in Custom Report Fields” 
on page 270.

To Align the Text in a Field
1. Select the field that contains the text you want to align.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click the Text Attribute tab to choose the alignment option for the 
text in the field.

4. Choose one of the six Alignment options to define how the text will 
be aligned within the boundaries of the field.

5. Check the Allow Word Wrap box to allow text to wrap onto another 
line if the text is wider than the boundary of the field.
To limit the field to one line of text and cut-off any text that is wider 
than the boundary of the field, uncheck this box.

6. Click another tab to change other properties, or click OK to close the 
Object Properties dialog and apply your changes.
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To Rotate the Text in a Field
1. Select the field that contains the text you want to rotate.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog. 

3. Click the Orientation tab to choose the rotation option for the text in 
the field.

4. Choose one of the three Rotate Object options to the rotation of the 
text within the field.
As you make choices, the box on the right shows how the text will 
rotate in the field.

5. Click another tab to change other properties, or click OK to close the 
Object Properties dialog and apply your changes.
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Adding Clipart to a Custom Report
You can add clipart to any of the header, footer, or detail areas of your 
report. Custom reports can use BMP, DIB, ICO, GIF, JPG, PNG, WMF, and 
EMF graphic formats.
1. Open the Insert menu and choose Clipart, or click the Clipart button 

in the Object Toolbar, to open the Insert Clipart dialog.
Clipart

  

2. Navigate to a folder and choose the clipart file you want.
3. Click Open.
4. Position the cursor on the report where you want the clipart, and then 

click to place it. 
If you want to make the clipart a specific size, you can click and drag 
when you place it.
You can click and drag the clipart to move it to any location on the report. 
To resize the clipart, click and drag one of the sizing handles.

Adding Lines and Rectangles to a Custom Report
You can add lines and rectangles to any of the header, footer, or detail 
areas of your report.
• To add a line, open the Insert menu and choose Line or click the 

Insert Line button in the toolbar, and then click where you want the 
line on the report.Line 

Button
Rectangle 

Button
 

• To add a rectangle, open the Insert menu and choose Rectangle or 
click the Insert Rectangle button in the toolbar, and then click where 
you want the rectangle on the report.

If you want to make the line or rectangle a specific size, you can click and 
drag when you place it.
You can click and drag the line or rectangle to move it to any location on 
the report. To resize the line or rectangle, click and drag one of the sizing 
handles.
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To Change the Attributes of a Line or Rectangle
1. Select the line or rectangle on your report.
2. Open the Format menu and choose Object Properties to open the 

Object Properties dialog.

To choose a color that 
isn’t in the palette, click 
Custom. 

 

3. Choose the attribute you want to change. 
• If you want to change the style, thickness, or color of a line or the 

outline of a rectangle, click the Line tab.
• If you want to change the color of the inside of a rectangle, click 

the Fill tab.
4. Choose the color from the palette or click Custom to create a custom 

color (see “Choosing a Custom Color” on page 180).
A preview of the color appears in the dialog.
To make the inside of a rectangle transparent, choose None. 

5. Choose the style and thickness of the line or outline, if you’re in the 
Line tab.

6. Click OK.
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Aligning Objects on a Custom Report
You can align objects on the report using the grid or the features in the 
Format menu and Format Toolbar.
• To turn the gridlines off and on in the Design view, open the View 

menu and choose Show Grid.
• To have the fields and text boxes attach to the grid lines when you 

move them, open the View menu and choose Snap to Grid.
The Format Toolbar gives you quick access to alignment, sizing, and 
spacing options.  

To use one of the options in the Format Toolbar, select one or more objects 
on your report, and then click a toolbar button to apply the option.
These same options are available in the Format menu under Alignment, 
Sizing, Horizontal Spacing, and Vertical Spacing.
If you want to place a row of fields in individual boxes, similar to a row of 
table cells, select the row of fields and then open the Format menu and 
choose Format as Table Row or click the Format as Table Row button in 
the toolbar.
To lock the objects on your report, so that they can’t be moved or sized, 
select an object on the report and then open the Format menu and choose 
Lock Fields or click the Lock Fields button in the toolbar. To unlock the 
objects, repeat this procedure.

Grouping, Subtotaling, and Filtering Custom Report Data
Group and subtotal the data in your records to define how the data is 
presented in the report. Apply a filter so that only particular records are 
included in your report.
Group, Subtotal, and Filter options are available in the Data Management 
menu and the Data Management Toolbar.
The reports in the Shared Reports list can be customized only by the 
database administrator.
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Selecting Groups for Sorting
In the Groups dialog, you can select the fields that you want to use for 
sorting the data in the report. To view the Groups dialog, open the Data 
Management menu and choose Grouping or click the Report Groups 
button in the toolbar. 

To sort the report by a field, select the field in the Available Fields list and 
then click the upper arrow button between the lists to place the field in the 
Exist Groups list. To remove a field from the Exist Groups list, select it 
and then click the lower arrow button between the lists.
You can choose to sort Ascending or Descending, and to keep none, part, 
or all of the information together in the report.
If you want the data from the sort field to appear in the header or footer of 
the group, choose the Header or Footer option. If you don’t want the data 
to appear in the header or footer, choose Not Shown.
If you have more than one sort group, you can determine the order of the 
sort by selecting a group and clicking the Up and Down buttons to move 
the selected group earlier or later in the sort order.
After you finish defining your sort groups, click OK.
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Adding Totals and Subtotals
In the Add Subtotal dialog, you can select the sort groups that you want to 
use to show subtotals in the report. To view the Add Subtotal dialog, open 
the Data Management menu and choose Add Subtotal or click the Add 
Subtotal button in the toolbar. 

To subtotal by a sort group in the report, select the sort group in the 
Groups list. 
To add a grand total, select Entire Report in the Groups list. 
If you have numeric fields in your database you can choose to Count the 
number of records or subtotal the Sum of a numeric field by selecting the 
subtotal Type and the field to Calculate On. Only numeric and calculated 
fields appear in the Calculate On drop-down list.
Define the where the total appears on the report by choosing the Header or 
Footer option.
After you finish defining your totals, click Add.
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To Edit Totals and Subtotals
In the Edit Subtotals dialog, you can change the properties of the sort 
groups that you want use to show subtotals in the report or remove 
subtoals from the report. To view the Edit Subtotals dialog, open the Data 
Management menu and choose Edit Subtotals or click the Edit 
Subtotals button in the toolbar. 

To define a subtotal, select the sort group in the Group list and the subtotal 
in the SubTotals list, and then edit the subtotal using the options on the 
right. To edit a grand total, select Entire Report in the Groups list and the 
grand total in the Grandtotals list before editing the options.
If you have numeric fields in your database you can choose to Count the 
number of records or subtotal the Sum of a numeric field by selecting the 
subtotal Type and the field to Calculate On. Only numeric and calculated 
fields appear in the Calculate On drop-down list.
• To remove a sort group from the SubTotals list, select it and then 

click the Remove SubTotal button below the SubTotals list. 
• To remove a sort group from the Grandtotals list, select it and then 

click the Remove Grandtotal button below the Grandtotals list. 
After you finish editing your totals, click OK.
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Defining a Custom Report Filter
In the Filters dialog, you can define a filter for the report. To view the 
Filters dialog, open the Data Management menu and choose Filtering or 
click the Report Filters button in the toolbar. 

You can choose a Simple, Standard, or Advanced filter by clicking one 
of the tabs at the top of the dialog. The filters you define for custom 
reports are independent from the filters you define for the database, but the 
procedures for defining filters is very similar. For information about 
defining filters, see “Filtering Records” on page 100.
If you want to use all of your data in the report without filtering, check the 
Display All Records box at the top of the wizard.
After you finish defining your filter, click OK.
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Previewing a Custom Report
You can switch between the design view and the preview of your custom 
report to see how you changes affect the way the report will look.
To switch between the Design view and the Preview, open the View menu 
and choose Design or Preview, or click the Design or Preview buttons in 
the toolbar.

Preview 
Button

Design 
Button  

The Preview toolbar allows you to navigate the pages of the report, change 
the viewing options, and print the report. 

Printing a Custom Report
When you finish defining your custom report, you can print the report. To 
open the Print dialog, open the Report menu and choose Print or click the 
Print Report button in the toolbar.
For information about using the Print dialog, see “Printing Output Forms” 
on page 193.
Click OK in the Print dialog to generate and print your custom report.
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Managing DataBase Files

Overview
Using DataBase, you can backup your files, make a copy of your files, and 
export your data for another program to use. You can also update your 
personal information and your Administrator password.

Backing Up Your Files
To keep from losing valuable information in the case of a computer 
failure, you should backup your database frequently.
Backup files can be created by the database administrator. The 
administrator can also restore the database from a backup.

Creating a Backup
1. Open the database that you want to backup and login as 

Administrator.
2. Open the File menu and choose Backup to open the Save As dialog.
3. Locate and open the drive and folder where you want to save the 

backup file.
We recommend that you save the backup file on a Zip disk, CD, or 
other external storage medium.

4. Enter a name for the backup file if you want to change the name.
DataBase names the backup using the name of the database file and 
the current date. For example, if your database is named Addresses 
and you’re creating the backup file on May 15, 2007, the backup file 
is named DBP_Addresses_20070515.bak.

5. Click Save to save the backup file.
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Restoring From a Backup
Since restoring from a backup file can’t be reversed, it’s a good idea to 
backup the current database before restoring (see “Creating a Backup” on 
page 285).
1. Open any database of which you’re the administrator and login as 

Administrator.
DataBase allows you to restore to any database, even one that you 
don’t have open. This allows you to restore to a database that might 
have corrupted data in it.

2. Open the File menu and choose Restore to open the Open dialog.
3. Locate and open the drive and folder where you saved the backup file.
4. Select the backup file you want to restore from.

DataBase names the backup using the name of the database file and 
the current date. For example, if your database is named Addresses 
and you created the backup file on May 15, 2007, the backup file is 
named DBP_Addresses_20070515.bak.

5. Click Open to open the Browse for Destination Folder dialog.

6. Select the folder where you want to save the restored database.
7. Click OK to open a Warning.

8. Click OK to open the Input Password dialog.

9. Enter your Administrator password and click OK to restore the 
database file from the selected backup.
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Copying Files
You can copy your file to another drive or folder on your computer, or just 
give it a new name. You might want to make a copy of your file if you 
want to create a new file that uses the same data or if you have forgotten 
your Administrator password.
When you copy a file, any changes you made to the old file will be saved 
to the new file.
The easiest way to make a copy of your file is to use the Save As dialog 
(see “Making a Copy of Your File” on page 287). After saving the file, the 
new file is open. To keep from making changes to the new file, open the 
old file again (see “Opening Existing Files” on page 32).

Making a Copy of Your File
You might want to save a copy of your work under a different name or in a 
different location.
1. Open the File menu and choose Save As.

If you have applied a filter or selected records in the Data Table, the 
Save What dialog opens for you to choose one of the following 
options.

All Records Saves all the records in the database
Filtered Records Saves only the filtered records, (see “Filtering 

Records” on page 100)
Selected Records Saves only the records you have selected, (see 

“Selecting a Group of Records” on page 108)

 

NOTE: To avoid losing your database, be sure to save 
a filtered records database or a selected records 
database with a name that is different from the original 
database name.
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Choose the option you want and click OK to open the Save As dialog. 

2. Click the Save in drop-down list to choose the drive and folder where 
you want to save the file.

3. Click in the File name box and type a name for the file.
4. Click Save to open the Select user Mode and Enter Password dialog. 

5. Enter a password between zero and thirty characters.
The password you enter in the Select User Mode and Enter Password 
dialog will be required each time you open the database as the 
administrator.

6. Click OK to save the new database.
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Transferring Files to Another Computer
You can use Windows Explorer to copy data files from one computer to 
another. For information about using Windows Explorer, see your 
Windows documentation.
Each DataBase file uses several support files and folders. To move your 
database to a different computer, you must also move the support files and 
folders.
When you create a new database, the name that you give to the database 
file is also given to a folder. This folder contains most of the supporting 
files for the database. There are also two files in the folder where you 
saved the database that have the following extensions:
• *.esd
• *.dbt

For example, if your file is named Addresses.esd, you would need to 
move the Addresses folder and the following files:
• Addresses.esd
• Addresses.dbt

If you’ve inserted any clipart into the forms in the file, you also need to 
copy the clipart files to the other computer. When you insert clipart into a 
form, DataBase stores only a reference to the file’s location. Copy the 
clipart file into the Clipart folder that is located in the folder that contains 
the supporting files for the database. For more information about clipart, 
see “Adding Clipart” on page 172.
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Creating New Files
To start a new DataBase file, open the File menu and choose one of the 
New options:

New File From Template Choose this option to open a new blank database 
using one of the DataBase templates (see 
“Choosing a Template” on page 44).

New Custom File Choose this option to open a new blank database 
without using a template. You create all of the 
fields, forms, and reports (see “Creating a 
Custom Database” on page 45).

New with Current Design Choose this option to open a blank database using 
your currently opened file like a template. Any 
custom fields, forms, or reports you have added 
to the current file will be used in the new file. If 
you have deleted any forms from the current file, 
they’ll also be removed from the new file.

For more information about creating a new database, see “Setting Up a 
Database” on page 41.

Exporting a File to Another Program
The Export feature lets you copy your DataBase data into a file format that 
can be used by other programs, such as delimited text format.
You can export the entire file, selected records, or selected fields.
If you want to export only some of the records, instead of all of them, filter 
the list so that only the records you want to export are displayed, or select 
the records that you want to export in the Data Table window.
• For information about filtering your list, see “Filtering Records” on 

page 100.
• For information about selecting records in the Data Table window, see 

“Selecting a Group of Records” on page 108.
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Exporting the File
1. Open the File menu and choose Export to open the Export dialog. 

2. Choose the Export Mode.
• All records in the list
• Only those records displayed in the current filter (see “Filtering 

Records” on page 100)
• Only the records selected in the Data Table (see “Selecting a 

Group of Records” on page 108).
3. Choose which fields to export:

• To include a field in the export file, click the field name in the 
Fields in Current File list and then click the Add button.

• To include every field in the current database, click the Add All 
button.

• To remove a field that is already selected, click the field name in 
the Fields to Export list and then click the Remove button.

• To remove all of the fields from the Fields to Export list, click 
Remove All.

4. Click OK to open the Save As dialog. 
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5. Choose the drive and folder where you want to store the exported file 
from the Save in list.

6. Type a name for the file in the File name box.
To make sure that the export file will be compatible with the other 
program, the file name should contain eight characters or less, with no 
spaces. For example, name the file mylist instead of myaddresses.

7. Use the Export type box to choose the format of the export file.
Unless you choose a different format, DataBase exports in a Quote 
and Comma Separated Variable (*.csv) format, which works well in 
most cases. Choose the export format based on the software you’re 
going to use to read the exported file. Check that program’s 
documentation to see what formats it accepts.

8. Click Save to export the current database.

Deleting Files
Each DataBase file uses several support files and folders. To delete your 
database, you must also delete the supporting files and folders.
When you create a new database, the name that you give to the database 
file is also given to a folder. This folder contains most of the supporting 
files for the database. There are also two files in the folder where you 
saved the database that have the following extensions:
• *.esd
• *.dbt

For example, if your file is named Addresses.esd, you would need to 
move the Addresses folder and the following files:
• Addresses.esd
• Addresses.dbt

Deleting the Files
1. If DataBase is running, make sure the file you want to delete is not 

open.
2. Open Windows Explorer and locate the file you want to delete.
3. Select and delete the files and folders.
For more information about using Windows Explorer, see your Windows 
documentation.
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Managing Settings and Preferences

Overview
Using DataBase, you can update your personal information and your 
Administrator password. You can also define program preferences.
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Updating Personal Settings
To change your user name or correct your license key, open the User 
Management menu and choose Personal Setting.
If you want to change the password you use to login as Administrator, see 
“Changing Your Administrator Password” on page 295.
Changing your personal settings affects the login information for all 
database files, so DataBase needs to temporarily close the open database 
before opening the Personal Settings dialog. 

Your current user name appears in the Old User Name box. Enter your 
new user name in the New User Name box. Your user name must be 
between one and twenty characters and can include only letters, hyphens, 
or underscores.
Your current company name appears in the Old Company Name box. 
Update your company name by typing in the New Company Name box.
To update your license key, click the Change License Key button to open 
the Change License Key dialog. 

For security purposes, your current license key doesn’t appear in the 
dialog. To save the new license key, click OK to return to the Personal 
Settings dialog.
When you finish updating you personal settings, click OK and login to the 
database that was previously opened.



DataBase Professional Managing Settings and Preferences   •   295

Changing Your Administrator Password
You can change your Administrator password after you login to the 
database as Administrator. If you can’t login to the database because you 
forgot your password, login as a Regular user and make a copy of the 
database. You can enter a new password when you create the new database 
(see “Making a Copy of Your File” on page 287).

To Change the Administrator Password
1. Open the database to which you want to change the password and 

login as Administrator.
2. Open the User Management menu and choose Change Admin 

Password to open the Change Admin Password dialog.

3. Enter your current Administrator password in the Please enter old 
password box.

4. Enter a new password in the Please enter new password box.
5. Enter the new password again in the Please reenter new password 

box.
6. Click OK to save the new password.
The new password you enter in the Change Admin Password dialog will 
be required each time you open the database as the administrator
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Updating Missing Information
Each time you start the program, DataBase checks your license 
information. If the license information can’t be found, a dialog appears 
allowing you enter you user name, company name, and license key. 

This can be caused by a number of different reasons:
• If you’re using Windows XP or NT, each user profile is required to 

separately enter the license key before the program can be used by 
that user profile. This allows multiple users to use the same computer 
with their own separate licenses.

• If you recently restored your registry settings, the license information 
might have been removed.

• If you recently installed or uninstalled a program, the license 
information might have been altered or deleted.

Enter your user name, company name, and license key in the boxes and 
then click OK to save the information and start the program.
For more information about entering your license key, see “Identifying 
Your License” on page 20.
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Changing Program Preferences
You can change the color settings to use your system colors instead of the 
colors that come standard with DataBase. You can also choose the data 
entry and display format of date fields. If you want to restore a helpful 
message that you turned off, check the box in the Message tab.

Changing the Color Settings
1. Open the File menu and choose Preferences to open the Preferences 

dialog. 

2. Click the View tab to display the view preferences.
3. Check the Use System Color Settings box.

If you want to use the colors that come standard with DataBase, 
uncheck this box.

4. Click OK.
You can change your system colors using the Windows Display Properties 
dialog (see your Windows documentation).
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Changing Date Field Preferences
Although date fields print in your system-defined format, the data entry 
format can be changed to match your preferred method for entering dates.
1. Open the File menu and choose Preferences to open the Preferences 

dialog. 

2. Click the View tab to display the view preferences.
3. Choose your preferred date format from the Date data entry and 

display format drop-down list.
• To enter the month before the day of the month, choose 

MM/DD/YYYY.
• To enter the day of the month before the month, choose 

DD/MM/YYYY.
4. Click OK.
You can change the printed output for dates using the Windows Control 
Panel (see your Windows documentation).
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Viewing Helpful Messages
Helpful Messages are a feature of DataBase designed to assist you in the 
functions of the program. These are popup windows with tips about using 
the program and additional information about how to use the feature. 
1. Open the File menu and choose Preferences to open the Preferences 

dialog. 

2. Click the Message tab to display the message preferences.
3. Check the Turn on Helpful Message box.

If you don’t want to display a helpful message, uncheck the box.
4. Click OK.

To Turn Off Helpful Messages
When a Helpful Message appears, the option to turn off the message is 
available at the bottom of the message. To turn off the helpful message, 
check the box at the bottom of the message and click OK.
If you want to turn off all Helpful Messages, uncheck the box on the 
Messages tab.
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Updating DataBase

Overview
MySoftware periodically improves DataBase—adding features, making 
changes based on customer requests, and fixing problems. When these 
updates (also known as patches) are available to you, Avanquest Update 
allows you to quickly download and install these updates and program 
patches.
Avanquest Update provides you with a list of available downloads, 
allowing you to update everything or choose the updates that you want.
We recommend running Avanquest Update immediately after installing 
DataBase, to check for updates that weren’t included with your version.
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Running Avanquest Update
The Update Download Wizard walks you through the process of updating 
DataBase.
1. Make sure your computer is connected to the Internet. 

If you access the Internet using a modem, you should already be 
dialed in, or your browser should be set up to automatically dial in.

2. Start DataBase.
3. Open the Help menu and choose the Update Software to start the 

Update Download Wizard.
4. Click Next to search for available updates.
5. Click Next to view a list of available updates.

If no updates are available, click Finish to close the Wizard.
6. Check the box next to the updates that you want to download and 

install.
7. Click Next to download the selected updates.
8. Click Install when the download is completed.
9. Click Finish and follow the on-screen instructions to install the 

downloaded updates.
After installing the updates, you might be asked to restart your computer. 
After you’ve restarted your computer (if necessary), the changes will 
appear in DataBase the next time you run the program.
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Automatically Checking for Updates
You can set DataBase to check for updates at regular intervals when 
you’re connected to the Internet.
1. Open the Help menu and choose the Configure Updates to open the 

Update Configuration dialog. 

2. Chose one of the options:
• Automatic downloads available updates at the interval you 

choose, and then notifies you to install them. 
To determine how often to automatically check for updates, 
choose the option you want from the Check updates every drop-
down list.
To have the Updates Wizard assist you with the updates, check 
the Use the Wizard for downloading updates box.

• Manual doesn’t check for updates unless you begin the process 
(see “Running Avanquest Update” on page 302).
If you chose the Manual option, Avanquest Update won’t use 
your selections under the Automatic option.

3. Click OK.
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Helpful Hints and Troubleshooting

Using Shortcuts
There are often several ways to perform tasks in DataBase. The user’s 
guide and online help describe the most straight-forward way to perform a 
program option, but might not describe the fastest way.
DataBase offers toolbars, shortcut menus, and keyboard shortcuts so you 
can quickly perform some common tasks.

Using Toolbars
The easiest way to speed up your work is to use the toolbar buttons. Most 
of the instructions tell you how to perform a task using the menu bar at the 
top of the window. However, there are toolbar buttons for some features 
that can save you a few mouse clicks. 
When available, toolbar buttons are shown next to the instructions for the 
task.

To Set Toolbar Options
You can turn the toolbar on or off. All of the features available in the 
toolbar can be accessed from the menus. You can also turn the ToolTips on 
or off.
1. Open the View menu and choose Toolbar to open the toolbar dialog.
2. Choose the options you want.
3. Click OK.
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Using Shortcut Menus
Shortcut menus are another way to speed up your work. Shortcut menus 
open when you right-click areas of the screen.
Different shortcut menus open, depending on where you click.  

To choose an item from a shortcut menu, click on it.

Using Keyboard Shortcuts
Keyboard shortcuts offer quick ways to perform some tasks without using 
your mouse. For example, to open another DataBase file, you can press 
CTRL+O (hold down the CTRL key and press O) instead of opening the File 
menu and choosing Open.
Several DataBase keyboard shortcuts are listed below. Some of these 
shortcuts are the same as for other Windows programs. 

Create a new DataBase file using a template CTRL+N

Open an existing DataBase file CTRL+O

Save the current file CTRL+S

Undo the last action CTRL+Z

Create a new record in your database CTRL+R

Set the display and printing options for the Data Table CTRL+K

Preview the Data Table in Portrait orientation CTRL+T

Preview the Data Table in Landscape orientation CTRL+L

Copy the selected text or object CTRL+C

Cut the selected text or object out of the form CTRL+X

Paste the Cut or Copied item into a new location CTRL+V

Use the Ditto Field feature CTRL+D

Open the Find dialog CTRL+F

Find the next occurrence F3

Open the Replace dialog CTRL+H

Exit DataBase CTRL+Q
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Form Design Hints

Adding Curved Lettering to Your Form
You can add special effects to your forms by taking advantage of the OLE 
capability of DataBase. For example, you can add a Microsoft WordArt 
object to your label and edit it right on your form design.
For more information about adding OLE objects to your forms, see 
“Adding Objects From Another Program” on page 181.

Adding Backgrounds or Watermarks
Place a background image on your form. For information about adding a 
background image, see “Creating a Background Image” on page 170.
When adding backgrounds or imitation watermarks, make sure that the 
text or graphic you’re using is a light enough color that it doesn’t interfere 
with the foreground objects on your label. You can lighten an image using 
the Advanced Configuration dialog (see “Adjusting the Brightness of 
Clipart” on page 175).
You can have greater control of background images on your label by 
adding the text or graphic you want to use for the background, and then 
sending it to the back of the object stacking order. For information about 
the object stacking order, see “Changing the Object Stacking Order” on 
page 145.

Calculating a Percentage
When you want to display a numeric value as a percent, you can create a 
numeric field using a Percent Output Format. The value you enter in the 
numeric percent field will appear as a percent in the print out. 
When you want to use a numeric percent field in a calculated field 
formula, you need to create a formula that will calculate the percent value. 
For example, if you wanted to create a field that calculates the total loan 
amount using simple interest, you could follow the steps below.

Only the database 
administrator can create 
new fields and modify 
their properties.

 
1. Create a Currency field for the principal.
2. Create a Numeric field for the interest rate with a Percent Output 

Format.
3. Create a Calculated field for the total loan amount with a Currency 

Output Format.
4. Create the following formula to calculate the total loan amount:

(<<Principal>>*(<<Interest Rate>>/100)) 
+<<Principal>>
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Changing the Background Color of Your Form
If you have a color printer, you can create colored labels on white stock. 
Simply add a rectangle or circle to your label, size it to fit your label, and 
then change the fill color to the color you want the label to be.
Make sure the rectangle or circle is at the back of the object stacking order.

NOTE: If part of your label is outside of the printable area 
for your printer, that part of the label won’t be colored by 
your printer. To keep the rectangle or circle within the 
printable region, right-click it and choose Border from the 
shortcut menu.

 

• For more information about adding rectangles or circles to your form, 
see “Drawing Rectangles and Circles” on page 177.

• For information about the object stacking order, see“Changing the 
Object Stacking Order” on page 145.

• For information about adding a background image to your form, see 
“Adding a Background Image” on page 170.

If the Outline of the Form Disappears...
If you place a picture or filled drawing object on your form that extends 
beyond the edge of the form, it might cover up the edge of the form.
To define the edge of a form that is obscured:
1. Temporarily move or remove the picture or drawing object that hides 

the form edge.
2. Draw lines, rectangles, or circles on the edge of the form.

Be sure to choose None for the fill color for any of these drawing 
objects.

3. Restore the picture or drawing object that you removed in Step 1 to 
your form.

4. Open the Format menu and choose Placement > Send to Back.
The drawing objects that you added in step 2 will define the edge of 
the form on top of the object you restored in step 3.

5. Finish designing your form.
6. Delete the drawing objects that you added in step 2, so that they won’t 

print on your form.
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If Clipart Doesn’t Appear on the Form…
When you add clipart to a form, DataBase remembers the location of the 
clipart file, but doesn’t actually add it to your DataBase file. This saves 
disk space, but DataBase won’t be able to find the clipart file if it’s moved 
or if you copy your database to another computer without also copying the 
clipart.
If you’re the database administrator and you created a shared form, you 
should save the image file in the database clipart folder when adding it to 
the form. 

If you click Yes, a copy of the clipart file will be placed in the database 
clipart folder. The original file will remain unchanged.

If Clipart is Unreadable…
If you have selected clipart from a graphic format that isn’t supported by 
DataBase, it might not display or print properly. DataBase supports BMP, 
RLE, DIB, GIF, TIF, PCX, DCX, WPG, JPG, IMG, TGA, WMF, and EPS 
graphic formats (LZW encoded TIF files aren’t supported).
If you want to use clipart of an unsupported format, try to convert it to one 
of the supported formats with a graphics conversion program.

If Colors Don’t Look Right…
Clipart colors might not appear accurately on your screen. DataBase uses 
the color palette of the original clipart to draw the screen images, if your 
video driver will support it. If you only have a 256-color video driver, only 
256-colors will be displayed. Check the documentation that came with 
your video card and your monitor. You might be able to change your 
system settings to display more colors using the Windows Control Panel.
Likewise, a picture will print on your labels using the color palette of your 
printer. If your printer has a 256-color palette, then a 256-color picture will 
print accurately.
Screen colors are usually different than printed colors. The colors on your 
monitor are created with red, green, and blue light, while the colors on a 
printed page are created with dye or pigments. The best way to know what 
the colors will look like on printed output is to actually print on paper.
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If Objects are Difficult to Select…
Objects might be difficult to select if they’re overlapping, or if one object 
is placed inside of another.

To Select Overlapping Objects
Objects which overlap or are touching each other might be difficult to 
select. You might notice that the most recently placed object is easiest to 
select. This is due to the stacking order of the objects. Each new object is 
placed in a layer above the other objects on the screen (see “Changing the 
Object Stacking Order” on page 145).

To Select an Object Within Another Object
You might not be able to select an object that has been placed within a 
larger object you have already selected. This might be true even if the 
smaller object is stacked in a layer above the larger object. To select the 
smaller object, you’ll need to deselect the larger object by clicking on the 
work area away from the object.
If you would like to select both objects at the same time:
1. Move the larger object to a layer below the smaller object.
2. Cancel the selection of the larger object by clicking on the work area 

away from the object.
3. Select the smaller object, and then hold the SHIFT key down and click 

the larger object.
You can now move both objects as a group.

If Toolbar Buttons and Menu Options are Dimmed…
Whenever a tool or feature isn’t available for you to use with a selected 
object, the related button or menu item is dimmed. For example, if you’re 
in the Data Table window, the Change Form Size option in the Format 
menu is dimmed, since you need to be in the Output Forms window to 
open the Change Form Size dialog.

If a Text Box is Too Big and You Can’t Resize it…
A text box is designed to show all of the text that has been entered into it. 
If there seems to be a lot of blank space at the bottom of a text box, and 
you can’t reduce the height of the box, you might have added blank lines 
by pressing the ENTER key.
To remove the blank lines allowing you to resize the text box, click in the 
text box to place the cursor at the bottom of the text box, and then press 
BACKSPACE until the cursor reaches the end of your text. This deletes the 
extra lines and allows you to resize the text box.
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Printing Hints

Printing Return Address Labels
To print return address labels using DataBase:
1. Choose or create a form that has your return address entered into a 

text box (see “Adding a Return Address” on page 159).
2. Open the File menu and choose Print > Active Output Form to open 

the Print dialog.
3. Set the Print Range to print only one record by entering the same 

record number in both the From box and the To box. For example, 
From 1 To 1.

4. Set the Number of Copies to the number of labels you want to print.
If you’re printing a full page of labels, enter the number of labels on 
the page.

5. Click Print to begin printing.

Printing Multiple Copies of One Label
1. Open the File menu and choose Print > Active Output Form to open 

the Print dialog.
2. Set the Print Range to print only one record by entering the same 

record number in both the From box and the To box. For example, 
From 22 To 22.
If you have already selected the record in the Data Table window, you 
can choose Selected Records in Data Table, instead.

3. Set the Number of Copies to the number of labels you want to print.
If you’re printing a full page of labels, enter the number of labels on 
the page.

4. Click Print to begin printing.
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Resuming an Interrupted Print Job
If your printer jams or you run out of labels, you can resume printing from 
where you left off.
1. Open the Edit menu and choose Find Record to find the last record 

that was printed correctly (see “Finding a Specific Record” on page 
87).

2. Open the Data Table window by clicking the Data Table tab.
3. Click the record number for the first record you need to print. Then, 

hold down the SHIFT key and click the number for the last record you 
need.
Every record between the first and last record you clicked is 
highlighted in the Data Table.

4. Open the File menu and choose Print > Active Output Form to open 
the Print dialog.

5. Set the Print Range to Selected Records in the Data Table.
6. Click Print to resume printing.

Calibrating Your Printer for CD Labels
CD labels are different from other types of labels, since there is more than 
one type of label on each sheet. DataBase defines only two large 
rectangular labels per sheet that includes the CD and spine labels within it.
If you need to re-calibrate your laser or ink-jet printer for printing on CD 
labels, use a straight-edge, such as a ruler, to draw a line to extend the right 
edge of the lowest spine label. 
Print the alignment grid on this sheet. Use the bottom of the lowest spine 
label for the vertical measurement and the line you have drawn for the 
horizontal measurement (see “Calibrating Sheet-Feed Printers” on page 
199).

Updating Printer Drivers
If you need to update your printer driver, contact your printer’s 
manufacturer or check their Web site. There are a number of places to help 
you get current printer drivers:
• Microsoft’s Web site: http://www.microsoft.com 
• The Web site of the printer’s manufacturer
• Local computer stores
To install a printer driver, use the Windows Control Panel (see your 
Windows documentation).

http://www.microsoft.com
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Using Sheet-Feed Labels
When printing with a sheet-feed printer, keep in mind that there is a 
printable and a non-printable region on a page. The non-printable region 
extends about .125" to .5" all around the edge of the page. The width of the 
non-printable region varies from printer to printer.
To help you see if objects are within the printable area, the Preview 
Window displays a dotted line around the boundary of the printable region 
(see “Previewing Your Form” on page 195).
If some of your objects are being clipped by your printer, use the Output 
Forms window to add a border (see “To Place a Border Around the Edge 
of Your Form” on page 177).
Borders are designed to fit within the printable area of a label. Move your 
objects, so that they’re inside of the border. The border can be deleted after 
you have moved the other objects if you don’t want it to print.

Using Photocopier Labels
Another common problem is using photocopier labels in your printer. 
Sheet-feed printers need a margin at the top and the bottom of the label 
sheet to make room for the non-printable region. The label sizes included 
with DataBase are designed for laser and ink-jet printer labels, which 
includes this margin. The program also automatically calculates the 
number of labels on a page based on sheet-feed label styles. If the number 
of labels per page doesn’t match, or if there is no margin at the top and 
bottom of the page, you’re probably using photocopier labels.
Also, photocopier labels aren’t designed for the heat and bending of laser 
and ink-jet printers; they might peel off and jam your printer.

Using Form-Feed Labels
If rows of labels are being skipped when you print, you probably have an 
old or defective printer driver. 
To fix the problem, contact your printer manufacturer or Microsoft and 
obtain a new printer driver. Libraries of many printer drivers are also 
maintained on many online services (see “Updating Printer Drivers” on 
page 314). 
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If Data Doesn’t Print…
There are several reasons why data might not print on your forms.
• If everything is printing except a particular field, make sure that all of 

the fields that you want to print are placed on the form that appears in 
the Output Forms window.

• Make sure that you’re printing the correct form. For example, you 
might have chosen to print the Data Entry Form instead of the Active 
Output Form.

• If entire records didn’t print, you might have set filter criteria that 
didn’t include those records (only displayed records can be printed). 
See if the records are displayed by opening the Edit menu and 
choosing Find Record, or by browsing the Data Table. If they aren’t 
displayed, change the filter criteria to include the records you want 
(see “Filtering Records” on page 100).

• If records weren’t included in the Print Range entered in the Print 
dialog, they won’t print.

• If data is cut off from the bottom of the printout, the data might extend 
into the non-printable region for the sheet. Because of mechanical 
limitations, every printer has some areas on a page where it can’t 
print. The size of the non-printable area depends on your type of 
printer. You can work around this by reducing the number of records 
that DataBase prints on each sheet.

To Reduce the Number of Records that Print on a Sheet
1. View your form design by clicking the Output Forms tab.
2. Open the Format menu and choose Change Form Size. 

The number of records in the current form is listed in the Sheet 
Preview box.

3. Click the Custom button in the Change Form Size dialog to create a 
custom form size.

4. Enter a name for the custom form size in the Description box.
5. Reduce the Down value in the Number of Labels on Sheet box by 

one.
For example, if the original label printed two across and seven down, 
the new label should print two across and six down.

6. Click OK to return to the Change Form Size dialog.
7. Click OK to close the Change Form Size dialog.
8. Print a test page to see if your data prints correctly.
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If Postal Barcodes Don’t Print…
There are two reasons why postal barcodes might not print:
• There must be a postal barcode field on the form that appears in the 

Output Forms window (see “Adding a Postal Barcode” on page 184).
• A postal barcode won’t print unless the address contains a ZIP+4 

Code (nine digits). If the ZIP Code only has five digits, the postal 
barcode won’t print.

If Color Doesn’t Print or Prints Incorrectly…
If you’re having problems printing color, you might need to update your 
printer driver. Check with the manufacturer of your color printer to make 
sure you have the most current version of the printer driver.

If Grays are Printed as Black…
On some black and white printers clipart grays are printed correctly while 
drawing objects created with DataBase print only in black and white. This 
might be a problem with your printer driver, or you might just need to 
change your graphics printing options.
• For information about the graphics printing options for your printer, 

see your printer’s documentation.
• For information about updating your printer driver, see “Updating 

Printer Drivers” on page 314.

If Data is Printed with Blank Spaces Between 
Fields…
If your data fields are placed next to each other in the Output Forms 
window, your form might still print with blank space around the fields. 
This is because the information you enter into a field might not be the 
same length in every record. For example, if you were making a list of 
mailing labels, some people will have long first names (like Josephine) 
while others will have short first names (like Sal). Also, you might leave 
one or more fields blank, such as a business title or second address line.
To suppress blank lines and spaces between fields, use an alignment box. 
For each record, the lengths of the data fields are adjusted to match the 
length of the data entered, and a single space is placed between each data 
field and text box on a line. If a line contains no information, it’s removed 
and the lines below are moved up to fill the space (see “Using an 
Alignment Box” on page 150).
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“Unable to set the printer for the currently-selected 
label stock” message
This message appears for one of two reasons.
• There is a mismatch between the type of printer that was last used for 

printing and the type of form that is selected now. For example, if you 
choose to print your data on a pin-feed label, but you used a laser 
printer the last time you printed something, this message appears.

• DataBase doesn’t recognize that you’re using a pin-feed printer. This 
occurs because some printer drivers don’t send feedback to DataBase, 
and DataBase chooses a laser printer type in this case. 

To fix the problem, do one of the following things:
• Choose another printer.
• Choose a different type of form.
• Make sure that the type of printer is the same as the form type, and 

then print your data anyway.

To Choose Another Printer
1. Click OK in the message box.
2. Choose another printer from the Name drop-down list in the Print 

dialog.
If no other printers are listed, then there are no other printers installed 
in Windows. For information about installing printers, see your 
Windows documentation.

3. Click Print to print your data.

To Choose A Different Form
1. Click OK in the message box.
2. Click Cancel in the Print dialog.
3. Click the Output Forms tab to view the Form Library in the Output 

Forms window.
4. Choose a form that is designed for the type of printer you’ll use.
5. Open the File menu and choose Print > Active Output Form to print 

your data in the new form.
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File Management Hints

Using a Customized Template With a New File
Rather than spend time creating a new form design, you might want to use 
a custom form that you have designed as a template. Open your custom 
database and then open the File menu and choose New With Current 
Design. A new database file is created with the design from your custom 
template in place. You can add records to your new database.

Making a Backup of Your DataBase File
To make a backup copy of your DataBase file on your computer or on a 
removable disk, open the File menu and choose Backup, and then choose 
where you want to save the backup file.
Only the database administrator can create a backup of the database.
For more information about making a backup copy of your DataBase file, 
see “Backing Up Your Files” on page 285.

Quitting the Program
To close the program, open the File menu and choose Exit.
Your data and designs are automatically saved while you work with the 
program.

Uninstalling the Program
To remove the DataBase program from your computer:
1. Open the File menu and choose Exit to exit DataBase.
2. Click the Windows Start menu and choose Settings > Control Panel 

to open the Windows Control Panel.
3. Double-click the Add/Remove Programs icon to open the Add/

Remove Programs dialog.
4. Choose DataBase Professional from the list of programs.
5. Click the Add/Remove button.
The program files for DataBase are removed from your computer, but 
your database files aren’t. If you reinstall the program later, your files will 
still be available to open.
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If You Forgot Your Administrator Password...
You can’t retrieve a forgotten administrator password.
If you can’t login to the database because you forgot your password, login 
as a Regular user and make a copy of the database in another folder or 
using another name. You must enter a new password when you create the 
new database (see “Making a Copy of Your File” on page 287).
You’ll need to recreate your shared form designs and shared reports. In 
addition, personal form designs and personal reports from other users will 
no longer work with the copied database and will need to be recreated.

NOTE: Don’t save the copy of your database in the same 
folder and using the same name as the original database, as 
this might cause you to lose all of your data.

 

If a DataBase File Won’t Open...
There are several reasons why a DataBase file won’t open:
• Someone Else has the File Open (see below).
• The File is Read Only (see page 321).
• There is a Conflict with a Shared Program File or System File (see 

page 321).
• Some of the Supporting Files Can’t be Found (see page 321).
• One or More of the Data Files Have Been Corrupted (see page 322).

Someone Else has the File Open
DataBase is designed to be used simultaneously by more than one user. 
However, when the Administrator is using the database, no other users can 
be using it at the same time. If you want to open a database as the 
Administrator, make sure that no other users have the database open. If 
you want to open the database as a Regular User, make sure that the 
Administrator doesn’t have the database open.



DataBase Professional Helpful Hints and Troubleshooting   •   321

The File is Read Only
To open a DataBase file, you need to be able to save your work in the 
location where the file is currently saved. If the file has been saved on a 
CD or on a network drive on which you don’t have write access, the file 
won’t open. Before you can open the file, you need to transfer the main 
DataBase file and all of the supporting files to a drive on your computer or 
network where you’re able to save changes (see “Transferring Files to 
Another Computer” on page 289).

Some of the Supporting Files Can’t be Found
When you save a DataBase file, the program generates the main file and 
several supporting files that work together to create your database, forms, 
and reports. If any one of these files has been renamed, moved, or deleted, 
you won’t be able to open the database. If you’ve used Windows Explorer 
or MyComputer to alter the main file or one of the supporting files, restore 
the file to the name and location where it was before you altered it. If 
you’ve deleted it, you might be able to restore it from your Windows 
Recycle Bin. For more information about the supporting files for 
DataBase, see “Transferring Files to Another Computer” on page 289. If 
you aren’t able to restore the supporting files, you can import your data 
from the main file into a new file. This will allow you to still use your 
data, but your forms and reports will be lost. For more information about 
importing data, see “Importing Data From Other Programs” on page 63.

There is a Conflict with a Shared Program File 
or System File
If you have a conflict with a shared program file or system file, you might 
need to uninstall and reinstall the program. For information about 
uninstalling DataBase, see “Uninstalling the Program” on page 319.
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One or More of the Data Files Have Been Corrupted
Typically, database corruption is caused by some kind of interruption in 
the program’s save process. This can occur if there is a power outage or 
power spike while the program is open. Data can also be corrupted if 
another program crashes or Windows shuts down while DataBase is still 
open.
If you can’t open a database or the program crashes when a specific 
database is open, there might be corrupted data in that database.
The best insurance against corrupted data is regular backups of your 
DataBase files. If you suspect data corruption, you can restore your data 
from your backup. DataBase has a built-in backup utility that makes it 
easy to backup and restore your data. For more information, see “Backing 
Up Your Files” on page 285.
If you don’t have a usable backup file, you can import your data into a new 
database. When you create the new database, don’t use the New with 
Current Design option, since this might bring the corruption problem into 
your new database. If you’ve created custom fields in the database, you 
should re-create the same custom fields in the new database before 
importing the data.
• To create a new database, see “Creating New Files” on page 290.
• To import your data, see “Importing Data From Other Programs” on 

page 63.
• To re-create your custom fields, see “Creating a New Field” on page 

54.
If you continue to have corruption problems with the new file, you need to 
export the data to a .csv file and then import the data from the .csv file into 
a new database. For information about exporting data, see “Exporting a 
File to Another Program” on page 290.
If you aren’t able to use DataBase to export your data, you can use 
Microsoft Excel to open your main DataBase file and then save the data in 
a .csv file. When you use Excel to open the main DataBase file, choose the 
All Files (*.*) option in the Files of Type drop-down list. Your main 
DataBase file has an .esd extension. For information about opening and 
saving files using Excel, see your Excel documentation.
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Glossary of Terms

Alignment Box
Alignment boxes keep the fields and text boxes in your forms packed 
together, so that blank fields don’t cause blank lines in your forms. After 
you place an alignment box on your form, you can add text objects to the 
box by clicking and dragging them in. The properties of the alignment box 
affect the properties of the fields and text boxes inside of it.

Aspect Ratio
Aspect ratio is the ratio between the height and width of an object. When 
you maintain the aspect ratio of an object, you keep it from looking 
squeezed or stretched when you resize it. To maintain the aspect ratio of 
clipart or a shape, hold the SHIFT key down when you resize it.

Check Box
Check boxes are placed next to dialog options that you can switch on or 
off. The database administrator can also can add a check box field to the 
database.
• A marked check box either has an X or check mark inside of it. 
• A cleared check box is empty.

Click and Drag
Click and drag is a technique used to move objects or highlight text. 
Position the cursor over the object or text, and then click and hold down 
the left mouse button. Move the cursor to a new position, and then release 
the mouse button.
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Clipart
Clipart refers to pictures or graphics created in another program that can 
be placed on your form. Add clipart to your form in the Edit Data Entry 
Form or Output Forms window. The clipart prints exactly the same with 
every record.

Clipboard
The Clipboard is where Windows temporarily stores information or 
objects you cut or copy, allowing you to paste it into another location. The 
contents of the Clipboard are overwritten each time you cut or copy.

Delivery Point
When DataBase imports records from certain programs, a Delivery Point 
field might be present. The Delivery Point data can be encoded along with 
the ZIP+4 information to form a POSTNET barcode. 
DataBase contains a Delivery Point field that you can match to the 
Delivery Point field from an address list that you import. The Delivery 
Point field is hidden and can’t be edited using DataBase.

Drive Letter
Each of the drives on your computer has a letter of the alphabet assigned 
to it. For example, your floppy drive might be drive A, your hard drive 
might be drive C, and your CD-drive might be drive D. If you aren’t sure 
of the drive letters for your computer, double-click the My Computer icon 
on your Windows desktop. The My Computer folder opens and displays 
the icons and letters for all of your disk drives.

Export
Save your DataBase data in a format that another program can use by 
exporting it. To export your data, open the File menu and choose Export.

Field
A field serves as a place holder in your form for information that can 
change from record to record. Place fields on your Data Entry form in the 
Edit Data Entry Form window. Enter information directly into each field 
in either the Data Entry or Data Table window.

Form-Feed
Form-feed refers to a type of printer that uses a roll or box of paper or 
labels. These printers are sometimes referred to as “pin-feed” or “tractor 
feed.” Dot-matrix and daisy wheel printers are usually form-feed type. See 
also Sheet-Feed.
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Grid
The grid is an alignment tool that helps you place objects in horizontal or 
vertical alignment. The grid can be displayed on the screen as dotted or 
solid lines. You can visually align objects to the grid or have objects 
“snap” to the nearest grid corner when you move them.

Import
When the database administrator imports data from another program into 
DataBase, the records are copied from the selected file and added to the 
end of the current DataBase list. The original file remains unchanged.

Increment
To increment is to increase the value of a number. For example, counting 
1,2,3... is incrementing by 1. You can increment a barcode or other data 
field in either the Data Entry or Data Table window.

Landscape
Landscape is a photographic term used to describe your printer’s page 
orientation. Landscape prints a page so that it’s wider than it’s tall. See 
also Portrait.

Object
An object is an item you can move, resize, add, or remove from a form. 
Objects include fields, clipart, rectangles, circles, lines, text boxes, and 
OLE objects. Work with the objects in the Output Forms window.

OLE
OLE (Object Linking and Embedding) allows you to use objects created in 
other programs in DataBase. You can edit these objects in their original 
format in the Output Forms window of DataBase.

Portrait
Portrait is a photographic term used to describe your printer’s page 
orientation. Portrait prints a page so that it’s taller than it’s wide. See also 
Landscape.

POSTNET Barcode
The POSTNET (Postal Numeric Encoding Technique) barcode was 
developed by the USPS to encode ZIP Code information so that it can be 
read by barcode sorting machines. A POSTNET barcode only prints when 
a record has a ZIP+4 Code. The USPS recommends that you only print 
barcodes when you want to submit for Bulk Mail Presort discounts.
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Printable Region
The printable region is the area where the printer can place information on 
a page. There is a margin on all edges of the paper where the printer can’t 
print. The size of this area varies depending on your printer.

Printer Driver
A printer driver is the software that allows DataBase to communicate with 
your printer. Install a printer driver using the Windows Control Panel.

Record
The data for each item, individual, or company in your database is stored 
in a record. Each database stores a collection of these records. The data for 
each record is stored in a set of fields within the record.

Right-Click
Right-clicking is a time-saving technique that opens a shortcut menu 
related to a button or area in the current window. Position the cursor over 
the item and click on it with your right mouse button. If available, a 
shortcut menu appears. Position the cursor over the shortcut option you 
want, and then click the left mouse button to select the option.

Sheet-Feed
Sheet-feed refers to a type of printer that uses individual sheets of paper or 
labels. Laser and ink-jet printers are sheet-feed type. See also Form-Feed.

Shortcut Menu
When you right-click an object, the menu that opens is called a shortcut 
menu. Select an item from a shortcut menu by clicking on it. 

Template
A Template is blank database with pre-defined fields, designs, and reports.

Text Box
A text box is used to enter text on your form that you want to print exactly 
the same in each record. Place a text box on your form in the Output 
Forms window or in the Edit Data Entry Form window. Edit the text in the 
same window that you use to create the text box.
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Index

A
Access 64, 65
ACT! 64
address

mailing 156
return 159

address fields
aligning on envelopes 203

administrator password 43, 295
advanced

filtering 103
search and replace 95
search to find 91

aligning
addresses on an envelope 203
objects 147, 149
printer 198, 199
text 161

alignment box
adding 150, 166
adding objects to 152
deleting 153
fonts 152
mailing address 156
moving 151
properties 152
sizing 151
text alignment 152
using 150, 317

Approach 64
ASCII text files 64, 65
aspect ratio 173
assigning fields 68
attributes 161

B
background image

adding 170, 170, 309
center image 171
color 310
fit image to label 171
remove 171
replace 171
rotate 171

backup files 287, 319
barcodes

adding 158, 183
color 188
control characters 190
entering data 189
font 188
incrementing 190
POSTNET 184, 189
rotating 188
sizing 188
specifications 186

basics of program 25
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booklets
designing forms 124
headers and footers 166

borders 177
brand 121
brightness and contrast 175
bring forward 145
bring to front 145
built-in help (see online help) 36
buying labels 122

C
calibrating printers 199
cards

designing forms 124
case of text 48
CD labels 314
cells

copy and paste 85
centimeters 128, 148
change form size 121, 122
checkbox field 55
choosing

forms 115
labels 117
new form size 120

circles
adding 177
borders 177
fill color 178
moving 177
outline color 178
outline thickness 178
properties 179
sizing 177

clipart
adding 169
field 74
file formats 172
moving 173
rotating 174
sizing 173
unreadable 311

collating copies 197

color
barcodes 188
data table rows 82
filling shapes 178
improving display 311
lines 176
system 311

color settings 297
columns in data table 81, 82
control characters 190
copying

cells 85
data 83
files 287
forms 118
records 84

corrupted data 322
curved lettering 309
custom file 45
custom form size 122, 199, 316
cutting

cells 85

D
data

barcodes 189
checking for overflow 193
copying between records 83
does not print 316
entering 69, 70, 71, 78, 78
exporting 290
fields 156
filtering records 100
finding 87, 88
importing 63, 64
incrementing fields 86
matching fields 68
replacing 92, 96
sorting 98, 99

data entry form 47
Data Entry window 70
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data table
changing fonts 80
formatting 81
inserting records 85
moving columns 82
options 79
previewing 205, 210
printing 193, 205, 211
properties 206
resizing columns 81
resizing rows 81
row color 82
sorting data 98

Data Table window 78
date settings 298
dBASE 64
deleting

alignment box 153
cells 85
duplicate records 109, 110
fields 158
files 292
form folders 120
forms 120
records 110

delivery point 189
display all records 100
ditto field 83
do not call list 232
do not email list 232
domain name 214
downloading updates 302
drawing objects, adding 169
duplicate record, removing 109, 110

E
earlier version 21
editing OLE objects 182

ellipses
adding 177
borders 177
fill color 178
moving 177
outline color 178
outline thickness 178
properties 179
sizing 177

email
preferences 214
server 214
summary 229
unsubscribe 232

email message
copying 104, 220
deleting 104, 221
renaming 221
spell checker 222

embedding objects 181, 182
entering data 69, 70, 71, 78, 78
envelopes

designing forms 124
printing 201

Excel 64, 66
exporting

files 290
reports 256

F
feed method 121
feed settings, envelope printing 202



330   •   Index DataBase Professional

fields
add 138
adding 156, 157
adding to alignment box 152
changing the printed format 48
deleting 56, 158
entering data 69
fonts 163
formatting text 160
images 74
in data table 79
in text boxes 157
incrementing 86, 167
list 157, 158
name placement 164
new 54
rotating 162
text alignment 161
types 55

files
backup 287, 319
cannot open 320
copying 287
deleting 292
exporting 290
importing 63
naming 42, 287
new 290
new custom 45
new with template 44
opening 32
saving 287
templates 44
transferring 289

fill color 178
filter dialog

advanced filter 103
simple filter 101
standard filter 102

filtering records 100
find dialog

advanced search 91
simple search 89
standard search 90

finding records 87, 88, 92

folders
adding new 118
renaming 117

fonts 80, 152, 163
booklet headers and footers 166

footers 166, 236
form letters, creating 235
form letters, designing 125
form-feed 200, 315, 324
forms

choosing 115
choosing new size 120
copying 118
custom size 122, 199, 316
moving 118
new output form 119
previewing 195
printing 193, 197
renaming 117

FoxPro 64

G
go to 75, 92
graphics

adding 169
file formats 172
moving 173
rotating 174
sizing 173

grid 148

H
headers 166, 236
help

getting 35
online 36
status bar 37
ToolTips 37
user’s guide 35

helpful message 299
history field 248
human readable information 188

I
image fields 74
importing data 63, 64, 68
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inches 128, 148
incrementing

barcodes 190
fields 86, 167

K
keyboard shortcuts 308

L
labels

borders 177
buying 122
CD 314
choosing 117
designing forms 124
form-feed 200, 315
outline disappears 310
sheet-feed 198, 315
skipping 196

lasso 143
layers 145
license key 20, 294
lines

color 176
drawing 176
moving 176
properties 179
sizing 176
thickness 176

linking objects 181, 182
list box fields

adding items to a list box 50
deleting items from a list box 52
moving items in a list box 51

login 20, 43
Lotus 64

M
mail server 214
mailing address 156
manual (see user’s guide) 35
mapping fields 68
margins for envelope printing 203
metric units 128, 148

moving
alignment box 151
between records 75
columns in data table 82
forms 118
lines 176
objects 144
pictures 173
shapes 177

MyContactManager 24, 64
MyDataBase 64
MyLabels 64
MyMailList 64, 184

N
name placement 164
naming a file 42
new

custom file 45
database 42
fields 54
file 42, 290
file with template 44
form 119
record 75

notebox field 55

O
object properties 152, 160, 164, 173, 175
object toolbar 126, 128, 160
objects

aligning 147
embedding 181, 182
group 143
layers 145
linking 181, 182
moving 144
selecting 141, 143, 312
sizing 144
stacking order 145

old version 21
OLE 181, 182, 309
online help 36
opening

files 32
ordering labels 122
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outline
color 178
thickness 178

Outlook 64, 66
output format 48, 56
Output Forms window 126
overflow of data 193

P
page numbers 236

adding to booklets 166
Paradox 64
part number 121
password 43, 295
pasting

cells 85
patches 301
personal settings 294
pictures

adding 169
field 74
file formats 172
moving 173
rotating 174
sizing 173

placement 145
POSTNET barcodes 184, 189
preferences

color settings 297
date settings 298
email 214
messages 299
program settings 297

preserve aspect ratio 173
previewing

data table 205, 210
forms 195
reports 255

previous version 21, 24
printable region 177, 198

printing
aligning printer 198, 199, 199
barcodes 190
data table 193, 205, 211
envelopes 201
forms 193, 197
previewing data table 205, 210
previewing forms 195
previewing reports 255
printer drivers 314
reports 255, 281
skipping labels 196

printouts
choosing (see forms) 115
creating new 129

product barcodes 186
program basics 25
program updates 301
properties toolbar 126, 128, 160
purchasing labels 122

Q
quick arrange 149
quick find buttons 88

R
read-only 320
records

adding 85
copying data 84
deleting 110
filtering 100
finding 87, 88, 92
moving between 75
removing duplicates 109, 110
replacing data 92, 96
selecting 108
sorting data 98, 99
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rectangles
adding 177
borders 177
fill color 178
moving 177
outline color 178
outline thickness 178
properties 179
sizing 177

removing
alignment box 153
blank spaces 150, 166
duplicate records 109, 110
fields 158
form folders 120
forms 120
program 319
records 110

renaming
forms and folders 117

replace dialog
advanced search and replace 95
simple search and replace 93
standard search and replace 94

replacing data 92, 96

reports 248
choosing 242, 258
column headings 247
column width 246
columns 245
copying 243, 259
counting records 251
data 245
date 254
deleting 244, 260
exporting 256
fields 245
filtering records 249
footer 254
header 254
headings 247
image height 246
landscape 245, 269
line spacing 253
margins 253
maximum column widths 246
new 244
notebox fields 248
orientation 245, 269
page layout 244, 269
page number 254
portrait 245, 269
previewing 255
print setup 244, 269
printing 255, 281
readability options 253
record count 251
renaming 243, 259
separator lines 253
sorting records 248
subtotal configuration 250
subtotal titles 250
text wrap 247
title 254
totaling columns 252
wrapping text 247
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resizing
alignment box 151
barcodes 188
lines 176
objects 144
pictures 173
shapes 177

return address 159, 313
rotating

barcodes 188
pictures 174
text 162

row color in data table 82
rows in data table 81
rulers 128

S
save as 287, 319
saving files 287
scan for overflow 194
scheduling updates 303
search for duplicates 109
select all 143
selecting

objects 312
records 108

send back 145
send to back 145
sequencing fields 167
serializing barcodes 190
server domain name 214
sheet-feed labels 198, 315
shortcut menus 308
shortcuts 307
shrink to fit 152, 193
simple

filtering 101
search and replace 93
search to find 89

sizing
alignment box 151
barcodes 188
lines 176
objects 144
pictures 173
shapes 177

skipping labels 196
SMTP 214
snap to grid 148
sorting data 98, 99
specifications for barcodes 186
spell check email 222
squares

adding 177
borders 177
fill color 178
moving 177
outline color 178
outline thickness 178
properties 179
sizing 177

stacking order 145
standard

filtering 102
search and replace 94
search to find 90

status bar 37
support, technical 337
system colors 297

T
technical support 337
templates 44
text boxes

adding 159
adding fields 157
adding to alignment box 152
fonts 163
formatting text 160
return address 159
rotating 162
sizing 312
text alignment 161

text files 64, 65
titles

adding to booklets 166
toolbars 128, 128, 160, 307
ToolTips 37
transferring files 289

U
uninstall program 319
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unsubscribe 232
update download wizard 302
updates

downloading 302
scheduling 303

updating the program 301
upgrading 21, 24
user login 20, 294
user’s guide 35

W
watermarks 309

Z
ZIP+4 Codes 189
zoom 127
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Technical Support Policy

BEFORE CONTACTING TECHNICAL SUPPORT: Please take 
advantage of our free options. Look in the User’s Guide installed with 
your program, the online help in the program, or the Frequently Asked 
Questions (FAQs) in the Support section of our Web site  
(http://www.avanquestusa.com/support). The FAQs might have 
information and helpful hints that are more current than the User’s Guide 
and online help. If the FAQs do not help, you can submit a free email 
request from the main FAQ page.
LIVE TECHNICAL SUPPORT POLICY: Avanquest USA’s goal is to 
provide powerful, low-cost software solutions and services to small 
business users. In order to keep our product costs low, we have chosen not 
to include the cost of Live Technical Support in the price of our software. 
Live Technical Support is a premium service and is available on a pay-per-
minute basis. There is an initial telephone charge for the first ten minutes, 
and an additional charge for each minute after the first ten. Customers will 
not be charged for problems resulting from product defects.
WHEN YOU CALL: Please have your credit card, serial number, and 
version number ready. Your serial number and version number are located 
on the CD and in the software program (open the Help menu and choose 
About).

Technical Support
$24.95 for the first 10 minutes

$2.95 for each additional minute
(925) 474-1701

NOTE: This policy is subject to change without notice. 
Support services will be provided according to the prices, 
terms, and conditions in place at the time the services are 
used.

http://www.avanquestusa.com/support
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